aboutsummaryrefslogtreecommitdiffstats
path: root/recipes/linux/linux-openmoko-devel_git.bb
diff options
context:
space:
mode:
authorDenys Dmytriyenko <denis@denix.org>2009-03-17 14:32:59 -0400
committerDenys Dmytriyenko <denis@denix.org>2009-03-17 14:32:59 -0400
commit709c4d66e0b107ca606941b988bad717c0b45d9b (patch)
tree37ee08b1eb308f3b2b6426d5793545c38396b838 /recipes/linux/linux-openmoko-devel_git.bb
parentfa6cd5a3b993f16c27de4ff82b42684516d433ba (diff)
downloadopenembedded-709c4d66e0b107ca606941b988bad717c0b45d9b.tar.gz
rename packages/ to recipes/ per earlier agreement
See links below for more details: http://thread.gmane.org/gmane.comp.handhelds.openembedded/21326 http://thread.gmane.org/gmane.comp.handhelds.openembedded/21816 Signed-off-by: Denys Dmytriyenko <denis@denix.org> Acked-by: Mike Westerhof <mwester@dls.net> Acked-by: Philip Balister <philip@balister.org> Acked-by: Khem Raj <raj.khem@gmail.com> Acked-by: Marcin Juszkiewicz <hrw@openembedded.org> Acked-by: Koen Kooi <koen@openembedded.org> Acked-by: Frans Meulenbroeks <fransmeulenbroeks@gmail.com>
Diffstat (limited to 'recipes/linux/linux-openmoko-devel_git.bb')
-rw-r--r--recipes/linux/linux-openmoko-devel_git.bb25
1 files changed, 25 insertions, 0 deletions
diff --git a/recipes/linux/linux-openmoko-devel_git.bb b/recipes/linux/linux-openmoko-devel_git.bb
new file mode 100644
index 0000000000..fb9c4f0498
--- /dev/null
+++ b/recipes/linux/linux-openmoko-devel_git.bb
@@ -0,0 +1,25 @@
+require linux.inc
+require linux-openmoko.inc
+
+DEFAULT_PREFERENCE = "-1"
+
+KERNEL_RELEASE = "2.6.29"
+KERNEL_VERSION = "${KERNEL_RELEASE}"
+
+OEV = "oe1"
+PV = "${KERNEL_RELEASE}-${OEV}+gitr${SRCREV}"
+PR = "r1"
+
+SRC_URI = "\
+ git://git.openmoko.org/git/kernel.git;protocol=git;branch=andy-tracking \
+"
+S = "${WORKDIR}/git"
+
+CONFIG_NAME_om-gta01 = "gta01_moredrivers_defconfig"
+CONFIG_NAME_om-gta02 = "gta02_packaging_defconfig"
+CONFIG_NAME_om-3d7k = "om_3d7k_defconfig"
+
+do_configure_prepend() {
+ install -m 644 ./arch/arm/configs/${CONFIG_NAME} ${WORKDIR}/defconfig-oe
+ cat ${WORKDIR}/defconfig-oe.patch | patch -p0 -d ${WORKDIR}
+}