aboutsummaryrefslogtreecommitdiffstats
path: root/recipes/linux/linux-openmoko_2.6.28.bb
diff options
context:
space:
mode:
authorMartin Jansa <Martin.Jansa@gmail.com>2010-05-25 14:36:33 +0200
committerMartin Jansa <Martin.Jansa@gmail.com>2010-05-26 13:02:43 +0200
commitbab8cda39ab1cecec1119a75596b168b38bc8014 (patch)
tree6053b349914c51e468667067fa02c45381a3d381 /recipes/linux/linux-openmoko_2.6.28.bb
parent351c813baedcebd8b91cb95aa0038fd0ff2a17dc (diff)
downloadopenembedded-bab8cda39ab1cecec1119a75596b168b38bc8014.tar.gz
linux-openmoko: rename recipes to common PN_PV scheme, cleanup versioning
* move DESCRIPTION to .inc * remove OEV, KERNEL_RELEASE and KERNEL_VERSION, keep KERNEL_* from kernel.bbclass * update distro/machine configs where needed Acked-by: Khem Raj <raj.khem@gmail.com> Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com>
Diffstat (limited to 'recipes/linux/linux-openmoko_2.6.28.bb')
-rw-r--r--recipes/linux/linux-openmoko_2.6.28.bb22
1 files changed, 22 insertions, 0 deletions
diff --git a/recipes/linux/linux-openmoko_2.6.28.bb b/recipes/linux/linux-openmoko_2.6.28.bb
new file mode 100644
index 0000000000..687990b7a3
--- /dev/null
+++ b/recipes/linux/linux-openmoko_2.6.28.bb
@@ -0,0 +1,22 @@
+require linux.inc
+require linux-openmoko.inc
+
+SRCREV = "8c65792a5c83c76d662a617a7c4e1ae8104bb6a5"
+PR = "r1"
+PR_append = "+gitr${SRCPV}"
+
+SRC_URI = "\
+ git://git.openmoko.org/git/kernel.git;protocol=git;branch=stable \
+ file://defconfig-oe.patch;apply=no \
+"
+S = "${WORKDIR}/git"
+
+CONFIG_NAME_om-gta01 = "gta01_moredrivers_defconfig"
+CONFIG_NAME_om-gta02 = "gta02_packaging_defconfig"
+
+do_configure_prepend() {
+ install -m 644 ./arch/arm/configs/${CONFIG_NAME} ${WORKDIR}/defconfig-oe
+ cat ${WORKDIR}/defconfig-oe.patch | patch -p0 -d ${WORKDIR}
+}
+
+