summaryrefslogtreecommitdiffstats
path: root/recipes/linux/linux-palmpre_2.6.24.bb
diff options
context:
space:
mode:
authorStefan Schmidt <stefan@datenfreihafen.org>2009-09-24 23:54:31 +0000
committerStefan Schmidt <stefan@datenfreihafen.org>2009-09-25 00:17:02 +0000
commitde00ea5152804f562b47bd9171375eb64519c49d (patch)
treeac8456bc3cf18c96383fa46a19fe0b660b5f940e /recipes/linux/linux-palmpre_2.6.24.bb
parenta22f66e2c362343922900d0d5443d423a028d267 (diff)
downloadopenembedded-de00ea5152804f562b47bd9171375eb64519c49d.tar.gz
linux-palmpre: Add kernel recipe for the Palm Pre.
We use a standard 2.6.24 as base and apply the palm patch on top of it. That should give us the identical kernel. (hope dies last) :) The output still needs to be tested on a real device.
Diffstat (limited to 'recipes/linux/linux-palmpre_2.6.24.bb')
-rw-r--r--recipes/linux/linux-palmpre_2.6.24.bb15
1 files changed, 15 insertions, 0 deletions
diff --git a/recipes/linux/linux-palmpre_2.6.24.bb b/recipes/linux/linux-palmpre_2.6.24.bb
new file mode 100644
index 0000000000..9d5bc20a41
--- /dev/null
+++ b/recipes/linux/linux-palmpre_2.6.24.bb
@@ -0,0 +1,15 @@
+require linux.inc
+
+DESCRIPTION = "Linux kernel for Palm Pre. Original version of Palm, Inc."
+KERNEL_IMAGETYPE = "uImage"
+
+SRC_URI = "${KERNELORG_MIRROR}/pub/linux/kernel/v2.6/linux-${PV}.tar.bz2 \
+ http://palm.cdnetworks.net/opensource/1.1.0/linux-2.6.24-patch.gz;patch=1 \
+ "
+
+S = "${WORKDIR}/linux-2.6.24"
+
+# We try to build the identical kernel as Palms here, use their defconfig.
+do_configure_prepend() {
+ install -m 0644 ${S}/arch/arm/configs/omap_sirloin_3430_defconfig ${WORKDIR}/defconfig
+}