aboutsummaryrefslogtreecommitdiffstats
path: root/recipes/linux/linux-sakoman_2.6.35.bb
diff options
context:
space:
mode:
authorSteve Sakoman <steve@sakoman.com>2010-09-08 13:33:17 -0700
committerKoen Kooi <koen@openembedded.org>2010-10-12 16:30:14 +0200
commit78dd26f49ef98a28dfce945fce4dd00457e7fb85 (patch)
tree4e4ba224e4e9611576d8faaa67a8ca26ee95eef7 /recipes/linux/linux-sakoman_2.6.35.bb
parentb19bdfd5eeed2633e9fab4447d058577b549546d (diff)
downloadopenembedded-78dd26f49ef98a28dfce945fce4dd00457e7fb85.tar.gz
linux: Add recipe to build from sakoman.com linux repository
Signed-off-by: Koen Kooi <koen@openembedded.org>
Diffstat (limited to 'recipes/linux/linux-sakoman_2.6.35.bb')
-rw-r--r--recipes/linux/linux-sakoman_2.6.35.bb34
1 files changed, 34 insertions, 0 deletions
diff --git a/recipes/linux/linux-sakoman_2.6.35.bb b/recipes/linux/linux-sakoman_2.6.35.bb
new file mode 100644
index 0000000000..424251698c
--- /dev/null
+++ b/recipes/linux/linux-sakoman_2.6.35.bb
@@ -0,0 +1,34 @@
+require linux-sakoman.inc
+
+DESCRIPTION = "Linux kernel for OMAP processors"
+KERNEL_IMAGETYPE = "uImage"
+
+COMPATIBLE_MACHINE = "beagleboard|omap3-multi|overo|omap4-multi|omap4430-panda|omap4430-sdp"
+
+PV = "2.6.35"
+
+S = "${WORKDIR}/git"
+SRCREV = ${AUTOREV}
+SRC_URI = "git://www.sakoman.com/git/linux-omap-2.6.git;branch=omap3-2.6.35;protocol=git \
+ file://defconfig \
+ file://${BOOT_SPLASH} \
+ "
+
+SRCREV_omap4430-panda = "6d019dae0034f66141cdeb355e2ffc71582f4131"
+SRC_URI_omap4430-panda = "git://www.sakoman.com/git/kernel-omap4.git;branch=L24.9;protocol=git \
+ file://defconfig \
+ file://${BOOT_SPLASH} \
+ "
+
+SRCREV_omap4430-sdp = "6d019dae0034f66141cdeb355e2ffc71582f4131"
+SRC_URI_omap4430-sdp = "git://www.sakoman.com/git/kernel-omap4.git;branch=L24.9;protocol=git \
+ file://defconfig \
+ file://${BOOT_SPLASH} \
+ "
+
+SRCREV_omap4-multi = "6d019dae0034f66141cdeb355e2ffc71582f4131"
+SRC_URI_omap4-multi = "git://www.sakoman.com/git/kernel-omap4.git;branch=L24.9;protocol=git \
+ file://defconfig \
+ file://${BOOT_SPLASH} \
+ "
+