aboutsummaryrefslogtreecommitdiffstats
path: root/recipes/linux/linux-smdk2440_2.6.20+git.bb
diff options
context:
space:
mode:
authorDenys Dmytriyenko <denis@denix.org>2009-03-17 14:32:59 -0400
committerDenys Dmytriyenko <denis@denix.org>2009-03-17 14:32:59 -0400
commit709c4d66e0b107ca606941b988bad717c0b45d9b (patch)
tree37ee08b1eb308f3b2b6426d5793545c38396b838 /recipes/linux/linux-smdk2440_2.6.20+git.bb
parentfa6cd5a3b993f16c27de4ff82b42684516d433ba (diff)
downloadopenembedded-709c4d66e0b107ca606941b988bad717c0b45d9b.tar.gz
rename packages/ to recipes/ per earlier agreement
See links below for more details: http://thread.gmane.org/gmane.comp.handhelds.openembedded/21326 http://thread.gmane.org/gmane.comp.handhelds.openembedded/21816 Signed-off-by: Denys Dmytriyenko <denis@denix.org> Acked-by: Mike Westerhof <mwester@dls.net> Acked-by: Philip Balister <philip@balister.org> Acked-by: Khem Raj <raj.khem@gmail.com> Acked-by: Marcin Juszkiewicz <hrw@openembedded.org> Acked-by: Koen Kooi <koen@openembedded.org> Acked-by: Frans Meulenbroeks <fransmeulenbroeks@gmail.com>
Diffstat (limited to 'recipes/linux/linux-smdk2440_2.6.20+git.bb')
-rw-r--r--recipes/linux/linux-smdk2440_2.6.20+git.bb25
1 files changed, 25 insertions, 0 deletions
diff --git a/recipes/linux/linux-smdk2440_2.6.20+git.bb b/recipes/linux/linux-smdk2440_2.6.20+git.bb
new file mode 100644
index 0000000000..b86d970e50
--- /dev/null
+++ b/recipes/linux/linux-smdk2440_2.6.20+git.bb
@@ -0,0 +1,25 @@
+DESCRIPTION = "Linux Kernel for smdk2440 compatible machines"
+SECTION = "kernel"
+LICENSE = "GPL"
+PR = "r1"
+
+GGSRC = "http://www.xora.org.uk/oe/patches/"
+
+SRC_URI = "git://opensource.wolfsonmicro.com/linux-2.6-asoc-ggdev;protocol=git;tag=asoc-merge-0002 \
+ file://0001-Enable-cs8900A-network-device-for-smdk2440-board.patch;patch=1 \
+ file://defconfig-smdk2440"
+
+S = "${WORKDIR}/git"
+
+inherit kernel
+
+COMPATIBLE_HOST = "arm.*-linux"
+COMPATIBLE_MACHINE = "smdk2440"
+
+do_configure() {
+ install ${WORKDIR}/defconfig-smdk2440 ${S}/.config
+ #oe_runmake s3c2410_defconfig
+ oe_runmake oldconfig
+}
+
+KERNEL_RELEASE = "2.6.21"