aboutsummaryrefslogtreecommitdiffstats
path: root/recipes/linux/linux-smdk2443_2.6.20+git.bb
diff options
context:
space:
mode:
authorDenys Dmytriyenko <denis@denix.org>2009-03-17 14:32:59 -0400
committerDenys Dmytriyenko <denis@denix.org>2009-03-17 14:32:59 -0400
commit709c4d66e0b107ca606941b988bad717c0b45d9b (patch)
tree37ee08b1eb308f3b2b6426d5793545c38396b838 /recipes/linux/linux-smdk2443_2.6.20+git.bb
parentfa6cd5a3b993f16c27de4ff82b42684516d433ba (diff)
downloadopenembedded-709c4d66e0b107ca606941b988bad717c0b45d9b.tar.gz
rename packages/ to recipes/ per earlier agreement
See links below for more details: http://thread.gmane.org/gmane.comp.handhelds.openembedded/21326 http://thread.gmane.org/gmane.comp.handhelds.openembedded/21816 Signed-off-by: Denys Dmytriyenko <denis@denix.org> Acked-by: Mike Westerhof <mwester@dls.net> Acked-by: Philip Balister <philip@balister.org> Acked-by: Khem Raj <raj.khem@gmail.com> Acked-by: Marcin Juszkiewicz <hrw@openembedded.org> Acked-by: Koen Kooi <koen@openembedded.org> Acked-by: Frans Meulenbroeks <fransmeulenbroeks@gmail.com>
Diffstat (limited to 'recipes/linux/linux-smdk2443_2.6.20+git.bb')
-rw-r--r--recipes/linux/linux-smdk2443_2.6.20+git.bb42
1 files changed, 42 insertions, 0 deletions
diff --git a/recipes/linux/linux-smdk2443_2.6.20+git.bb b/recipes/linux/linux-smdk2443_2.6.20+git.bb
new file mode 100644
index 0000000000..034137e89c
--- /dev/null
+++ b/recipes/linux/linux-smdk2443_2.6.20+git.bb
@@ -0,0 +1,42 @@
+DESCRIPTION = "Linux Kernel for smdk2443 compatible machines"
+SECTION = "kernel"
+LICENSE = "GPL"
+DEPENDS += "u-boot-mkimage-openmoko-native"
+
+PR = "r1"
+
+GGSRC = "http://www.xora.org.uk/oe/patches/"
+
+SRC_URI = "git://git.kernel.org/pub/scm/linux/kernel/git/torvalds/linux-2.6.git;protocol=git;tag=v2.6.21-rc5 \
+ file://0020-Add-ASoC-S3C24xx-platform-support.patch;patch=1 \
+ file://0021-Add-Neo1973-ASoC-support.patch;patch=1 \
+ file://0022-Add-initial-ASoC-SMDK2440-support.patch;patch=1 \
+ file://0023-Add-ASoC-SMDK2440-support-for-WM8956-codec.patch;patch=1 \
+ file://0034-Export-ac97_dai.patch;patch=1 \
+ file://0036-Move-s3c24xx_i2s_dai-and-add-dma_size.patch;patch=1 \
+ file://0037-Use-dma_size-parameter-and-fix-buffdone-oops.patch;patch=1 \
+ file://0038-Add-smdk2443-s3c2443-ac97-and-wm9710-support.patch;patch=1 \
+ file://asoc-mainline.patch;patch=1 \
+ file://defconfig-smdk2443"
+
+S = "${WORKDIR}/git"
+
+inherit kernel
+
+COMPATIBLE_HOST = "arm.*-linux"
+COMPATIBLE_MACHINE = "smdk2443"
+
+do_configure() {
+ install ${WORKDIR}/defconfig-smdk2443 ${S}/.config
+ oe_runmake oldconfig
+}
+
+do_deploy_append() {
+ ${OBJCOPY} -O binary -R .note -R .comment -S vmlinux linux.bin
+ rm -f linux.bin.gz
+ gzip -9 linux.bin
+ uboot-mkimage -A arm -O linux -T kernel -C gzip -a 30008000 -e 30008000 -n "smdk2443 kernel" -d linux.bin.gz ${DEPLOY_DIR_IMAGE}/uImage-${PV}-${MACHINE}-${DATETIME}.bin
+ rm -f linux.bin.gz
+}
+
+KERNEL_RELEASE = "2.6.21-rc5"