summaryrefslogtreecommitdiffstats
path: root/recipes/linux/linux-wrap-geode_2.6.17.bb
diff options
context:
space:
mode:
authorDenys Dmytriyenko <denis@denix.org>2009-03-17 14:32:59 -0400
committerDenys Dmytriyenko <denis@denix.org>2009-03-17 14:32:59 -0400
commit709c4d66e0b107ca606941b988bad717c0b45d9b (patch)
tree37ee08b1eb308f3b2b6426d5793545c38396b838 /recipes/linux/linux-wrap-geode_2.6.17.bb
parentfa6cd5a3b993f16c27de4ff82b42684516d433ba (diff)
downloadopenembedded-709c4d66e0b107ca606941b988bad717c0b45d9b.tar.gz
rename packages/ to recipes/ per earlier agreement
See links below for more details: http://thread.gmane.org/gmane.comp.handhelds.openembedded/21326 http://thread.gmane.org/gmane.comp.handhelds.openembedded/21816 Signed-off-by: Denys Dmytriyenko <denis@denix.org> Acked-by: Mike Westerhof <mwester@dls.net> Acked-by: Philip Balister <philip@balister.org> Acked-by: Khem Raj <raj.khem@gmail.com> Acked-by: Marcin Juszkiewicz <hrw@openembedded.org> Acked-by: Koen Kooi <koen@openembedded.org> Acked-by: Frans Meulenbroeks <fransmeulenbroeks@gmail.com>
Diffstat (limited to 'recipes/linux/linux-wrap-geode_2.6.17.bb')
-rw-r--r--recipes/linux/linux-wrap-geode_2.6.17.bb22
1 files changed, 22 insertions, 0 deletions
diff --git a/recipes/linux/linux-wrap-geode_2.6.17.bb b/recipes/linux/linux-wrap-geode_2.6.17.bb
new file mode 100644
index 0000000000..3d9b81a936
--- /dev/null
+++ b/recipes/linux/linux-wrap-geode_2.6.17.bb
@@ -0,0 +1,22 @@
+SECTION = "kernel"
+DESCRIPTION = "Linux kernel for PC-Engines WRAP which are \
+Geode SC1100 (i486) based wirless router appliance boards"
+LICENSE = "GPL"
+PR = "r0"
+
+SRC_URI = "${KERNELORG_MIRROR}/pub/linux/kernel/v2.6/linux-${PV}.tar.bz2 \
+ file://defconfig"
+S = "${WORKDIR}/linux-${PV}"
+
+COMPATIBLE_HOST = 'i486.*-linux'
+COMPATIBLE_MACHINE = "wrap"
+
+inherit kernel
+
+ARCH = "i386"
+KERNEL_OUTPUT = "arch/${ARCH}/boot/${KERNEL_IMAGETYPE}"
+
+do_configure_prepend() {
+ install -m 0644 ${WORKDIR}/defconfig ${S}/.config
+ yes '' | oe_runmake oldconfig
+}