aboutsummaryrefslogtreecommitdiffstats
path: root/recipes/linux/linux-x86_2.6.20.bb
diff options
context:
space:
mode:
authorDenys Dmytriyenko <denis@denix.org>2009-03-17 14:32:59 -0400
committerDenys Dmytriyenko <denis@denix.org>2009-03-17 14:32:59 -0400
commit709c4d66e0b107ca606941b988bad717c0b45d9b (patch)
tree37ee08b1eb308f3b2b6426d5793545c38396b838 /recipes/linux/linux-x86_2.6.20.bb
parentfa6cd5a3b993f16c27de4ff82b42684516d433ba (diff)
downloadopenembedded-709c4d66e0b107ca606941b988bad717c0b45d9b.tar.gz
rename packages/ to recipes/ per earlier agreement
See links below for more details: http://thread.gmane.org/gmane.comp.handhelds.openembedded/21326 http://thread.gmane.org/gmane.comp.handhelds.openembedded/21816 Signed-off-by: Denys Dmytriyenko <denis@denix.org> Acked-by: Mike Westerhof <mwester@dls.net> Acked-by: Philip Balister <philip@balister.org> Acked-by: Khem Raj <raj.khem@gmail.com> Acked-by: Marcin Juszkiewicz <hrw@openembedded.org> Acked-by: Koen Kooi <koen@openembedded.org> Acked-by: Frans Meulenbroeks <fransmeulenbroeks@gmail.com>
Diffstat (limited to 'recipes/linux/linux-x86_2.6.20.bb')
-rw-r--r--recipes/linux/linux-x86_2.6.20.bb30
1 files changed, 30 insertions, 0 deletions
diff --git a/recipes/linux/linux-x86_2.6.20.bb b/recipes/linux/linux-x86_2.6.20.bb
new file mode 100644
index 0000000000..3872c50cba
--- /dev/null
+++ b/recipes/linux/linux-x86_2.6.20.bb
@@ -0,0 +1,30 @@
+DESCRIPTION = "Linux Kernel for x86 compatible machines"
+SECTION = "kernel"
+LICENSE = "GPL"
+PR = "r5"
+
+SRC_URI = "${KERNELORG_MIRROR}/pub/linux/kernel/v2.6/linux-${PV}.tar.bz2 "
+
+SRC_URI_append_x86 = "file://i486-defconfig"
+SRC_URI_append_i586 = "file://i586-defconfig"
+SRC_URI_append_i686 = "file://i686-defconfig"
+
+S = "${WORKDIR}/linux-${PV}"
+
+KERNEL_IMAGETYPE ?= "bzImage"
+
+inherit kernel
+
+COMPATIBLE_HOST = "i.86.*-linux"
+
+do_configure_prepend_x86() {
+ install -m 0644 ${WORKDIR}/i486-defconfig ${S}/.config
+}
+
+do_configure_prepend_i586-generic() {
+ install -m 0644 ${WORKDIR}/i586-defconfig ${S}/.config
+}
+
+do_configure_prepend_i686() {
+ install -m 0644 ${WORKDIR}/i686-defconfig ${S}/.config
+}