aboutsummaryrefslogtreecommitdiffstats
path: root/recipes/linux/linux-xilinx-slab_git.bb
diff options
context:
space:
mode:
authorDenys Dmytriyenko <denis@denix.org>2009-03-17 14:32:59 -0400
committerDenys Dmytriyenko <denis@denix.org>2009-03-17 14:32:59 -0400
commit709c4d66e0b107ca606941b988bad717c0b45d9b (patch)
tree37ee08b1eb308f3b2b6426d5793545c38396b838 /recipes/linux/linux-xilinx-slab_git.bb
parentfa6cd5a3b993f16c27de4ff82b42684516d433ba (diff)
downloadopenembedded-709c4d66e0b107ca606941b988bad717c0b45d9b.tar.gz
rename packages/ to recipes/ per earlier agreement
See links below for more details: http://thread.gmane.org/gmane.comp.handhelds.openembedded/21326 http://thread.gmane.org/gmane.comp.handhelds.openembedded/21816 Signed-off-by: Denys Dmytriyenko <denis@denix.org> Acked-by: Mike Westerhof <mwester@dls.net> Acked-by: Philip Balister <philip@balister.org> Acked-by: Khem Raj <raj.khem@gmail.com> Acked-by: Marcin Juszkiewicz <hrw@openembedded.org> Acked-by: Koen Kooi <koen@openembedded.org> Acked-by: Frans Meulenbroeks <fransmeulenbroeks@gmail.com>
Diffstat (limited to 'recipes/linux/linux-xilinx-slab_git.bb')
-rw-r--r--recipes/linux/linux-xilinx-slab_git.bb49
1 files changed, 49 insertions, 0 deletions
diff --git a/recipes/linux/linux-xilinx-slab_git.bb b/recipes/linux/linux-xilinx-slab_git.bb
new file mode 100644
index 0000000000..2900ad9516
--- /dev/null
+++ b/recipes/linux/linux-xilinx-slab_git.bb
@@ -0,0 +1,49 @@
+#Kernel for the xilinx-ml403 board using SecretLabs git tree
+# Copyright (C) 2007, Stelios Koroneos - Digital OPSiS, All Rights Reserved
+# Released under the MIT license (see packages/COPYING)
+SECTION = "kernel"
+DESCRIPTION = "Linux kernel for Xilinx ML403 Virtex 4 fpga board"
+LICENSE = "GPL"
+
+SRCREV = "d7ed933b578d9c4dec0e23a5a6f78c464b31c47c"
+
+PR = "r3"
+PV = "2.6.25+2.6.26+${PR}+gitr${SRCREV}"
+PE = "1"
+
+COMPATIBLE_MACHINE = "xilinx-ml403"
+
+#inherit kernel xilinx-bsp
+inherit kernel
+
+S = "${WORKDIR}/git"
+
+
+FILES_kernel-image = "/boot/zImage.elf"
+
+export OS = "Linux"
+ARCH = "ppc"
+KERNEL_IMAGETYPE = "zImage"
+KERNEL_OUTPUT = "arch/ppc/boot/images/zImage.elf"
+
+SRC_URI = "\
+ git://git.secretlab.ca/git/linux-2.6-virtex.git;protocol=git \
+ "
+
+do_configure() {
+
+ make ARCH=${ARCH} ml403_defconfig
+}
+
+do_deploy() {
+ install -d ${DEPLOY_DIR_IMAGE}
+ install -m 0644 arch/${ARCH}/boot/images/${KERNEL_IMAGETYPE}.elf \
+ ${DEPLOY_DIR_IMAGE}/${KERNEL_IMAGETYPE}-${PV}-${MACHINE}-${DATETIME}
+}
+
+#seems like 2.6.21 kernel images have moved (or is this only for the Denx kernel ?)
+#so we need to copy the kernel image where kernel.bbclass expects it to be
+#do_install_prepend() {
+# install -m 0644 arch/${ARCH}/boot/images/${KERNEL_IMAGETYPE}.elf \
+# arch/${ARCH}/boot/${KERNEL_IMAGETYPE}
+#}