aboutsummaryrefslogtreecommitdiffstats
path: root/recipes/linux/linux_2.6.14.bb
diff options
context:
space:
mode:
authorDenys Dmytriyenko <denis@denix.org>2009-03-17 14:32:59 -0400
committerDenys Dmytriyenko <denis@denix.org>2009-03-17 14:32:59 -0400
commit709c4d66e0b107ca606941b988bad717c0b45d9b (patch)
tree37ee08b1eb308f3b2b6426d5793545c38396b838 /recipes/linux/linux_2.6.14.bb
parentfa6cd5a3b993f16c27de4ff82b42684516d433ba (diff)
downloadopenembedded-709c4d66e0b107ca606941b988bad717c0b45d9b.tar.gz
rename packages/ to recipes/ per earlier agreement
See links below for more details: http://thread.gmane.org/gmane.comp.handhelds.openembedded/21326 http://thread.gmane.org/gmane.comp.handhelds.openembedded/21816 Signed-off-by: Denys Dmytriyenko <denis@denix.org> Acked-by: Mike Westerhof <mwester@dls.net> Acked-by: Philip Balister <philip@balister.org> Acked-by: Khem Raj <raj.khem@gmail.com> Acked-by: Marcin Juszkiewicz <hrw@openembedded.org> Acked-by: Koen Kooi <koen@openembedded.org> Acked-by: Frans Meulenbroeks <fransmeulenbroeks@gmail.com>
Diffstat (limited to 'recipes/linux/linux_2.6.14.bb')
-rw-r--r--recipes/linux/linux_2.6.14.bb43
1 files changed, 43 insertions, 0 deletions
diff --git a/recipes/linux/linux_2.6.14.bb b/recipes/linux/linux_2.6.14.bb
new file mode 100644
index 0000000000..d625d15ebe
--- /dev/null
+++ b/recipes/linux/linux_2.6.14.bb
@@ -0,0 +1,43 @@
+DESCRIPTION = "Linux Kernel"
+SECTION = "kernel"
+LICENSE = "GPL"
+
+SRC_URI = "${KERNELORG_MIRROR}/pub/linux/kernel/v2.6/linux-${PV}.tar.bz2 \
+ file://defconfig"
+
+SRC_URI_append_acern30 = "\
+ http://lechat.rtp-net.org/ipaq/patches/2.6.14-3/v2.6.14-gitcurrent.patch;patch=1 \
+ http://lechat.rtp-net.org/ipaq/patches/2.6.14-3/full.patch;patch=1 \
+ file://n30-cleanup.patch;patch=1 \
+ file://n35.patch;patch=1 \
+ file://n30-lcd.patch;patch=1 \
+ file://n30-backlight.patch;patch=1 \
+ file://n30-ts.patch;patch=1 \
+ file://n30-buttons.patch;patch=1 \
+ file://n30-mmc.patch;patch=1 \
+ file://n30-mmc-power.patch;patch=1 \
+ file://n30-mmc-wprotect.patch;patch=1 \
+ file://n30-nand.patch;patch=1 \
+ file://n30-usbstart.patch;patch=1 \
+ file://n30-hardcode.patch;patch=1 \
+ file://n30-apm.patch;patch=1 \
+ file://s3c2410fb-resume.patch;patch=1 \
+ file://s3c2410_ts-pm.patch;patch=1 \
+ file://s3c2410_lcd-pm.c;patch=1 \
+ file://s3c2410mci-pm.patch;patch=1 \
+ file://s3c2410-nand-pm.patch;patch=1 \
+ file://n30-nand-hack.patch;patch=1 \
+ file://mmc-plus.patch;patch=1 \
+ file://gpio-sysfs.patch;patch=1 \
+ file://regdump.patch;patch=1 \
+ file://n30-pm.patch;patch=1 \
+ file://spi.patch;patch=1 \
+ file://wingel-hacking.patch;patch=1 \
+ file://gcc4-fixes.patch;patch=1 \
+ "
+
+inherit kernel
+
+do_configure_prepend() {
+ install -m 0644 ${WORKDIR}/defconfig ${S}/.config
+}