summaryrefslogtreecommitdiffstats
path: root/recipes/linux/linux_2.6.23.bb
diff options
context:
space:
mode:
authorChris Larson <chris_larson@mentor.com>2010-05-23 20:23:53 -0700
committerChris Larson <chris_larson@mentor.com>2010-05-25 12:53:41 -0700
commitbf7d0467a0788a7fcc1c96e0dc35a25ae09278a0 (patch)
tree96f28e2f5133d68c3e3dadabaa2339340671454f /recipes/linux/linux_2.6.23.bb
parentfab0af3aefee22b21541e403d3c356a6979bfa63 (diff)
downloadopenembedded-bf7d0467a0788a7fcc1c96e0dc35a25ae09278a0.tar.gz
Rename url params patch=<ignored>/pnum=<n> to apply={yes,no}/striplevel=<n>
I think this makes the behavior rather more clear. Signed-off-by: Chris Larson <chris_larson@mentor.com> Acked-by: Denys Dmytriyenko <denis@denix.org> Acked-by: Khem Raj <raj.khem@gmail.com>
Diffstat (limited to 'recipes/linux/linux_2.6.23.bb')
-rw-r--r--recipes/linux/linux_2.6.23.bb42
1 files changed, 21 insertions, 21 deletions
diff --git a/recipes/linux/linux_2.6.23.bb b/recipes/linux/linux_2.6.23.bb
index b62d9b7a19..7070de44ec 100644
--- a/recipes/linux/linux_2.6.23.bb
+++ b/recipes/linux/linux_2.6.23.bb
@@ -9,47 +9,47 @@ DEFAULT_PREFERENCE_avr32 = "1"
PR = "r13"
SRC_URI = "${KERNELORG_MIRROR}/pub/linux/kernel/v2.6/linux-2.6.23.tar.bz2;name=kernel \
- file://binutils-buildid-arm.patch;patch=1 \
- file://kallsyms-missing-include.patch;patch=1 \
+ file://binutils-buildid-arm.patch;apply=yes \
+ file://kallsyms-missing-include.patch;apply=yes \
file://defconfig \
"
# Bug fixes on the 2.6.23.x stable branch
-SRC_URI += "${KERNELORG_MIRROR}/pub/linux/kernel/v2.6/patch-2.6.23.17.bz2;patch=1;name=stablepatch"
+SRC_URI += "${KERNELORG_MIRROR}/pub/linux/kernel/v2.6/patch-2.6.23.17.bz2;apply=yes;name=stablepatch"
# Real-time preemption (includes CFS). This is experimental and requires a different defconfig.
-#SRC_URI += "file://patch-2.6.23.12-rt14;patch=1"
+#SRC_URI += "file://patch-2.6.23.12-rt14;apply=yes"
# Only the Completely Fair Scheduler (CFS), the official backport from 2.6.24 (adapted for 2.6.23.17)
-SRC_URI += "file://sched-cfs-v2.6.23.12-v24.1.patch;patch=1"
+SRC_URI += "file://sched-cfs-v2.6.23.12-v24.1.patch;apply=yes"
# Add support for squashfs-lzma (a highly compressed read-only filesystem)
-SRC_URI += "http://kamikaze.waninkoko.info/patches/2.6.23/klight1/broken-out/squashfs-lzma-2.6.23.patch;patch=1;name=squashfspatch"
+SRC_URI += "http://kamikaze.waninkoko.info/patches/2.6.23/klight1/broken-out/squashfs-lzma-2.6.23.patch;apply=yes;name=squashfspatch"
-SRC_URI += "file://time.h.patch;patch=1"
+SRC_URI += "file://time.h.patch;apply=yes"
# The Atmel patch doesn't apply against 2.6.23.12 :(
SRC_URI_avr32 = "${KERNELORG_MIRROR}/pub/linux/kernel/v2.6/linux-2.6.23.tar.bz2;name=kernel \
file://defconfig \
- http://avr32linux.org/twiki/pub/Main/LinuxPatches/linux-2.6.23.atmel.3.patch.bz2;patch=1;name=atmelpatch \
+ http://avr32linux.org/twiki/pub/Main/LinuxPatches/linux-2.6.23.atmel.3.patch.bz2;apply=yes;name=atmelpatch \
"
SRC_URI_append_em-x270 = "\
- file://em-x270.patch;patch=1 "
+ file://em-x270.patch;apply=yes "
SRC_URI_append_cm-x270 = "\
- file://0001-cm-x270-base2.patch;patch=1 \
- file://0002-cm-x270-match-type.patch;patch=1 \
- file://0003-cm-x270-ide.patch;patch=1 \
- file://0004-cm-x270-it8152.patch;patch=1 \
- file://0005-cm-x270-pcmcia.patch;patch=1 \
- file://0006-ramdisk_load.patch;patch=1 \
- file://0007-mmcsd_large_cards-r0.patch;patch=1 \
- file://0008-cm-x270-nand-simplify-name.patch;patch=1"
+ file://0001-cm-x270-base2.patch;apply=yes \
+ file://0002-cm-x270-match-type.patch;apply=yes \
+ file://0003-cm-x270-ide.patch;apply=yes \
+ file://0004-cm-x270-it8152.patch;apply=yes \
+ file://0005-cm-x270-pcmcia.patch;apply=yes \
+ file://0006-ramdisk_load.patch;apply=yes \
+ file://0007-mmcsd_large_cards-r0.patch;apply=yes \
+ file://0008-cm-x270-nand-simplify-name.patch;apply=yes"
SRC_URI_append_mpc8313e-rdb = "\
- file://mpc831x-nand.patch;patch=1 \
- file://mpc8313e-rdb-leds.patch;patch=1 \
- file://mpc8313e-rdb-rtc.patch;patch=1"
+ file://mpc831x-nand.patch;apply=yes \
+ file://mpc8313e-rdb-leds.patch;apply=yes \
+ file://mpc8313e-rdb-rtc.patch;apply=yes"
SRC_URI_append_mpc8323e-rdb = "\
- file://mpc832x-leds.patch;patch=1"
+ file://mpc832x-leds.patch;apply=yes"
CMDLINE_cm-x270 = "console=${CMX270_CONSOLE_SERIAL_PORT},38400 monitor=8 bpp=16 mem=64M mtdparts=physmap-flash.0:256k(boot)ro,0x180000(kernel),-(root);cm-x270-nand:64m(app),-(data) rdinit=/sbin/init root=mtd3 rootfstype=jffs2"