aboutsummaryrefslogtreecommitdiffstats
path: root/recipes/linux/linux_2.6.27.bb
diff options
context:
space:
mode:
authorPetr Štetiar <ynezz@true.cz>2010-03-03 20:43:16 +0100
committerMarcin Juszkiewicz <marcin@juszkiewicz.com.pl>2010-03-04 15:11:11 +0100
commit07046be146f644760476cc593c31a3c7e16636ad (patch)
tree4a941854558b24acedb981720a106e9543a81811 /recipes/linux/linux_2.6.27.bb
parentb5263c641ea29e0d3064318bf8a95ceef010d4fd (diff)
downloadopenembedded-07046be146f644760476cc593c31a3c7e16636ad.tar.gz
linux 2.6.27: add support for ts72xx and make it default kernel
Signed-off-by: Petr Štetiar <ynezz@true.cz> Acked-by: Marcin Juszkiewicz <marcin@juszkiewicz.com.pl>
Diffstat (limited to 'recipes/linux/linux_2.6.27.bb')
-rw-r--r--recipes/linux/linux_2.6.27.bb36
1 files changed, 35 insertions, 1 deletions
diff --git a/recipes/linux/linux_2.6.27.bb b/recipes/linux/linux_2.6.27.bb
index 0437547bf1..7661600e3c 100644
--- a/recipes/linux/linux_2.6.27.bb
+++ b/recipes/linux/linux_2.6.27.bb
@@ -1,12 +1,13 @@
require linux.inc
-PR = "r13"
+PR = "r14"
# Mark archs/machines that this kernel supports
DEFAULT_PREFERENCE = "-1"
DEFAULT_PREFERENCE_boc01 = "1"
DEFAULT_PREFERENCE_progear = "1"
DEFAULT_PREFERENCE_simpad = "-1"
+DEFAULT_PREFERENCE_ts72xx = "1"
SRC_URI = "${KERNELORG_MIRROR}/pub/linux/kernel/v2.6/linux-${PV}.tar.bz2 \
${KERNELORG_MIRROR}/pub/linux/kernel/v2.6/patch-${PV}.45.bz2;patch=1 \
@@ -42,6 +43,39 @@ SRC_URI_append_simpad = "\
file://connectplus-remove-ide-HACK.patch;patch=1 \
"
+SRC_URI_append_ts72xx = "\
+ file://0001-TS72xx-update-memory-map-comments.patch;patch=1 \
+ file://0002-GPIO-fix.patch;patch=1 \
+ file://0003-Debounce-IRQ.patch;patch=1 \
+ file://0004-OHCI-fix.patch;patch=1 \
+ file://0005-Fix-wrong-machine-ID-passed-from-RedBoot.patch;patch=1 \
+ file://0006-Force-the-nF-bit-on.patch;patch=1 \
+ file://0007-Use-CPLD-watchdog-to-reset.patch;patch=1 \
+ file://0008-Fix-UART-clocks.patch;patch=1 \
+ file://0009-CPU-info-and-board-revision.patch;patch=1 \
+ file://0010-GPIO-leds.patch;patch=1 \
+ file://0011-EP93xx-Ethernet-support.patch;patch=1 \
+ file://0012-TS72xx-watchdog.patch;patch=1 \
+ file://0013-TS7200-NOR-physmap-fix.patch;patch=1 \
+ file://0014-TS-7200-8MB-NOR-flash.patch;patch=1 \
+ file://0015-TS-72xx-MAX197-support.patch;patch=1 \
+ file://0016-RS485-common-bits.patch;patch=1 \
+ file://0017-TS-72xx-SBC-proc-info.patch;patch=1 \
+ file://0018-EP93xx-GPIO-I2C.patch;patch=1 \
+ file://0019-EP93xx-SPI-driver.patch;patch=1 \
+ file://0020-TS-72XX-LCD-console-driver.patch;patch=1 \
+ file://0021-EP93xx-GPIO-matrix-keypad.patch;patch=1 \
+ file://0022-TS-72xx-RS485-auto-mode-support.patch;patch=1 \
+ file://0023-Clean-and-invalidate-D-cache-entry.patch;patch=1 \
+ file://0024-PC-104-I-O-and-memory-mappings.patch;patch=1 \
+ file://0025-EP93xx-discontigmem.patch;patch=1 \
+ file://0026-TS72xx-PATA-support.patch;patch=1 \
+ file://0027-TS72xx-TS-SER1-support.patch;patch=1 \
+ file://0028-TS72xx-TS-ETH100.patch;patch=1 \
+ file://0029-EP93xx-Power-Management-Routines.patch;patch=1 \
+ file://0030-EP93xx-CPUfreq-driver.patch;patch=1 \
+ "
+
# see http://bugzilla.kernel.org/show_bug.cgi?id=11143
do_stage_append() {
if [ -f arch/${ARCH}/lib/crtsavres.o ]; then