aboutsummaryrefslogtreecommitdiffstats
path: root/recipes/linux/linux_3.0.bb
diff options
context:
space:
mode:
authorKoen Kooi <koen@openembedded.org>2011-07-26 12:03:56 +0200
committerKoen Kooi <koen@openembedded.org>2011-07-26 12:03:56 +0200
commit82f25a42165fc050b21da183ec882109cec73d15 (patch)
tree5e27d066a1f7cf9eb39ec2b53e5c412aa5383079 /recipes/linux/linux_3.0.bb
parent23207090cb8ec01171ea29fdad4a3fd70b6e744e (diff)
downloadopenembedded-82f25a42165fc050b21da183ec882109cec73d15.tar.gz
linux 3.0: add initial recipe with patches for hx4700 machine
Signed-off-by: Koen Kooi <koen@openembedded.org>
Diffstat (limited to 'recipes/linux/linux_3.0.bb')
-rw-r--r--recipes/linux/linux_3.0.bb22
1 files changed, 22 insertions, 0 deletions
diff --git a/recipes/linux/linux_3.0.bb b/recipes/linux/linux_3.0.bb
new file mode 100644
index 0000000000..74793b7c72
--- /dev/null
+++ b/recipes/linux/linux_3.0.bb
@@ -0,0 +1,22 @@
+require linux.inc
+
+# Mark archs/machines that this kernel supports
+DEFAULT_PREFERENCE = "-1"
+DEFAULT_PREFERENCE_hx4700 = "1"
+
+SRC_URI = "${KERNELORG_MIRROR}/pub/linux/kernel/v3.0/linux-${PV}.tar.bz2;name=kernel \
+ file://defconfig "
+
+SRC_URI[kernel.md5sum] = "398e95866794def22b12dfbc15ce89c0"
+SRC_URI[kernel.sha256sum] = "64b0228b54ce39b0b2df086109a7b737cde58e3df4f779506ddcaccee90356a0"
+
+SRC_URI_append_hx4700 = " \
+ file://0001-Add-LED-support-for-the-HTC-ASIC3.-Underlying-suppor.patch \
+ file://0002-tmio_mmc_irq-race.patch \
+ file://0003-Only-compile-tmio_mmc_dma.o-when-CONFIG_MMC_SDHI-is-.patch \
+ file://0004-Add-PCMCIA-CF-support-for-the-HTC-ASIC3.-Underlying-.patch \
+ file://0005-Suspend-unbalanced-irqs.patch \
+ file://0006-suspend.patch \
+ file://0007-hx4700-change-led-trigger-assignments.patch \
+ "
+