aboutsummaryrefslogtreecommitdiffstats
path: root/recipes/linux/linux_git.bb
diff options
context:
space:
mode:
authorMartin Jansa <Martin.Jansa@gmail.com>2010-05-01 13:23:53 +0200
committerMartin Jansa <Martin.Jansa@gmail.com>2010-05-03 19:30:54 +0200
commit2fe35cacc1b9235db3c6266d5a10f3a32dd62768 (patch)
treeee28b21ef2b36707105e0e64ec32b301981f995e /recipes/linux/linux_git.bb
parent5f38959851ea1319ebbeb0cd7921e15c62495ee0 (diff)
downloadopenembedded-2fe35cacc1b9235db3c6266d5a10f3a32dd62768.tar.gz
linux: add git recipe for vanilla kernel
* spitz's defconfig based on 2.6.33, disabled obsolete PCMCIA ioctl, because it's broken in current HEAD Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com>
Diffstat (limited to 'recipes/linux/linux_git.bb')
-rw-r--r--recipes/linux/linux_git.bb14
1 files changed, 14 insertions, 0 deletions
diff --git a/recipes/linux/linux_git.bb b/recipes/linux/linux_git.bb
new file mode 100644
index 0000000000..2af35b355d
--- /dev/null
+++ b/recipes/linux/linux_git.bb
@@ -0,0 +1,14 @@
+require linux.inc
+
+KERNEL_RELEASE = "2.6.34-rc6"
+SRCREV = "be1066bbcd443a65df312fdecea7e4959adedb45"
+PV = "${KERNEL_RELEASE}+gitr${SRCPV}"
+
+SRC_URI = "git://git.kernel.org/pub/scm/linux/kernel/git/torvalds/linux-2.6.git;protocol=git;branch=master \
+ file://ARM-Add-support-for-LZMA-compressed-kernel-images.patch;patch=1;status=pending \
+ file://defconfig"
+
+S = "${WORKDIR}/git"
+
+# Mark archs/machines that this kernel supports
+DEFAULT_PREFERENCE = "-1"