aboutsummaryrefslogtreecommitdiffstats
path: root/recipes/linux/logicpd-pxa270_2.6.17-rc5.bb
diff options
context:
space:
mode:
authorDenys Dmytriyenko <denis@denix.org>2009-03-17 14:32:59 -0400
committerDenys Dmytriyenko <denis@denix.org>2009-03-17 14:32:59 -0400
commit709c4d66e0b107ca606941b988bad717c0b45d9b (patch)
tree37ee08b1eb308f3b2b6426d5793545c38396b838 /recipes/linux/logicpd-pxa270_2.6.17-rc5.bb
parentfa6cd5a3b993f16c27de4ff82b42684516d433ba (diff)
downloadopenembedded-709c4d66e0b107ca606941b988bad717c0b45d9b.tar.gz
rename packages/ to recipes/ per earlier agreement
See links below for more details: http://thread.gmane.org/gmane.comp.handhelds.openembedded/21326 http://thread.gmane.org/gmane.comp.handhelds.openembedded/21816 Signed-off-by: Denys Dmytriyenko <denis@denix.org> Acked-by: Mike Westerhof <mwester@dls.net> Acked-by: Philip Balister <philip@balister.org> Acked-by: Khem Raj <raj.khem@gmail.com> Acked-by: Marcin Juszkiewicz <hrw@openembedded.org> Acked-by: Koen Kooi <koen@openembedded.org> Acked-by: Frans Meulenbroeks <fransmeulenbroeks@gmail.com>
Diffstat (limited to 'recipes/linux/logicpd-pxa270_2.6.17-rc5.bb')
-rw-r--r--recipes/linux/logicpd-pxa270_2.6.17-rc5.bb29
1 files changed, 29 insertions, 0 deletions
diff --git a/recipes/linux/logicpd-pxa270_2.6.17-rc5.bb b/recipes/linux/logicpd-pxa270_2.6.17-rc5.bb
new file mode 100644
index 0000000000..e7ab462c0b
--- /dev/null
+++ b/recipes/linux/logicpd-pxa270_2.6.17-rc5.bb
@@ -0,0 +1,29 @@
+SECTION = "kernel"
+DESCRIPTION = "Linux kernel for the LogicPD Zoom(PXA270 ref design)"
+LICENSE = "GPL"
+PR = "r3"
+
+SRC_URI = "${KERNELORG_MIRROR}/pub/linux/kernel/v2.6/testing/linux-2.6.17-rc5.tar.bz2 \
+ file://linux-2.6.17-rc5.patch;pnum=0;patch=1 \
+ file://ucb1400-ac97-audio.patch;pnum=1;patch=1 \
+ file://ucb1400-touchscreen.patch;pnum=1;patch=1 \
+ file://defconfig"
+
+S = "${WORKDIR}/linux-2.6.17-rc5"
+
+COMPATIBLE_HOST = 'arm.*-linux'
+
+inherit kernel
+inherit package
+
+ARCH = "arm"
+
+FILES_kernel-image = ""
+
+do_configure_prepend() {
+# install -m 0644 ${S}/arch/arm/configs/lpd270_defconfig ${S}/.config
+ install -m 0644 ${WORKDIR}/defconfig ${S}/.config
+
+}
+
+COMPATIBLE_MACHINE = "logicpd-pxa270"