aboutsummaryrefslogtreecommitdiffstats
path: root/recipes/linux
diff options
context:
space:
mode:
authorTom Rini <tom_rini@mentor.com>2011-03-16 12:03:53 -0700
committerSteffen Sledz <sledz@dresearch-fe.de>2011-04-29 14:08:39 +0200
commite9d796d3d91043e0a9386e0eba8a713bf5d0baf2 (patch)
tree07833dad79684ac17c0b784e15a95db4f2fbb9f7 /recipes/linux
parent2685ca76fd11c9bc2b1e96b1e4c40fc3b9763691 (diff)
downloadopenembedded-e9d796d3d91043e0a9386e0eba8a713bf5d0baf2.tar.gz
In a large number of patches, remove unneeded '..' in paths.
In most cases we had both ../foopkg/foopkg as the first path and this simply became foopkg (the second path was already correct for the default strip level which is why the patch applies normally). In a few cases the second path was '.' which is valid but not as clear as 'b' (which is what git shows for example) so update that while we're at it. Signed-off-by: Tom Rini <tom_rini@mentor.com> Signed-off-by: Koen Kooi <koen@dominion.thruhere.net>
Diffstat (limited to 'recipes/linux')
-rw-r--r--recipes/linux/linux-kexecboot-2.6.24/poodle-bootparams.patch2
-rw-r--r--recipes/linux/linux-wrt-2.4.30/001-Makefile2
-rw-r--r--recipes/linux/linux-wrt-2.4.30/005-arch_mips_config-shared_in2
-rw-r--r--recipes/linux/linux-wrt-2.4.30/022-drivers_net_Makefile2
-rw-r--r--recipes/linux/linux-wrt-2.4.30/023-drivers_parport_Makefile2
-rw-r--r--recipes/linux/linux-wrt-2.4.30/024-drivers_parport_Config_in2
-rw-r--r--recipes/linux/linux-wrt-2.4.30/310-netfilter-maxconn2
-rw-r--r--recipes/linux/linux/sarge-at91/2.6.21-sarge-kernel.patch24
-rw-r--r--recipes/linux/linux/sarge-at91/2.6.21-sarge-mmc.patch18
-rw-r--r--recipes/linux/linux/sarge-at91/2.6.21-sarge-phy.patch30
10 files changed, 43 insertions, 43 deletions
diff --git a/recipes/linux/linux-kexecboot-2.6.24/poodle-bootparams.patch b/recipes/linux/linux-kexecboot-2.6.24/poodle-bootparams.patch
index 4c22fb7960..c95b353e05 100644
--- a/recipes/linux/linux-kexecboot-2.6.24/poodle-bootparams.patch
+++ b/recipes/linux/linux-kexecboot-2.6.24/poodle-bootparams.patch
@@ -1,4 +1,4 @@
---- ../ref/linux-2.6.21.6/arch/arm/mach-pxa/poodle.c 2007-07-06 23:47:55.000000000 -0500
+--- linux-2.6.21.6/arch/arm/mach-pxa/poodle.c 2007-07-06 23:47:55.000000000 -0500
+++ linux-2.6.21.6-armeb/arch/arm/mach-pxa/poodle.c 2007-08-06 23:02:50.000000000 -0500
@@ -409,6 +409,7 @@
diff --git a/recipes/linux/linux-wrt-2.4.30/001-Makefile b/recipes/linux/linux-wrt-2.4.30/001-Makefile
index d01051f844..b117e7f8eb 100644
--- a/recipes/linux/linux-wrt-2.4.30/001-Makefile
+++ b/recipes/linux/linux-wrt-2.4.30/001-Makefile
@@ -1,4 +1,4 @@
---- ../../../kernel/linux-mips-cvs/Makefile 2005-01-20 03:19:21.000000000 +0100
+--- linux-mips-cvs/Makefile 2005-01-20 03:19:21.000000000 +0100
+++ linux-2.4.29.new/Makefile 2005-03-15 01:15:27.441095231 +0100
@@ -17,9 +17,9 @@
FINDHPATH = $(HPATH)/asm $(HPATH)/linux $(HPATH)/scsi $(HPATH)/net $(HPATH)/math-emu
diff --git a/recipes/linux/linux-wrt-2.4.30/005-arch_mips_config-shared_in b/recipes/linux/linux-wrt-2.4.30/005-arch_mips_config-shared_in
index 16c6766eec..87c8d3abe8 100644
--- a/recipes/linux/linux-wrt-2.4.30/005-arch_mips_config-shared_in
+++ b/recipes/linux/linux-wrt-2.4.30/005-arch_mips_config-shared_in
@@ -1,4 +1,4 @@
---- ../../../kernel/linux-mips-cvs/arch/mips/config-shared.in 2005-01-31 12:59:28.000000000 +0100
+--- linux-mips-cvs/arch/mips/config-shared.in 2005-01-31 12:59:28.000000000 +0100
+++ linux-2.4.29/arch/mips/config-shared.in 2005-03-12 19:51:22.474214917 +0100
@@ -208,6 +208,14 @@
fi
diff --git a/recipes/linux/linux-wrt-2.4.30/022-drivers_net_Makefile b/recipes/linux/linux-wrt-2.4.30/022-drivers_net_Makefile
index 8340c9565b..f2fba96bae 100644
--- a/recipes/linux/linux-wrt-2.4.30/022-drivers_net_Makefile
+++ b/recipes/linux/linux-wrt-2.4.30/022-drivers_net_Makefile
@@ -1,4 +1,4 @@
---- ../../../kernel/linux-mips-cvs/drivers/net/Makefile 2004-08-14 20:38:51.000000000 +0200
+--- linux-mips-cvs/drivers/net/Makefile 2004-08-14 20:38:51.000000000 +0200
+++ linux/drivers/net/Makefile 2005-03-16 12:45:24.523263597 +0100
@@ -21,6 +21,16 @@
list-multi := rcpci.o
diff --git a/recipes/linux/linux-wrt-2.4.30/023-drivers_parport_Makefile b/recipes/linux/linux-wrt-2.4.30/023-drivers_parport_Makefile
index 996e30a9b1..d45b88951a 100644
--- a/recipes/linux/linux-wrt-2.4.30/023-drivers_parport_Makefile
+++ b/recipes/linux/linux-wrt-2.4.30/023-drivers_parport_Makefile
@@ -1,4 +1,4 @@
---- ../../../kernel/linux-mips-cvs/drivers/parport/Makefile 2004-08-14 20:38:53.000000000 +0200
+--- linux-mips-cvs/drivers/parport/Makefile 2004-08-14 20:38:53.000000000 +0200
+++ linux-2.4.29/drivers/parport/Makefile 2005-03-21 13:57:53.338746517 +0100
@@ -22,6 +22,7 @@
diff --git a/recipes/linux/linux-wrt-2.4.30/024-drivers_parport_Config_in b/recipes/linux/linux-wrt-2.4.30/024-drivers_parport_Config_in
index 1b43798558..a8602a242e 100644
--- a/recipes/linux/linux-wrt-2.4.30/024-drivers_parport_Config_in
+++ b/recipes/linux/linux-wrt-2.4.30/024-drivers_parport_Config_in
@@ -1,4 +1,4 @@
---- ../../../kernel/linux-mips-cvs/drivers/parport/Config.in 2004-02-20 02:22:18.000000000 +0100
+--- linux-mips-cvs/drivers/parport/Config.in 2004-02-20 02:22:18.000000000 +0100
+++ linux-2.4.29/drivers/parport/Config.in 2005-03-21 13:59:33.958193664 +0100
@@ -11,6 +11,7 @@
tristate 'Parallel port support' CONFIG_PARPORT
diff --git a/recipes/linux/linux-wrt-2.4.30/310-netfilter-maxconn b/recipes/linux/linux-wrt-2.4.30/310-netfilter-maxconn
index 87be89d72f..4438974218 100644
--- a/recipes/linux/linux-wrt-2.4.30/310-netfilter-maxconn
+++ b/recipes/linux/linux-wrt-2.4.30/310-netfilter-maxconn
@@ -1,4 +1,4 @@
---- ../../buildroot-unpacked/build_mipsel/linux/net/ipv4/netfilter/ip_conntrack_core.c 2004-11-28 22:59:36.000000000 -0500
+--- linux/net/ipv4/netfilter/ip_conntrack_core.c 2004-11-28 22:59:36.000000000 -0500
+++ linux/net/ipv4/netfilter/ip_conntrack_core.c 2004-11-30 05:05:32.000000000 -0500
@@ -1386,7 +1386,7 @@
nf_unregister_sockopt(&so_getorigdst);
diff --git a/recipes/linux/linux/sarge-at91/2.6.21-sarge-kernel.patch b/recipes/linux/linux/sarge-at91/2.6.21-sarge-kernel.patch
index 7b5f408c37..76eaf3fcba 100644
--- a/recipes/linux/linux/sarge-at91/2.6.21-sarge-kernel.patch
+++ b/recipes/linux/linux/sarge-at91/2.6.21-sarge-kernel.patch
@@ -1,6 +1,6 @@
-diff -Nurp ../linux-2.6.21.4/arch/arm/boot/compressed/head-at91rm9200.S ./arch/arm/boot/compressed/head-at91rm9200.S
---- ../linux-2.6.21.4/arch/arm/boot/compressed/head-at91rm9200.S 2007-06-12 22:29:12.000000000 +0200
-+++ ./arch/arm/boot/compressed/head-at91rm9200.S 2007-06-12 02:57:07.000000000 +0200
+diff -Nurp linux-2.6.21.4/arch/arm/boot/compressed/head-at91rm9200.S b/arch/arm/boot/compressed/head-at91rm9200.S
+--- linux-2.6.21.4/arch/arm/boot/compressed/head-at91rm9200.S 2007-06-12 22:29:12.000000000 +0200
++++ b/arch/arm/boot/compressed/head-at91rm9200.S 2007-06-12 02:57:07.000000000 +0200
@@ -73,6 +73,12 @@
cmp r7, r3
beq 99f
@@ -14,9 +14,9 @@ diff -Nurp ../linux-2.6.21.4/arch/arm/boot/compressed/head-at91rm9200.S ./arch/a
@ Unknown board, use the AT91RM9200DK board
@ mov r7, #MACH_TYPE_AT91RM9200
mov r7, #(MACH_TYPE_AT91RM9200DK & 0xff)
-diff -Nurp ../linux-2.6.21.4/arch/arm/mach-at91/board-sarge.c ./arch/arm/mach-at91/board-sarge.c
---- ../linux-2.6.21.4/arch/arm/mach-at91/board-sarge.c 1970-01-01 01:00:00.000000000 +0100
-+++ ./arch/arm/mach-at91/board-sarge.c 2007-06-12 02:57:07.000000000 +0200
+diff -Nurp linux-2.6.21.4/arch/arm/mach-at91/board-sarge.c b/arch/arm/mach-at91/board-sarge.c
+--- linux-2.6.21.4/arch/arm/mach-at91/board-sarge.c 1970-01-01 01:00:00.000000000 +0100
++++ b/arch/arm/mach-at91/board-sarge.c 2007-06-12 02:57:07.000000000 +0200
@@ -0,0 +1,190 @@
+/*
+ * linux/arch/arm/mach-at91/board-sarge.c
@@ -208,9 +208,9 @@ diff -Nurp ../linux-2.6.21.4/arch/arm/mach-at91/board-sarge.c ./arch/arm/mach-at
+ .init_irq = sarge_init_irq,
+ .init_machine = sarge_board_init,
+MACHINE_END
-diff -Nurp ../linux-2.6.21.4/arch/arm/mach-at91/Kconfig ./arch/arm/mach-at91/Kconfig
---- ../linux-2.6.21.4/arch/arm/mach-at91/Kconfig 2007-06-12 22:29:12.000000000 +0200
-+++ ./arch/arm/mach-at91/Kconfig 2007-06-12 03:00:28.000000000 +0200
+diff -Nurp linux-2.6.21.4/arch/arm/mach-at91/Kconfig b/arch/arm/mach-at91/Kconfig
+--- linux-2.6.21.4/arch/arm/mach-at91/Kconfig 2007-06-12 22:29:12.000000000 +0200
++++ b/arch/arm/mach-at91/Kconfig 2007-06-12 03:00:28.000000000 +0200
@@ -90,6 +90,13 @@ config MACH_KAFA
help
Select this if you are using Sperry-Sun's KAFA board.
@@ -225,9 +225,9 @@ diff -Nurp ../linux-2.6.21.4/arch/arm/mach-at91/Kconfig ./arch/arm/mach-at91/Kco
config MACH_CHUB
bool "Promwad Chub board"
depends on ARCH_AT91RM9200
-diff -Nurp ../linux-2.6.21.4/arch/arm/mach-at91/Makefile ./arch/arm/mach-at91/Makefile
---- ../linux-2.6.21.4/arch/arm/mach-at91/Makefile 2007-06-12 22:29:12.000000000 +0200
-+++ ./arch/arm/mach-at91/Makefile 2007-06-12 03:00:47.000000000 +0200
+diff -Nurp linux-2.6.21.4/arch/arm/mach-at91/Makefile b/arch/arm/mach-at91/Makefile
+--- linux-2.6.21.4/arch/arm/mach-at91/Makefile 2007-06-12 22:29:12.000000000 +0200
++++ b/arch/arm/mach-at91/Makefile 2007-06-12 03:00:47.000000000 +0200
@@ -29,6 +29,7 @@ obj-$(CONFIG_MACH_KB9200) += board-kb920
obj-$(CONFIG_MACH_ATEB9200) += board-eb9200.o
obj-$(CONFIG_MACH_KAFA) += board-kafa.o
diff --git a/recipes/linux/linux/sarge-at91/2.6.21-sarge-mmc.patch b/recipes/linux/linux/sarge-at91/2.6.21-sarge-mmc.patch
index 01bbaeb73e..08c3e735ff 100644
--- a/recipes/linux/linux/sarge-at91/2.6.21-sarge-mmc.patch
+++ b/recipes/linux/linux/sarge-at91/2.6.21-sarge-mmc.patch
@@ -1,6 +1,6 @@
-diff -Nurp ../linux-2.6.21.4/drivers/mmc/at91_mci.c ./drivers/mmc/at91_mci.c
---- ../linux-2.6.21.4/drivers/mmc/at91_mci.c 2007-06-12 22:29:12.000000000 +0200
-+++ ./drivers/mmc/at91_mci.c 2007-06-12 03:52:55.000000000 +0200
+diff -Nurp linux-2.6.21.4/drivers/mmc/at91_mci.c b/drivers/mmc/at91_mci.c
+--- linux-2.6.21.4/drivers/mmc/at91_mci.c 2007-06-12 22:29:12.000000000 +0200
++++ b/drivers/mmc/at91_mci.c 2007-06-12 03:52:55.000000000 +0200
@@ -421,8 +421,11 @@ static unsigned int at91_mci_send_comman
if (cmd->opcode == MMC_STOP_TRANSMISSION)
cmdr |= AT91_MCI_TRCMD_STOP;
@@ -29,9 +29,9 @@ diff -Nurp ../linux-2.6.21.4/drivers/mmc/at91_mci.c ./drivers/mmc/at91_mci.c
return IRQ_HANDLED;
}
-diff -Nurp ../linux-2.6.21.4/drivers/mmc/mmc_block.c ./drivers/mmc/mmc_block.c
---- ../linux-2.6.21.4/drivers/mmc/mmc_block.c 2007-06-07 23:27:31.000000000 +0200
-+++ ./drivers/mmc/mmc_block.c 2007-06-12 04:19:36.000000000 +0200
+diff -Nurp linux-2.6.21.4/drivers/mmc/mmc_block.c b/drivers/mmc/mmc_block.c
+--- linux-2.6.21.4/drivers/mmc/mmc_block.c 2007-06-07 23:27:31.000000000 +0200
++++ b/drivers/mmc/mmc_block.c 2007-06-12 04:19:36.000000000 +0200
@@ -256,10 +256,24 @@ static int mmc_blk_issue_rq(struct mmc_q
* this rule as they support querying the number of
* successfully written sectors.
@@ -58,9 +58,9 @@ diff -Nurp ../linux-2.6.21.4/drivers/mmc/mmc_block.c ./drivers/mmc/mmc_block.c
if (brq.data.blocks > 1) {
brq.data.flags |= MMC_DATA_MULTI;
-diff -Nurp ../linux-2.6.21.4/drivers/mmc/mmc.c ./drivers/mmc/mmc.c
---- ../linux-2.6.21.4/drivers/mmc/mmc.c 2007-06-07 23:27:31.000000000 +0200
-+++ ./drivers/mmc/mmc.c 2007-06-12 04:10:05.000000000 +0200
+diff -Nurp linux-2.6.21.4/drivers/mmc/mmc.c b/drivers/mmc/mmc.c
+--- linux-2.6.21.4/drivers/mmc/mmc.c 2007-06-07 23:27:31.000000000 +0200
++++ b/drivers/mmc/mmc.c 2007-06-12 04:10:05.000000000 +0200
@@ -1500,12 +1500,22 @@ static void mmc_setup(struct mmc_host *h
mmc_set_ios(host);
diff --git a/recipes/linux/linux/sarge-at91/2.6.21-sarge-phy.patch b/recipes/linux/linux/sarge-at91/2.6.21-sarge-phy.patch
index 25ce15eb94..5cdc73b4dd 100644
--- a/recipes/linux/linux/sarge-at91/2.6.21-sarge-phy.patch
+++ b/recipes/linux/linux/sarge-at91/2.6.21-sarge-phy.patch
@@ -1,6 +1,6 @@
-diff -Nurp ../linux-2.6.21.4/drivers/net/arm/at91_ether.c ./drivers/net/arm/at91_ether.c
---- ../linux-2.6.21.4/drivers/net/arm/at91_ether.c 2007-06-12 22:29:12.000000000 +0200
-+++ ./drivers/net/arm/at91_ether.c 2007-06-12 03:11:16.000000000 +0200
+diff -Nurp linux-2.6.21.4/drivers/net/arm/at91_ether.c b/drivers/net/arm/at91_ether.c
+--- linux-2.6.21.4/drivers/net/arm/at91_ether.c 2007-06-12 22:29:12.000000000 +0200
++++ b/drivers/net/arm/at91_ether.c 2007-06-12 03:11:16.000000000 +0200
@@ -235,6 +235,11 @@ static irqreturn_t at91ether_phy_interru
if (!(phy & (1 << 7)))
goto done;
@@ -54,9 +54,9 @@ diff -Nurp ../linux-2.6.21.4/drivers/net/arm/at91_ether.c ./drivers/net/arm/at91
detected = at91ether_setup(phy_id, phy_address, pdev, ether_clk);
break;
}
-diff -Nurp ../linux-2.6.21.4/drivers/net/arm/at91_ether.h ./drivers/net/arm/at91_ether.h
---- ../linux-2.6.21.4/drivers/net/arm/at91_ether.h 2007-06-12 22:29:12.000000000 +0200
-+++ ./drivers/net/arm/at91_ether.h 2007-06-12 03:07:54.000000000 +0200
+diff -Nurp linux-2.6.21.4/drivers/net/arm/at91_ether.h b/drivers/net/arm/at91_ether.h
+--- linux-2.6.21.4/drivers/net/arm/at91_ether.h 2007-06-12 22:29:12.000000000 +0200
++++ b/drivers/net/arm/at91_ether.h 2007-06-12 03:07:54.000000000 +0200
@@ -29,6 +29,15 @@
#define MII_ISINTS_REG 19
#define MII_LEDCTRL_REG 20
@@ -73,9 +73,9 @@ diff -Nurp ../linux-2.6.21.4/drivers/net/arm/at91_ether.h ./drivers/net/arm/at91
/* Realtek RTL8201 PHY */
#define MII_RTL8201_ID 0x00008200
-diff -Nurp ../linux-2.6.21.4/drivers/net/phy/Kconfig ./drivers/net/phy/Kconfig
---- ../linux-2.6.21.4/drivers/net/phy/Kconfig 2007-06-07 23:27:31.000000000 +0200
-+++ ./drivers/net/phy/Kconfig 2007-06-12 03:12:16.000000000 +0200
+diff -Nurp linux-2.6.21.4/drivers/net/phy/Kconfig b/drivers/net/phy/Kconfig
+--- linux-2.6.21.4/drivers/net/phy/Kconfig 2007-06-07 23:27:31.000000000 +0200
++++ b/drivers/net/phy/Kconfig 2007-06-12 03:12:16.000000000 +0200
@@ -62,6 +62,12 @@ config BROADCOM_PHY
---help---
Currently supports the BCM5411, BCM5421 and BCM5461 PHYs.
@@ -89,17 +89,17 @@ diff -Nurp ../linux-2.6.21.4/drivers/net/phy/Kconfig ./drivers/net/phy/Kconfig
config FIXED_PHY
tristate "Drivers for PHY emulation on fixed speed/link"
depends on PHYLIB
-diff -Nurp ../linux-2.6.21.4/drivers/net/phy/Makefile ./drivers/net/phy/Makefile
---- ../linux-2.6.21.4/drivers/net/phy/Makefile 2007-06-07 23:27:31.000000000 +0200
-+++ ./drivers/net/phy/Makefile 2007-06-12 03:12:29.000000000 +0200
+diff -Nurp linux-2.6.21.4/drivers/net/phy/Makefile b/drivers/net/phy/Makefile
+--- linux-2.6.21.4/drivers/net/phy/Makefile 2007-06-07 23:27:31.000000000 +0200
++++ b/drivers/net/phy/Makefile 2007-06-12 03:12:29.000000000 +0200
@@ -12,3 +12,4 @@ obj-$(CONFIG_SMSC_PHY) += smsc.o
obj-$(CONFIG_VITESSE_PHY) += vitesse.o
obj-$(CONFIG_BROADCOM_PHY) += broadcom.o
obj-$(CONFIG_FIXED_PHY) += fixed.o
+obj-$(CONFIG_STE100P_PHY) += ste100p.o
-diff -Nurp ../linux-2.6.21.4/drivers/net/phy/ste100p.c ./drivers/net/phy/ste100p.c
---- ../linux-2.6.21.4/drivers/net/phy/ste100p.c 1970-01-01 01:00:00.000000000 +0100
-+++ ./drivers/net/phy/ste100p.c 2007-06-12 02:52:31.000000000 +0200
+diff -Nurp linux-2.6.21.4/drivers/net/phy/ste100p.c b/drivers/net/phy/ste100p.c
+--- linux-2.6.21.4/drivers/net/phy/ste100p.c 1970-01-01 01:00:00.000000000 +0100
++++ b/drivers/net/phy/ste100p.c 2007-06-12 02:52:31.000000000 +0200
@@ -0,0 +1,297 @@
+/*
+ * drivers/net/phy/ste100p.c