aboutsummaryrefslogtreecommitdiffstats
path: root/recipes/linux
diff options
context:
space:
mode:
authorMichael 'Mickey' Lauer <mickey@vanille-media.de>2010-04-12 19:47:29 +0200
committerMichael 'Mickey' Lauer <mickey@vanille-media.de>2010-04-12 19:47:29 +0200
commit9171e9cd1f758f750bab55a568f191a9920859f9 (patch)
tree2ebb90991caec6b610c20a83ba659c4fb2abe742 /recipes/linux
parent60c40c8dc652a09b8b479df4c1aeac0c56bd24b5 (diff)
downloadopenembedded-9171e9cd1f758f750bab55a568f191a9920859f9.tar.gz
linux-leviathan: enable debugfs to fix wifi (yes, it's true)
BIG HATS OFF TO GNUtoo, who found the magic switch!
Diffstat (limited to 'recipes/linux')
-rw-r--r--recipes/linux/linux-leviathan/defconfig15
-rw-r--r--recipes/linux/linux-leviathan_git.bb2
2 files changed, 13 insertions, 4 deletions
diff --git a/recipes/linux/linux-leviathan/defconfig b/recipes/linux/linux-leviathan/defconfig
index cd3fbadb52..77838c38df 100644
--- a/recipes/linux/linux-leviathan/defconfig
+++ b/recipes/linux/linux-leviathan/defconfig
@@ -1,7 +1,7 @@
#
# Automatically generated make config: don't edit
# Linux kernel version: 2.6.32
-# Sun Apr 11 21:08:16 2010
+# Mon Apr 12 19:28:58 2010
#
CONFIG_ARM=y
CONFIG_SYS_SUPPORTS_APM_EMULATION=y
@@ -111,7 +111,9 @@ CONFIG_HAVE_KRETPROBES=y
#
# GCOV-based kernel profiling
#
+# CONFIG_GCOV_KERNEL is not set
CONFIG_SLOW_WORK=y
+# CONFIG_SLOW_WORK_DEBUG is not set
CONFIG_HAVE_GENERIC_DMA_COHERENT=y
CONFIG_SLABINFO=y
CONFIG_RT_MUTEXES=y
@@ -662,6 +664,7 @@ CONFIG_CFG80211_DEVELOPER_WARNINGS=y
CONFIG_CFG80211_REG_DEBUG=y
CONFIG_CFG80211_DEFAULT_PS=y
CONFIG_CFG80211_DEFAULT_PS_VALUE=1
+# CONFIG_CFG80211_DEBUGFS is not set
# CONFIG_WIRELESS_OLD_REGULATORY is not set
CONFIG_WIRELESS_EXT=y
CONFIG_WIRELESS_EXT_SYSFS=y
@@ -671,8 +674,9 @@ CONFIG_MAC80211_RC_MINSTREL=y
# CONFIG_MAC80211_RC_DEFAULT_PID is not set
CONFIG_MAC80211_RC_DEFAULT_MINSTREL=y
CONFIG_MAC80211_RC_DEFAULT="minstrel"
-# CONFIG_MAC80211_MESH is not set
+CONFIG_MAC80211_MESH=y
CONFIG_MAC80211_LEDS=y
+# CONFIG_MAC80211_DEBUGFS is not set
# CONFIG_MAC80211_DEBUG_MENU is not set
# CONFIG_WIMAX is not set
CONFIG_RFKILL=y
@@ -1127,6 +1131,8 @@ CONFIG_FB_CFB_IMAGEBLIT=y
CONFIG_FB_MSM=y
CONFIG_MSMFB_FBIOBLANK=y
CONFIG_FB_MSM_REFRESH=y
+CONFIG_FB_MSM_LOGO=y
+CONFIG_FB_MSM_LOGO_SOURCE="/logo.rle"
# CONFIG_FB_BROADSHEET is not set
# CONFIG_BACKLIGHT_LCD_SUPPORT is not set
CONFIG_BACKLIGHT_CLASS_DEVICE=y
@@ -1208,6 +1214,7 @@ CONFIG_USB_ARCH_HAS_HCD=y
CONFIG_USB_GADGET=y
# CONFIG_USB_GADGET_DEBUG is not set
# CONFIG_USB_GADGET_DEBUG_FILES is not set
+# CONFIG_USB_GADGET_DEBUG_FS is not set
CONFIG_USB_GADGET_VBUS_DRAW=2
CONFIG_USB_GADGET_SELECTED=y
# CONFIG_USB_GADGET_AT91 is not set
@@ -1411,6 +1418,7 @@ CONFIG_EXT3_FS_POSIX_ACL=y
CONFIG_EXT3_FS_SECURITY=y
# CONFIG_EXT4_FS is not set
CONFIG_JBD=y
+# CONFIG_JBD_DEBUG is not set
CONFIG_FS_MBCACHE=y
# CONFIG_REISERFS_FS is not set
# CONFIG_JFS_FS is not set
@@ -1590,7 +1598,7 @@ CONFIG_FRAME_WARN=1024
# CONFIG_MAGIC_SYSRQ is not set
# CONFIG_STRIP_ASM_SYMS is not set
# CONFIG_UNUSED_SYMBOLS is not set
-# CONFIG_DEBUG_FS is not set
+CONFIG_DEBUG_FS=y
# CONFIG_HEADERS_CHECK is not set
CONFIG_DEBUG_KERNEL=y
# CONFIG_DEBUG_SHIRQ is not set
@@ -1636,6 +1644,7 @@ CONFIG_DEBUG_MEMORY_INIT=y
CONFIG_HAVE_FUNCTION_TRACER=y
CONFIG_TRACING_SUPPORT=y
# CONFIG_FTRACE is not set
+# CONFIG_DYNAMIC_DEBUG is not set
# CONFIG_SAMPLES is not set
CONFIG_HAVE_ARCH_KGDB=y
# CONFIG_KGDB is not set
diff --git a/recipes/linux/linux-leviathan_git.bb b/recipes/linux/linux-leviathan_git.bb
index eb9daaa5f0..3220d661cd 100644
--- a/recipes/linux/linux-leviathan_git.bb
+++ b/recipes/linux/linux-leviathan_git.bb
@@ -2,7 +2,7 @@ require linux.inc
DEPENDS += "android-image-utils-native"
PV = "2.6.32+${PR}+gitr${SRCREV}"
-PR = "r15"
+PR = "r16"
COMPATIBLE_MACHINE = "htcdream"
CMDLINE = "console=tty1 no_console_suspend=1 root=/dev/mmcblk0p1 rootdelay=8 fbcon=rotate:1 panic=30 mem=110M"