aboutsummaryrefslogtreecommitdiffstats
path: root/recipes/linux
diff options
context:
space:
mode:
authorMartin Jansa <Martin.Jansa@gmail.com>2010-08-02 15:00:48 +0200
committerMartin Jansa <Martin.Jansa@gmail.com>2010-08-03 09:24:01 +0200
commitc0f6de52cbb831481d2ac07a258ae334fa2a6f23 (patch)
tree8c826e6982ee37dba557678054da33cb0eaf0775 /recipes/linux
parent0a1635529a4a8cc5dfe614695bc8dd506f657f21 (diff)
downloadopenembedded-c0f6de52cbb831481d2ac07a258ae334fa2a6f23.tar.gz
linux-openmoko-2.6.34: add patch for proper gsm sysfs node path
Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com>
Diffstat (limited to 'recipes/linux')
-rw-r--r--recipes/linux/linux-openmoko-2.6.34/0001-glamo-display-Enable-FIFO-stage-for-the-LCD-engine-s.patch25
-rw-r--r--recipes/linux/linux-openmoko-2.6.34/0001-mach-gta02-fix-gsm-power_on-sysfs-node-path.patch25
-rw-r--r--recipes/linux/linux-openmoko-2.6.34_git.bb5
3 files changed, 54 insertions, 1 deletions
diff --git a/recipes/linux/linux-openmoko-2.6.34/0001-glamo-display-Enable-FIFO-stage-for-the-LCD-engine-s.patch b/recipes/linux/linux-openmoko-2.6.34/0001-glamo-display-Enable-FIFO-stage-for-the-LCD-engine-s.patch
new file mode 100644
index 0000000000..b4186d9792
--- /dev/null
+++ b/recipes/linux/linux-openmoko-2.6.34/0001-glamo-display-Enable-FIFO-stage-for-the-LCD-engine-s.patch
@@ -0,0 +1,25 @@
+From 660579bd6333e7e33cfb176f849bcc098e33af38 Mon Sep 17 00:00:00 2001
+From: Martin Jansa <Martin.Jansa@gmail.com>
+Date: Mon, 19 Jul 2010 13:39:06 +0200
+Subject: [PATCH] glamo-display: Enable FIFO stage for the LCD engine's memory access
+
+---
+ drivers/gpu/drm/glamo/glamo-display.c | 2 +-
+ 1 files changed, 1 insertions(+), 1 deletions(-)
+
+diff --git a/drivers/gpu/drm/glamo/glamo-display.c b/drivers/gpu/drm/glamo/glamo-display.c
+index 6f25326..4e85906 100644
+--- a/drivers/gpu/drm/glamo/glamo-display.c
++++ b/drivers/gpu/drm/glamo/glamo-display.c
+@@ -210,7 +210,7 @@ static struct glamo_script lcd_init_script[] = {
+ /* The following values assume 640*480@16bpp */
+ /* FIXME: fb0 has not yet been allocated! */
+ { GLAMO_REG_LCD_A_BASE1, PAGE_SIZE }, /* display A base address 15:0 */
+- { GLAMO_REG_LCD_A_BASE2, 0x0000 }, /* display A base address 22:16 */
++ { GLAMO_REG_LCD_A_BASE2, 0x4000 }, /* display A base address 22:16 */
+ { GLAMO_REG_LCD_B_BASE1, 0x6000 }, /* display B base address 15:0 */
+ { GLAMO_REG_LCD_B_BASE2, 0x0009 }, /* display B base address 22:16 */
+ { GLAMO_REG_LCD_CURSOR_BASE1, 0xC000 }, /* cursor base address 15:0 */
+--
+1.7.1.1
+
diff --git a/recipes/linux/linux-openmoko-2.6.34/0001-mach-gta02-fix-gsm-power_on-sysfs-node-path.patch b/recipes/linux/linux-openmoko-2.6.34/0001-mach-gta02-fix-gsm-power_on-sysfs-node-path.patch
new file mode 100644
index 0000000000..d1053d4530
--- /dev/null
+++ b/recipes/linux/linux-openmoko-2.6.34/0001-mach-gta02-fix-gsm-power_on-sysfs-node-path.patch
@@ -0,0 +1,25 @@
+From ed36456fa34c2653d4a39c3dbeb66b4e671103fe Mon Sep 17 00:00:00 2001
+From: Gennady Kupava <gb@bsdmn.com>
+Date: Mon, 2 Aug 2010 14:53:55 +0200
+Subject: [PATCH] mach-gta02: fix gsm power_on sysfs node path
+
+---
+ arch/arm/mach-s3c2440/mach-gta02.c | 2 +-
+ 1 files changed, 1 insertions(+), 1 deletions(-)
+
+diff --git a/arch/arm/mach-s3c2440/mach-gta02.c b/arch/arm/mach-s3c2440/mach-gta02.c
+index e7d0b82..08e9dcc 100644
+--- a/arch/arm/mach-s3c2440/mach-gta02.c
++++ b/arch/arm/mach-s3c2440/mach-gta02.c
+@@ -1341,7 +1341,7 @@ static struct platform_device* gta02_hdq_children[] = {
+
+ static struct gta02_device_children gta02_device_children[] = {
+ {
+- .dev_name = "pcf50633-gpio",
++ .dev_name = "pcf50633-gpio.0",
+ .num_children = 2,
+ .children = gta02_pcf50633_gpio_children,
+ },
+--
+1.7.1.1
+
diff --git a/recipes/linux/linux-openmoko-2.6.34_git.bb b/recipes/linux/linux-openmoko-2.6.34_git.bb
index c3146dfbe9..d891896229 100644
--- a/recipes/linux/linux-openmoko-2.6.34_git.bb
+++ b/recipes/linux/linux-openmoko-2.6.34_git.bb
@@ -4,7 +4,7 @@ require linux-openmoko.inc
KERNEL_RELEASE="2.6.34"
SRCREV = "3f6725d43021d2d7597027e36020df5b44d0667e"
-OEV = "oe4.4"
+OEV = "oe4.6"
PV = "${KERNEL_RELEASE}-${OEV}+gitr${SRCPV}"
SRC_URI = "\
@@ -24,11 +24,14 @@ SRC_URI = "\
file://0006-Debug-statements-for-testing.patch \
file://0007-Fix-claim-of-2D-register-resource.patch \
file://0008-Use-unlocked_ioctl-rather-than-ioctl.patch \
+ file://0001-glamo-display-Enable-FIFO-stage-for-the-LCD-engine-s.patch \
# patches from Radek Polak used in qtmoko
file://0001-accels.patch.patch \
file://0002-usbhost.patch.patch \
file://0003-ar6000_delay.patch.patch \
file://0004-save_regs.patch.patch \
+# sysfs node path fix
+ file://0001-mach-gta02-fix-gsm-power_on-sysfs-node-path.patch \
file://defconfig \
"