aboutsummaryrefslogtreecommitdiffstats
path: root/recipes/linux
diff options
context:
space:
mode:
authorRobert Nelson <robert.nelson@digikey.com>2009-11-05 12:49:22 +0100
committerKoen Kooi <koen@openembedded.org>2009-11-05 12:49:22 +0100
commit6f0e47264d01494bdf74368acc6330537f6361c7 (patch)
tree1019b872ec7d7a9602afd7fae265500ec11613fc /recipes/linux
parentac8425fce9249cb483e6a206334ce23e95be0250 (diff)
downloadopenembedded-6f0e47264d01494bdf74368acc6330537f6361c7.tar.gz
linux-omap 2.6.29: fix FIFO issues with large transfers on the MUSB controller
Diffstat (limited to 'recipes/linux')
-rw-r--r--recipes/linux/linux-omap-2.6.29/musb/0030-musb-fifo.patch26
-rw-r--r--recipes/linux/linux-omap_2.6.29.bb1
2 files changed, 27 insertions, 0 deletions
diff --git a/recipes/linux/linux-omap-2.6.29/musb/0030-musb-fifo.patch b/recipes/linux/linux-omap-2.6.29/musb/0030-musb-fifo.patch
new file mode 100644
index 0000000000..8ac3707ad3
--- /dev/null
+++ b/recipes/linux/linux-omap-2.6.29/musb/0030-musb-fifo.patch
@@ -0,0 +1,26 @@
+diff --git a/drivers/usb/musb/musb_core.c b/drivers/usb/musb/musb_core.c
+index d3b8e0e..cee974e 100644
+--- a/drivers/usb/musb/musb_core.c
++++ b/drivers/usb/musb/musb_core.c
+@@ -1103,15 +1103,12 @@ static struct fifo_cfg __initdata mode_4_cfg[] = {
+ { .hw_ep_num = 8, .style = FIFO_RX, .maxpacket = 512, },
+ { .hw_ep_num = 9, .style = FIFO_TX, .maxpacket = 512, },
+ { .hw_ep_num = 9, .style = FIFO_RX, .maxpacket = 512, },
+-{ .hw_ep_num = 10, .style = FIFO_TX, .maxpacket = 256, },
+-{ .hw_ep_num = 10, .style = FIFO_RX, .maxpacket = 64, },
+-{ .hw_ep_num = 11, .style = FIFO_TX, .maxpacket = 256, },
+-{ .hw_ep_num = 11, .style = FIFO_RX, .maxpacket = 64, },
+-{ .hw_ep_num = 12, .style = FIFO_TX, .maxpacket = 256, },
+-{ .hw_ep_num = 12, .style = FIFO_RX, .maxpacket = 64, },
+-{ .hw_ep_num = 13, .style = FIFO_RXTX, .maxpacket = 4096, },
+-{ .hw_ep_num = 14, .style = FIFO_RXTX, .maxpacket = 1024, },
+-{ .hw_ep_num = 15, .style = FIFO_RXTX, .maxpacket = 1024, },
++{ .hw_ep_num = 10, .style = FIFO_TX, .maxpacket = 512, },
++{ .hw_ep_num = 10, .style = FIFO_RX, .maxpacket = 512, },
++{ .hw_ep_num = 11, .style = FIFO_RXTX, .maxpacket = 512, },
++{ .hw_ep_num = 12, .style = FIFO_RXTX, .maxpacket = 4096,},
++{ .hw_ep_num = 13, .style = FIFO_RXTX, .maxpacket = 512, },
++{ .hw_ep_num = 14, .style = FIFO_RXTX, .maxpacket = 512, },
+ };
+
+
diff --git a/recipes/linux/linux-omap_2.6.29.bb b/recipes/linux/linux-omap_2.6.29.bb
index 130f9a8f69..6996416e58 100644
--- a/recipes/linux/linux-omap_2.6.29.bb
+++ b/recipes/linux/linux-omap_2.6.29.bb
@@ -131,6 +131,7 @@ SRC_URI_append = " \
file://musb/0027-musb-otg-timer-cleanup.patch;patch=1 \
file://musb/0028-musb-make-initial-HNP-roleswitch-work-v2.patch;patch=1 \
file://musb/0029-musb-support-disconnect-after-HNP-roleswitch.patch;patch=1 \
+ file://musb/0030-musb-fifo.patch;patch=1 \
file://isp/v4l/0001-V4L2-Add-COLORFX-user-control.patch;patch=1 \
file://isp/v4l/0002-V4L-Int-if-v4l2_int_device_try_attach_all-requires.patch;patch=1 \
file://isp/v4l/0003-V4L-Int-if-Dummy-slave.patch;patch=1 \