aboutsummaryrefslogtreecommitdiffstats
path: root/recipes/linux
diff options
context:
space:
mode:
authorThilo Fromm <fromm@dresearch-fe.de>2011-03-31 15:18:00 +0000
committerSteffen Sledz <sledz@dresearch-fe.de>2011-06-06 11:29:34 +0200
commit0caee0e55d3aad94127c028dbb668e3bd883fb70 (patch)
tree6c267c8fcaa73a2b1f1199df9ddd541e703ab188 /recipes/linux
parente29b167bc68a136ae916963912945f1b0b0108ad (diff)
downloadopenembedded-0caee0e55d3aad94127c028dbb668e3bd883fb70.tar.gz
linux-2.6.24: fix 1/2-byte read access to PCI config space (hipox machine only)
Signed-off-by: Thilo Fromm <fromm@dresearch-fe.de> Acked-by: Steffen Sledz <sledz@dresearch-fe.de>
Diffstat (limited to 'recipes/linux')
-rw-r--r--recipes/linux/linux-2.6.24/hipox/ox810-pci-read-config-fix.patch17
-rw-r--r--recipes/linux/linux_2.6.24.bb3
2 files changed, 19 insertions, 1 deletions
diff --git a/recipes/linux/linux-2.6.24/hipox/ox810-pci-read-config-fix.patch b/recipes/linux/linux-2.6.24/hipox/ox810-pci-read-config-fix.patch
new file mode 100644
index 0000000000..5df26762db
--- /dev/null
+++ b/recipes/linux/linux-2.6.24/hipox/ox810-pci-read-config-fix.patch
@@ -0,0 +1,17 @@
+--- /linux-2.6.24-orig/arch/arm/mach-hipox/pci.c 2011-03-31 16:56:17.968638003 +0200
++++ /linux-2.6.24/arch/arm/mach-hipox/pci.c 2011-03-31 17:06:21.198638000 +0200
+@@ -311,12 +311,12 @@
+ switch (size) {
+ case 1:
+ // printk(KERN_DEBUG "PCI: readb( 0x%lx )\n", PCI_CONFIG_IO_READ_DATA );
+- *value>>=(where&3);
++ *value >>= ( (where & 3) * 8);
+ *value&=0x000000ff;
+ break;
+ case 2:
+ // printk(KERN_DEBUG "PCI: readw( 0x%lx )\n", PCI_CONFIG_IO_READ_DATA );
+- *value>>=(where&2);
++ *value >>= ( (where & 2) * 8);
+ *value&=0x0000ffff;
+ break;
+ case 4:
diff --git a/recipes/linux/linux_2.6.24.bb b/recipes/linux/linux_2.6.24.bb
index 5cc686a4c7..2552ae0277 100644
--- a/recipes/linux/linux_2.6.24.bb
+++ b/recipes/linux/linux_2.6.24.bb
@@ -11,7 +11,7 @@ DEFAULT_PREFERENCE_hipox = "1"
DEFAULT_PREFERENCE_cs-e9302 = "1"
DEFAULT_PREFERENCE_smartq5 = "1"
-PR = "r37"
+PR = "r38"
SRC_URI = "${KERNELORG_MIRROR}/pub/linux/kernel/v2.6/linux-2.6.24.tar.bz2;name=kernel \
${KERNELORG_MIRROR}/pub/linux/kernel/v2.6/patch-${PV}.7.bz2;apply=yes;name=stablepatch \
@@ -106,6 +106,7 @@ SRC_URI_append_hipox = " \
file://hipox-poe-enable.patch \
file://siocoutqsnd.patch \
file://hipox-phy.patch \
+ file://ox810-pci-read-config-fix.patch \
"
EXTRA_OEMAKE_smartq5 = " OBJCOPY=${OBJCOPY}"