aboutsummaryrefslogtreecommitdiffstats
path: root/recipes/linux
diff options
context:
space:
mode:
authorJoel A Fernandes <agnel.joel@gmail.com>2011-07-15 22:56:31 +0000
committerKoen Kooi <koen@openembedded.org>2011-07-15 17:42:27 +0200
commit93e91091c7e2864274207cc7c59e3f64e453f843 (patch)
treeb675cf53c7773219d06440d7cabe4dcedb2e1fc9 /recipes/linux
parenta4e41b90ecc3f71f93b6363cc7ff112fc3cf4570 (diff)
downloadopenembedded-93e91091c7e2864274207cc7c59e3f64e453f843.tar.gz
linux-omap-psp: Added patch to fix MMC timeout errors
This fixes MMC errors due to timeouts, and is borrowed from Steve Sakoman's patch for the linux-omap-2.6.39 recipe (as noticed by Jason Kridner) Details of the issue: http://www.mail-archive.com/linux-omap@vger.kernel.org/msg42214.html Signed-off-by: Joel A Fernandes <agnel.joel@gmail.com> Signed-off-by: Koen Kooi <koen@openembedded.org>
Diffstat (limited to 'recipes/linux')
-rw-r--r--recipes/linux/linux-omap-psp-2.6.32/0047-omap-mmc-Adjust-dto-to-eliminate-timeout-errors.patch22
-rw-r--r--recipes/linux/linux-omap-psp_2.6.32.bb3
2 files changed, 24 insertions, 1 deletions
diff --git a/recipes/linux/linux-omap-psp-2.6.32/0047-omap-mmc-Adjust-dto-to-eliminate-timeout-errors.patch b/recipes/linux/linux-omap-psp-2.6.32/0047-omap-mmc-Adjust-dto-to-eliminate-timeout-errors.patch
new file mode 100644
index 0000000000..4867d3f761
--- /dev/null
+++ b/recipes/linux/linux-omap-psp-2.6.32/0047-omap-mmc-Adjust-dto-to-eliminate-timeout-errors.patch
@@ -0,0 +1,22 @@
+From 26a79f408bd41ad7b4a47f2683909d3fc1575eab Mon Sep 17 00:00:00 2001
+From: Steve Sakoman <steve@sakoman.com>
+Date: Wed, 12 Jan 2011 05:54:55 -0800
+Subject: [PATCH] omap: mmc: Adjust dto to eliminate timeout errors
+
+A number of SD card types were experiencing timeout errors. This
+could also lead to data corruption in some cases.
+
+This fix proposed by Sukumar Ghoral of TI.
+---
+diff --git a/drivers/mmc/host/omap_hsmmc.c b/drivers/mmc/host/omap_hsmmc.c
+index 9646a75..ef458d6 100644
+--- a/drivers/mmc/host/omap_hsmmc.c
++++ b/drivers/mmc/host/omap_hsmmc.c
+@@ -1032,6 +1032,7 @@ static void set_data_timeout(struct omap_hsmmc_host *host,
+ cycle_ns = 1000000000 / (clk_get_rate(host->fclk) / clkd);
+ timeout = timeout_ns / cycle_ns;
+ timeout += timeout_clks;
++ timeout *= 2;
+ if (timeout) {
+ while ((timeout & 0x80000000) == 0) {
+ dto += 1;
diff --git a/recipes/linux/linux-omap-psp_2.6.32.bb b/recipes/linux/linux-omap-psp_2.6.32.bb
index e33dc51f2b..91de194c79 100644
--- a/recipes/linux/linux-omap-psp_2.6.32.bb
+++ b/recipes/linux/linux-omap-psp_2.6.32.bb
@@ -9,7 +9,7 @@ COMPATIBLE_MACHINE = "am3517-crane|beagleboard|omap3evm|am3517-evm|dm37x-evm|am3
SRCREV = "5fc29e7b2a76a64a739f857858ef0b98294aa155"
# The main PR is now using MACHINE_KERNEL_PR, for omap3 see conf/machine/include/omap3.inc
-MACHINE_KERNEL_PR_append = "e+gitr${SRCREV}"
+MACHINE_KERNEL_PR_append = "f+gitr${SRCREV}"
SRC_URI = "git://arago-project.org/git/projects/linux-omap3.git;protocol=http;branch=master \
file://0001-Added-Crane-Board-support.patch \
@@ -59,6 +59,7 @@ SRC_URI = "git://arago-project.org/git/projects/linux-omap3.git;protocol=http;br
file://0044-ARM-OMAP-beagle-every-known-beagle-except-revB-uses-.patch \
file://0045-ARM-OMAP-beagle-add-support-for-beagleFPGA-expansion.patch \
file://0046-ARM-OMAP-beagle-disable-uart-timeout.patch \
+ file://0047-omap-mmc-Adjust-dto-to-eliminate-timeout-errors.patch \
file://cam/0001-mt9t111-first-stab-at-merging-sensor-driver-based-on.patch \
file://cam/0002-mt9t111-Fix-all-checkpatch-errors.patch \
file://cam/0003-mt9t111-Pass-v4l2_int_device-data.patch \