aboutsummaryrefslogtreecommitdiffstats
path: root/recipes/linux
diff options
context:
space:
mode:
authorJoel A Fernandes <agnel.joel@gmail.com>2011-06-23 13:04:40 +0000
committerKoen Kooi <koen@openembedded.org>2011-06-23 09:38:34 +0200
commitc28ca0ff20a4c77041294b4fc1023bc07f476f8a (patch)
tree8897c8417fe31649cf9fe246e2312f9fb99d9d73 /recipes/linux
parent2bcdca7c1b670addbc83ef8420af55150831d973 (diff)
downloadopenembedded-c28ca0ff20a4c77041294b4fc1023bc07f476f8a.tar.gz
linux-omap: Disable UART sleep timeout to avoid serial port problems on wakeup.
Signed-off-by: Joel A Fernandes <agnel.joel@gmail.com> Signed-off-by: Koen Kooi <koen@openembedded.org>
Diffstat (limited to 'recipes/linux')
-rw-r--r--recipes/linux/linux-omap-psp-2.6.32/0046-ARM-OMAP-beagle-disable-uart-timeout.patch21
-rw-r--r--recipes/linux/linux-omap-psp_2.6.32.bb1
2 files changed, 22 insertions, 0 deletions
diff --git a/recipes/linux/linux-omap-psp-2.6.32/0046-ARM-OMAP-beagle-disable-uart-timeout.patch b/recipes/linux/linux-omap-psp-2.6.32/0046-ARM-OMAP-beagle-disable-uart-timeout.patch
new file mode 100644
index 0000000000..b0c0d0b891
--- /dev/null
+++ b/recipes/linux/linux-omap-psp-2.6.32/0046-ARM-OMAP-beagle-disable-uart-timeout.patch
@@ -0,0 +1,21 @@
+commit 06a8d6478752403a617ed9fb9f6b78c31ad25020
+Author: Joel A Fernandes <agnel.joel@gmail.com>
+Date: Tue Jun 21 17:31:13 2011 -0500
+
+ omap: Disable UART sleep timeout to avoid serial port problems on wakeup.
+
+ Signed-off-by: Joel A Fernandes <agnel.joel@gmail.com>
+
+diff --git a/arch/arm/mach-omap2/serial.c b/arch/arm/mach-omap2/serial.c
+index 19805a7..35a24af 100644
+--- a/arch/arm/mach-omap2/serial.c
++++ b/arch/arm/mach-omap2/serial.c
+@@ -36,7 +36,7 @@
+ #define UART_OMAP_NO_EMPTY_FIFO_READ_IP_REV 0x52
+ #define UART_OMAP_WER 0x17 /* Wake-up enable register */
+
+-#define DEFAULT_TIMEOUT (5 * HZ)
++#define DEFAULT_TIMEOUT 0
+
+ struct omap_uart_state {
+ int num;
diff --git a/recipes/linux/linux-omap-psp_2.6.32.bb b/recipes/linux/linux-omap-psp_2.6.32.bb
index da2e9430dd..11e1f06426 100644
--- a/recipes/linux/linux-omap-psp_2.6.32.bb
+++ b/recipes/linux/linux-omap-psp_2.6.32.bb
@@ -58,6 +58,7 @@ SRC_URI = "git://arago-project.org/git/projects/linux-omap3.git;protocol=http;br
file://0043-MTD-silence-ecc-errors-on-mtdblock0.patch \
file://0044-ARM-OMAP-beagle-every-known-beagle-except-revB-uses-.patch \
file://0045-ARM-OMAP-beagle-add-support-for-beagleFPGA-expansion.patch \
+ file://0046-ARM-OMAP-beagle-disable-uart-timeout.patch \
file://cam/0001-mt9t111-first-stab-at-merging-sensor-driver-based-on.patch \
file://cam/0002-mt9t111-Fix-all-checkpatch-errors.patch \
file://cam/0003-mt9t111-Pass-v4l2_int_device-data.patch \