aboutsummaryrefslogtreecommitdiffstats
path: root/recipes/linux
diff options
context:
space:
mode:
authorFlorian Boor <florian.boor@kernelconcepts.de>2009-04-22 12:58:54 +0200
committerFlorian Boor <florian.boor@kernelconcepts.de>2009-04-22 13:00:25 +0200
commit695bef534776d776f46515a4eaafdc3a007e5793 (patch)
treeaada8373d8c3810ffe4bd50a0e44b1db312c5834 /recipes/linux
parentdd8a979f49af06f840400d22fdf3305cc696a921 (diff)
downloadopenembedded-695bef534776d776f46515a4eaafdc3a007e5793.tar.gz
linux: 2.6.26 Add inital support for Topas910, we'll add a better kernel later.
Diffstat (limited to 'recipes/linux')
-rw-r--r--recipes/linux/linux_2.6.26.bb7
1 files changed, 6 insertions, 1 deletions
diff --git a/recipes/linux/linux_2.6.26.bb b/recipes/linux/linux_2.6.26.bb
index ff4ced7fec..53d55577b0 100644
--- a/recipes/linux/linux_2.6.26.bb
+++ b/recipes/linux/linux_2.6.26.bb
@@ -1,12 +1,14 @@
require linux.inc
-PR = "r8"
+PR = "r9"
# Mark archs/machines that this kernel supports
DEFAULT_PREFERENCE = "-1"
DEFAULT_PREFERENCE_boc01 = "1"
DEFAULT_PREFERENCE_mpc8313e-rdb = "1"
DEFAULT_PREFERENCE_canyonlands = "1"
+DEFAULT_PREFERENCE_topas910 = "1"
+
SRC_URI = "${KERNELORG_MIRROR}/pub/linux/kernel/v2.6/linux-2.6.26.tar.bz2 \
file://defconfig"
@@ -34,6 +36,9 @@ SRC_URI_append_mpc8313e-rdb = "\
file://mpc8313e-rdb-eth-fixed.patch;patch=1 \
"
+SRC_URI_append_topas910 = " ${KERNELORG_MIRROR}/pub/linux/kernel/v2.6/patch-2.6.26.5.bz2;patch=1 \
+ http://www.bplan-gmbh.org/data/toshiba/topas/linux/2.6.26.5/patch_2.6.26.5_topas910.bz2;patch=1"
+
# see http://bugzilla.kernel.org/show_bug.cgi?id=11143
do_stage_append() {
if [ -f arch/${ARCH}/lib/crtsavres.o ]; then