aboutsummaryrefslogtreecommitdiffstats
path: root/recipes/linux
diff options
context:
space:
mode:
authorMartin Jansa <Martin.Jansa@gmail.com>2010-10-18 21:12:03 +0200
committerMartin Jansa <Martin.Jansa@gmail.com>2010-10-18 21:24:10 +0200
commitd98685b02bbfb9aa6ed907fc57773521473c138e (patch)
treede385595cafe2a535c5aabdedecf49e5868c2227 /recipes/linux
parent78f4e57aa4343c339e5bcb5c06a326970d4a1bee (diff)
downloadopenembedded-d98685b02bbfb9aa6ed907fc57773521473c138e.tar.gz
linux-openmoko-2.6.34: add tslib patch from qtmoko
Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com>
Diffstat (limited to 'recipes/linux')
-rw-r--r--recipes/linux/linux-openmoko-2.6.34/0021-tslib-relies-on-ts-pressures-events-so-this-hack-is-.patch41
-rw-r--r--recipes/linux/linux-openmoko-2.6.34_git.bb3
2 files changed, 43 insertions, 1 deletions
diff --git a/recipes/linux/linux-openmoko-2.6.34/0021-tslib-relies-on-ts-pressures-events-so-this-hack-is-.patch b/recipes/linux/linux-openmoko-2.6.34/0021-tslib-relies-on-ts-pressures-events-so-this-hack-is-.patch
new file mode 100644
index 0000000000..bd893c344a
--- /dev/null
+++ b/recipes/linux/linux-openmoko-2.6.34/0021-tslib-relies-on-ts-pressures-events-so-this-hack-is-.patch
@@ -0,0 +1,41 @@
+From f509194b68993cfa3566d4968f8fe0000ccc5afb Mon Sep 17 00:00:00 2001
+From: Arnaud Patard <arnaud.patard@rtp-net.org>
+Date: Tue, 17 Aug 2010 07:30:06 +0200
+Subject: [PATCH] tslib relies on ts pressures events so this hack is needed to get tslib stuff
+ working
+
+---
+ drivers/input/touchscreen/s3c2410_ts.c | 3 +++
+ 1 files changed, 3 insertions(+), 0 deletions(-)
+
+diff --git a/drivers/input/touchscreen/s3c2410_ts.c b/drivers/input/touchscreen/s3c2410_ts.c
+index 8fba8a8..ed5b437 100644
+--- a/drivers/input/touchscreen/s3c2410_ts.c
++++ b/drivers/input/touchscreen/s3c2410_ts.c
+@@ -144,6 +144,7 @@ static void touch_timer_fire(unsigned long data)
+ input_report_abs(ts.input, ABS_Y, ts.yp);
+
+ input_report_key(ts.input, BTN_TOUCH, 1);
++ input_report_abs(ts.input, ABS_PRESSURE, 1);
+ input_sync(ts.input);
+
+ ts.xp = 0;
+@@ -158,6 +159,7 @@ static void touch_timer_fire(unsigned long data)
+ ts.count = 0;
+
+ input_report_key(ts.input, BTN_TOUCH, 0);
++ input_report_abs(ts.input, ABS_PRESSURE, 0);
+ input_sync(ts.input);
+
+ ts.expectedintr = WAITFORINT_DOWN;
+@@ -343,6 +345,7 @@ static int __devinit s3c2410ts_probe(struct platform_device *pdev)
+ ts.input->keybit[BIT_WORD(BTN_TOUCH)] = BIT_MASK(BTN_TOUCH);
+ input_set_abs_params(ts.input, ABS_X, 0, 0x3FF, 0, 0);
+ input_set_abs_params(ts.input, ABS_Y, 0, 0x3FF, 0, 0);
++ input_set_abs_params(ts.input, ABS_PRESSURE, 0, 1, 0, 0);
+
+ ts.input->name = "S3C24XX TouchScreen";
+ ts.input->id.bustype = BUS_HOST;
+--
+1.7.3.1
+
diff --git a/recipes/linux/linux-openmoko-2.6.34_git.bb b/recipes/linux/linux-openmoko-2.6.34_git.bb
index 64a2f92bd5..9d22d9a11f 100644
--- a/recipes/linux/linux-openmoko-2.6.34_git.bb
+++ b/recipes/linux/linux-openmoko-2.6.34_git.bb
@@ -4,7 +4,7 @@ require linux-openmoko.inc
KERNEL_RELEASE="2.6.34.7"
SRCREV = "e4182f3551f1b8e8f8bd07a2d68e49a0ec4cd04a"
-OEV = "oe5"
+OEV = "oe6"
PV = "${KERNEL_RELEASE}-${OEV}+gitr${SRCPV}"
SRC_URI = "\
@@ -34,6 +34,7 @@ SRC_URI = "\
file://0018-Rename-dev-s3c2410_serialXXX-to-dev-ttySACXXX.patch \
file://0019-Enable-powering-off-after-8s-POWER-press.patch \
file://0020-GTA02-bt-remember-state-of-bluetooth-in-variable.patch \
+ file://0021-tslib-relies-on-ts-pressures-events-so-this-hack-is-.patch \
# fix PR2349
file://0010-mach-gta02-fix-PR2349-do-not-manage-down.patch \
file://defconfig \