aboutsummaryrefslogtreecommitdiffstats
path: root/recipes/linux
diff options
context:
space:
mode:
authorMike Westerhof <mwester@dls.net>2009-04-15 20:01:10 -0500
committerMike Westerhof <mwester@dls.net>2009-04-15 20:01:10 -0500
commitfb7eba513b2d59c33163bd380019a4cabc8b6782 (patch)
treef6ba44e483f05eb98a7f3619fe5ecb4785f5c682 /recipes/linux
parenta91ef39c62f371125a92098d4fbd45056122c384 (diff)
downloadopenembedded-fb7eba513b2d59c33163bd380019a4cabc8b6782.tar.gz
Openmoko: linux-openmoko-2.6.29 - commit new recipe tied to upstream kernel
git repo, which is currently at 2.6.29-rc3 + Openmoko patches. Note that the preferred kernel remains unchanged; select this kernel via local.conf.
Diffstat (limited to 'recipes/linux')
-rw-r--r--recipes/linux/linux-openmoko-2.6.29/defconfig-oe.patch12
-rw-r--r--recipes/linux/linux-openmoko-2.6.29/fix-install.patch23
-rw-r--r--recipes/linux/linux-openmoko-2.6.29_git.bb31
3 files changed, 66 insertions, 0 deletions
diff --git a/recipes/linux/linux-openmoko-2.6.29/defconfig-oe.patch b/recipes/linux/linux-openmoko-2.6.29/defconfig-oe.patch
new file mode 100644
index 0000000000..3f65387b78
--- /dev/null
+++ b/recipes/linux/linux-openmoko-2.6.29/defconfig-oe.patch
@@ -0,0 +1,12 @@
+--- gta02-packaging-defconfig 2009-01-12 13:09:33.000000000 +0000
++++ defconfig-oe 2009-01-12 13:18:23.000000000 +0000
+@@ -337,9 +337,6 @@
+ #
+ # At least one emulation must be selected
+ #
+-CONFIG_FPE_NWFPE=y
+-# CONFIG_FPE_NWFPE_XP is not set
+-# CONFIG_FPE_FASTFPE is not set
+
+ #
+ # Userspace binary formats
diff --git a/recipes/linux/linux-openmoko-2.6.29/fix-install.patch b/recipes/linux/linux-openmoko-2.6.29/fix-install.patch
new file mode 100644
index 0000000000..46bc25a50b
--- /dev/null
+++ b/recipes/linux/linux-openmoko-2.6.29/fix-install.patch
@@ -0,0 +1,23 @@
+From: Steve Sakoman <steve@sakoman.com>
+Date: Mon, 18 Aug 2008 16:07:31 +0000 (-0700)
+Subject: scripts/Makefile.fwinst: add missing space when setting mode in cmd_install
+X-Git-Url: http://www.sakoman.net/cgi-bin/gitweb.cgi?p=linux-omap-2.6.git;a=commitdiff_plain;h=f039944bdd491cde7327133e9976881d3133ae70
+
+scripts/Makefile.fwinst: add missing space when setting mode in cmd_install
+
+This was causing build failures on some machines
+---
+
+diff --git a/scripts/Makefile.fwinst b/scripts/Makefile.fwinst
+index 6bf8e87..fb20532 100644
+--- a/scripts/Makefile.fwinst
++++ b/scripts/Makefile.fwinst
+@@ -37,7 +37,7 @@ install-all-dirs: $(installed-fw-dirs)
+ @true
+
+ quiet_cmd_install = INSTALL $(subst $(srctree)/,,$@)
+- cmd_install = $(INSTALL) -m0644 $< $@
++ cmd_install = $(INSTALL) -m 0644 $< $@
+
+ $(installed-fw-dirs):
+ $(call cmd,mkdir)
diff --git a/recipes/linux/linux-openmoko-2.6.29_git.bb b/recipes/linux/linux-openmoko-2.6.29_git.bb
new file mode 100644
index 0000000000..19423509e8
--- /dev/null
+++ b/recipes/linux/linux-openmoko-2.6.29_git.bb
@@ -0,0 +1,31 @@
+require linux.inc
+require linux-openmoko.inc
+
+DESCRIPTION_${PN} = "Linux ${KERNEL_RELEASE} kernel for the Openmoko Neo GSM Smartphones"
+
+# NOTE: This recipe is tied to an upstream git repo; the KERNEL_VERSION must match the
+# the kernel version string as built, otherwise depmod will silently fail when building
+# the image itself. KERNEL_RELEASE should match the kernel version in the recipe name.
+# This may have to be adjusted as the upstream git repository changes!
+KERNEL_RELEASE = "2.6.29"
+KERNEL_VERSION = "2.6.29-rc3"
+
+OEV = "oe1"
+PV = "${KERNEL_RELEASE}-${OEV}+gitr${SRCREV}"
+PR = "r0"
+
+SRC_URI = "\
+ git://git.openmoko.org/git/kernel.git;protocol=git;branch=andy-tracking \
+ file://fix-install.patch;patch=1 \
+ file://defconfig-oe.patch \
+"
+S = "${WORKDIR}/git"
+
+CONFIG_NAME_om-gta01 = "gta01_moredrivers_defconfig"
+CONFIG_NAME_om-gta02 = "gta02_packaging_defconfig"
+CONFIG_NAME_om-gta03 = "gta03_defconfig"
+
+do_configure_prepend() {
+ install -m 644 ./arch/arm/configs/${CONFIG_NAME} ${WORKDIR}/defconfig-oe
+ cat ${WORKDIR}/defconfig-oe.patch | patch -p0 -d ${WORKDIR}
+}