summaryrefslogtreecommitdiffstats
path: root/recipes/linux
diff options
context:
space:
mode:
authorTom Rini <tom_rini@mentor.com>2010-08-20 11:06:29 -0700
committerTom Rini <tom_rini@mentor.com>2010-08-20 11:06:29 -0700
commit6059d55945c4ce090f976391944dd986e5b7702e (patch)
tree960c3e6844832eb87ce1dd73834fd1672bf83093 /recipes/linux
parentf484884f7e7db8bd3eb346bcd9d4d5d796355c93 (diff)
downloadopenembedded-6059d55945c4ce090f976391944dd986e5b7702e.tar.gz
linux-gumstix: Call uboot-mkimage and just use normal hook for DEPENDS
Signed-off-by: Tom Rini <tom_rini@mentor.com>
Diffstat (limited to 'recipes/linux')
-rw-r--r--recipes/linux/linux-gumstix_2.6.15.bb4
1 files changed, 1 insertions, 3 deletions
diff --git a/recipes/linux/linux-gumstix_2.6.15.bb b/recipes/linux/linux-gumstix_2.6.15.bb
index bc8b5e47b4..2c4a6132fc 100644
--- a/recipes/linux/linux-gumstix_2.6.15.bb
+++ b/recipes/linux/linux-gumstix_2.6.15.bb
@@ -3,8 +3,6 @@ SECTION = "kernel"
LICENSE = "GPLv2"
PR = "r2"
-DEPENDS = "u-boot-utils-native"
-
COMPATIBLE_MACHINE = "gumstix"
SRC_URI = "${KERNELORG_MIRROR}/pub/linux/kernel/v2.6/linux-${PV}.tar.bz2;name=kernel \
@@ -74,7 +72,7 @@ do_configure_prepend() {
do_deploy_append() {
${HOST_PREFIX}objcopy -O binary -R .note -R .comment -S arch/arm/boot/compressed/vmlinux arch/arm/boot/compressed/linux.bin
- mkimage -A arm -O linux -T kernel -C none -a 0xa0008000 -e 0xa0008000 -n "gumstix" -d arch/arm/boot/compressed/linux.bin arch/arm/boot/uImage
+ uboot-mkimage -A arm -O linux -T kernel -C none -a 0xa0008000 -e 0xa0008000 -n "gumstix" -d arch/arm/boot/compressed/linux.bin arch/arm/boot/uImage
install -d ${DEPLOY_DIR_IMAGE}
cp arch/arm/boot/uImage ${DEPLOY_DIR_IMAGE}/uImage-${PN}-${PV}
}