summaryrefslogtreecommitdiffstats
path: root/recipes/linux
diff options
context:
space:
mode:
authorKhem Raj <raj.khem@gmail.com>2010-08-22 20:08:09 -0700
committerKhem Raj <raj.khem@gmail.com>2010-08-23 08:11:51 -0700
commitde2e9637017afd18a895140ac85bb98cf1aef3e2 (patch)
tree8c9e7afef6dc2a234f627b6f110922d6c288b823 /recipes/linux
parent8fdc993235e83e50cc17acc6ee16cb697dd5de46 (diff)
downloadopenembedded-de2e9637017afd18a895140ac85bb98cf1aef3e2.tar.gz
linux-efikamx_2.6.31.bb: Add recipe for linux kernel used for Efika MX
Signed-off-by: Khem Raj <raj.khem@gmail.com> Acked-by: Frans Meulenbroeks <fransmeulenbroeks@gmail.com>
Diffstat (limited to 'recipes/linux')
-rw-r--r--recipes/linux/linux-efikamx_2.6.31.bb47
1 files changed, 47 insertions, 0 deletions
diff --git a/recipes/linux/linux-efikamx_2.6.31.bb b/recipes/linux/linux-efikamx_2.6.31.bb
new file mode 100644
index 0000000000..96eb682dfc
--- /dev/null
+++ b/recipes/linux/linux-efikamx_2.6.31.bb
@@ -0,0 +1,47 @@
+require linux.inc
+
+DESCRIPTION = "Linux kernel for EfikaMX platform"
+KERNEL_IMAGETYPE = "uImage"
+
+COMPATIBLE_MACHINE = "efikamx"
+
+python do_fetch () {
+ import os,shutil
+ bb.build.exec_func("base_do_fetch", d)
+ if os.access(bb.data.expand("${DL_DIR}/73", d), os.R_OK):
+ shutil.copy(bb.data.expand("${DL_DIR}/73", d), bb.data.expand("${DL_DIR}/${PN}-${PV}.tar.lzma", d))
+
+ if os.access(bb.data.expand("${DL_DIR}/83", d), os.R_OK):
+ shutil.copy(bb.data.expand("${DL_DIR}/83", d), bb.data.expand("${DL_DIR}/patch-${PV}.tar.lzma", d))
+}
+
+python do_unpack () {
+ bb.build.exec_func('efikamx_kernel_do_unpack', d)
+}
+
+efikamx_kernel_do_unpack () {
+ mkdir -p ${S}
+ tar xf ${DL_DIR}/${PN}-${PV}.tar.lzma --strip-components=1 -C ${S}
+ tar xf ${DL_DIR}/patch-${PV}.tar.lzma -C ${S}
+}
+
+python do_patch () {
+ bb.build.exec_func('efikamx_kernel_do_patch', d)
+}
+
+efikamx_kernel_do_patch (){
+ ( cd ${S}/patches; ls *.patch >series;cp *.config ${S}/../defconfig)
+ ( cd ${S}; quilt push -a)
+}
+
+SRC_URI += "http://www.powerdeveloper.org/asset/by-id/73;name=kernel \
+ http://www.powerdeveloper.org/asset/by-id/83;name=patch \
+ "
+
+SRC_URI[kernel.md5sum] = "c70ce0549cf85de79d5b28db7b552868"
+SRC_URI[kernel.sha256sum] = "658395072352cd38477d80c105f00d824c73bf437f0843579d1e0bf41066617f"
+
+SRC_URI[patch.md5sum] = "6c04416bce74dd413f3e82cd17378419"
+SRC_URI[patch.sha256sum] = "5c15cffa02089d286fc07ba734b1f33a81d1f7ceaf70e596bd8b82ddd5e73ec2"
+
+S = "${WORKDIR}/${PN}-${PV}"