aboutsummaryrefslogtreecommitdiffstats
path: root/recipes/linux
diff options
context:
space:
mode:
authorJoel A Fernandes <agnel.joel@gmail.com>2011-07-06 09:48:56 +0000
committerKoen Kooi <koen@openembedded.org>2011-07-11 09:32:00 +0200
commitd808b945d94e4dc789eebec4f62a342000fab154 (patch)
treedcfb63a8426af03baa1b1b67fe0b99cd0155a938 /recipes/linux
parent2801aee77746b7f7834bb9660a4458a07b321f35 (diff)
downloadopenembedded-d808b945d94e4dc789eebec4f62a342000fab154.tar.gz
linux-omap-psp: Fix the user button GPIO to the correct value for a BeagleBoard-xM
Signed-off-by: Joel A Fernandes <agnel.joel@gmail.com> Signed-off-by: Koen Kooi <koen@openembedded.org>
Diffstat (limited to 'recipes/linux')
-rw-r--r--recipes/linux/linux-omap-psp-2.6.32/beagleboard-xmc/0008-omap3-beagle-cleaned-up-board-revision-conditions.patch4
-rw-r--r--recipes/linux/linux-omap-psp_2.6.32.bb2
2 files changed, 3 insertions, 3 deletions
diff --git a/recipes/linux/linux-omap-psp-2.6.32/beagleboard-xmc/0008-omap3-beagle-cleaned-up-board-revision-conditions.patch b/recipes/linux/linux-omap-psp-2.6.32/beagleboard-xmc/0008-omap3-beagle-cleaned-up-board-revision-conditions.patch
index 513a1019c2..fb91cb6f28 100644
--- a/recipes/linux/linux-omap-psp-2.6.32/beagleboard-xmc/0008-omap3-beagle-cleaned-up-board-revision-conditions.patch
+++ b/recipes/linux/linux-omap-psp-2.6.32/beagleboard-xmc/0008-omap3-beagle-cleaned-up-board-revision-conditions.patch
@@ -143,8 +143,8 @@ index 4bde54b..664a9c6 100644
omap3_beagle_i2c_init();
- if (cpu_is_omap3630()) {
-+ if ((omap3_beagle_get_rev() != OMAP3BEAGLE_BOARD_XMAB) &&
-+ (omap3_beagle_get_rev() != OMAP3BEAGLE_BOARD_XMC)) {
++ if ((omap3_beagle_get_rev() == OMAP3BEAGLE_BOARD_XMAB) ||
++ (omap3_beagle_get_rev() == OMAP3BEAGLE_BOARD_XMC)) {
gpio_buttons[0].gpio = 4;
}
diff --git a/recipes/linux/linux-omap-psp_2.6.32.bb b/recipes/linux/linux-omap-psp_2.6.32.bb
index ff9e1664cb..e33dc51f2b 100644
--- a/recipes/linux/linux-omap-psp_2.6.32.bb
+++ b/recipes/linux/linux-omap-psp_2.6.32.bb
@@ -9,7 +9,7 @@ COMPATIBLE_MACHINE = "am3517-crane|beagleboard|omap3evm|am3517-evm|dm37x-evm|am3
SRCREV = "5fc29e7b2a76a64a739f857858ef0b98294aa155"
# The main PR is now using MACHINE_KERNEL_PR, for omap3 see conf/machine/include/omap3.inc
-MACHINE_KERNEL_PR_append = "d+gitr${SRCREV}"
+MACHINE_KERNEL_PR_append = "e+gitr${SRCREV}"
SRC_URI = "git://arago-project.org/git/projects/linux-omap3.git;protocol=http;branch=master \
file://0001-Added-Crane-Board-support.patch \