summaryrefslogtreecommitdiffstats
path: root/recipes/literki/literki_git.bb
diff options
context:
space:
mode:
authorYann Dirson <ydirson@altern.org>2010-08-03 12:59:43 +0000
committerEric Bénard <eric@eukrea.com>2010-11-06 22:16:09 +0100
commitf53dd8f34c98380c8f8f13398b4e074cc79dfdd6 (patch)
treed3aff333149c699a03e87c4bcf4a6deb95f0fdcf /recipes/literki/literki_git.bb
parentc6551e24443066c7e3c8d40b1766c0f45553fb2a (diff)
downloadopenembedded-f53dd8f34c98380c8f8f13398b4e074cc79dfdd6.tar.gz
literki: initial packaging.
No formal release yet, although upstreams ships an ipk with a version and a packaging revision, so we pull from git. Patches: - Makefile was completely broken and had no install target, rewrites most of it. - author has put a "switcher" feature in it, which is non-functional, disable it in conffile - in the area in which the "slide" to bringup the keyboard starts, drags are not propagated to window below; make the area smaller so we can unlock the screen Signed-off-by: Yann Dirson <ydirson@altern.org> Signed-off-by: Eric Bénard <eric@eukrea.com>
Diffstat (limited to 'recipes/literki/literki_git.bb')
-rw-r--r--recipes/literki/literki_git.bb35
1 files changed, 35 insertions, 0 deletions
diff --git a/recipes/literki/literki_git.bb b/recipes/literki/literki_git.bb
new file mode 100644
index 0000000000..ff497bb5e5
--- /dev/null
+++ b/recipes/literki/literki_git.bb
@@ -0,0 +1,35 @@
+DESCRIPTION = "Literki overlay keyboard"
+SECTION = "x11"
+LICENSE = "GPL"
+HOMEPAGE = "http://www.opkg.org/package_232.html"
+
+SRCREV = "master"
+PR = "r0.1"
+
+# TODO:
+# steal from http://users.tkk.fi/~tajyrink/moko/literki_mods/
+
+SRC_URI = "git://git.senfdax.de/git/literki;protocol=http"
+SRC_URI += "file://makefile.patch"
+SRC_URI += "file://noswitcher.patch"
+SRC_URI += "file://sliderheight.patch"
+
+PV = "${SRCPV}"
+
+DEPENDS += " \
+ freetype \
+ libxtst \
+ libxext \
+ libxrandr \
+ libpng \
+ libfakekey \
+"
+
+S = "${WORKDIR}/git"
+PACKAGES = "${PN}"
+
+inherit base
+
+do_install() {
+ oe_runmake DESTDIR=${D} install
+}