aboutsummaryrefslogtreecommitdiffstats
path: root/recipes/live555
diff options
context:
space:
mode:
authorOttavio Campana <ottavio@campana.vi.it>2009-06-09 21:21:23 +0000
committerKoen Kooi <koen@openembedded.org>2009-06-30 20:18:38 +0200
commit378be0dcdc32126268b05329b980dd574d695fe9 (patch)
tree4099f992377eb6989c80eaf083e0e7559464e19c /recipes/live555
parentbb6a5a722b0845baad602a51daf3304e6c2ef1ad (diff)
downloadopenembedded-378be0dcdc32126268b05329b980dd574d695fe9.tar.gz
live555: update to 2009.06
Signed-off-by: Koen Kooi <koen@openembedded.org>
Diffstat (limited to 'recipes/live555')
-rw-r--r--recipes/live555/live555_20090602.bb42
1 files changed, 42 insertions, 0 deletions
diff --git a/recipes/live555/live555_20090602.bb b/recipes/live555/live555_20090602.bb
new file mode 100644
index 0000000000..8d1a314f35
--- /dev/null
+++ b/recipes/live555/live555_20090602.bb
@@ -0,0 +1,42 @@
+# live555 OE build file
+# Copyright (C) 2005, Koninklijke Philips Electronics NV. All Rights Reserved
+# Released under the MIT license (see packages/COPYING)
+
+DESCRIPTION = "LIVE555 Streaming Media libraries"
+HOMEPAGE = "http://live.com/"
+LICENSE = "LGPL"
+SECTION = "devel"
+
+SRC_URI = "http://www.live555.com/liveMedia/public/live.2009.06.02.tar.gz \
+ file://config.linux-cross"
+
+S = "${WORKDIR}/live"
+
+do_configure() {
+ cp ${WORKDIR}/config.linux-cross .
+ ./genMakefiles linux-cross
+}
+
+do_compile() {
+ make
+}
+
+do_install() {
+ install -d ${D}${includedir}/BasicUsageEnvironment
+ install -d ${D}${includedir}/groupsock
+ install -d ${D}${includedir}/liveMedia
+ install -d ${D}${includedir}/UsageEnvironment
+ install -d ${D}${libdir}
+ cp -a ${S}/BasicUsageEnvironment/include/*.hh ${D}${includedir}/BasicUsageEnvironment/
+ cp -a ${S}/groupsock/include/*.h ${D}${includedir}/groupsock/
+ cp -a ${S}/groupsock/include/*.hh ${D}${includedir}/groupsock/
+ cp -a ${S}/liveMedia/include/*.hh ${D}${includedir}/liveMedia/
+ cp -a ${S}/UsageEnvironment/include/*.hh ${D}${includedir}/UsageEnvironment/
+ cp ${S}/*/*.a ${D}${libdir}
+}
+
+do_stage () {
+ cp -a ${D}${includedir}/* ${STAGING_INCDIR}
+ cp -a ${D}${libdir}/* ${STAGING_LIBDIR}
+}
+