aboutsummaryrefslogtreecommitdiffstats
path: root/recipes/live555
diff options
context:
space:
mode:
authorKoen Kooi <koen@openembedded.org>2009-07-17 14:15:34 +0200
committerKoen Kooi <koen@openembedded.org>2009-07-17 14:15:34 +0200
commitfe82eb4b983cb2ae01a3857f766151b3379fd236 (patch)
tree58e7298caacfd83634e3267b97e8e42888d33bd7 /recipes/live555
parent852d21c0369f8b499931098fdc55eea59116402f (diff)
downloadopenembedded-fe82eb4b983cb2ae01a3857f766151b3379fd236.tar.gz
live555: fix staging
Diffstat (limited to 'recipes/live555')
-rw-r--r--recipes/live555/live555_20090602.bb16
1 files changed, 14 insertions, 2 deletions
diff --git a/recipes/live555/live555_20090602.bb b/recipes/live555/live555_20090602.bb
index 8d1a314f35..c6438bce6e 100644
--- a/recipes/live555/live555_20090602.bb
+++ b/recipes/live555/live555_20090602.bb
@@ -7,6 +7,8 @@ HOMEPAGE = "http://live.com/"
LICENSE = "LGPL"
SECTION = "devel"
+PR = "r1"
+
SRC_URI = "http://www.live555.com/liveMedia/public/live.2009.06.02.tar.gz \
file://config.linux-cross"
@@ -36,7 +38,17 @@ do_install() {
}
do_stage () {
- cp -a ${D}${includedir}/* ${STAGING_INCDIR}
- cp -a ${D}${libdir}/* ${STAGING_LIBDIR}
+ install -d ${STAGING_INCDIR}/
+ install -d ${STAGING_LIBDIR}/
+
+ # Find all the headers
+ for i in $(find . -name "*.hh") $(find . -name "*.h") ; do
+ install ${i} ${STAGING_INCDIR}/
+ done
+
+ # Find the libs *.a
+ for i in $(find . -name "*.a") ; do
+ install ${i} ${STAGING_LIBDIR}
+ done
}