aboutsummaryrefslogtreecommitdiffstats
path: root/recipes/llvm/llvm2.7_2.7.bb
diff options
context:
space:
mode:
authorRobert Schuster <robertschuster@fsfe.org>2010-06-11 13:20:00 +0200
committerRobert Schuster <robertschuster@fsfe.org>2010-06-11 13:21:21 +0200
commit5356193d0f64dfdb0b9fb500357a183a6f2c2316 (patch)
treeddc21c09cb3090412702b6799236b9338da351ef /recipes/llvm/llvm2.7_2.7.bb
parenta7bcc78ad94a7cbce2fd5da6fc3f54ae09228f8b (diff)
downloadopenembedded-5356193d0f64dfdb0b9fb500357a183a6f2c2316.tar.gz
llvm.inc: fixed typo.
llvm2.7 2.7: Build with shared library, added patch to work around not correctly linking libgcc.
Diffstat (limited to 'recipes/llvm/llvm2.7_2.7.bb')
-rw-r--r--recipes/llvm/llvm2.7_2.7.bb4
1 files changed, 3 insertions, 1 deletions
diff --git a/recipes/llvm/llvm2.7_2.7.bb b/recipes/llvm/llvm2.7_2.7.bb
index b72581c7e3..623f6fa4b8 100644
--- a/recipes/llvm/llvm2.7_2.7.bb
+++ b/recipes/llvm/llvm2.7_2.7.bb
@@ -1,17 +1,19 @@
require llvm.inc
-PR = "r0"
+PR = "r1"
DEPENDS = "llvm-common llvm2.7-native"
SRC_URI = "\
http://llvm.org/releases/${PV}/llvm-${PV}.tgz \
file://BX_to_BLX.patch \
+ file://link.patch \
"
EXTRA_OECMAKE += "\
-DLLVM_TARGET_ARCH:STRING=${LLVM_ARCH} \
-DLLVM_ENABLE_ASSERTIONS:BOOL=ON \
+ -DBUILD_SHARED_LIBS:BOOL=ON \
-DCMAKE_BUILD_TYPE:STRING=RelWithDebInfo \
"