aboutsummaryrefslogtreecommitdiffstats
path: root/recipes/llvm
diff options
context:
space:
mode:
authorRobert Schuster <robertschuster@fsfe.org>2009-05-13 13:34:30 +0200
committerRobert Schuster <robertschuster@fsfe.org>2009-05-13 13:34:30 +0200
commit49608b50121cf83d21c4616ca048d1dff86e1efa (patch)
tree64c1dca7237c885f050349e4b92405cb8f665187 /recipes/llvm
parent8079cec72c1014c1676a6de10a6eb4709d9e812d (diff)
downloadopenembedded-49608b50121cf83d21c4616ca048d1dff86e1efa.tar.gz
llvm2.6: Updated to newer SVN snapshot (includes some patches developed in OE).
llvm2.6-native: Dito.
Diffstat (limited to 'recipes/llvm')
-rw-r--r--recipes/llvm/llvm2.6-native_2.5+svnr20090511.bb (renamed from recipes/llvm/llvm2.6-native_2.5+svnr20090504.bb)3
-rw-r--r--recipes/llvm/llvm2.6/llvm-fix-have_libpthread.patch29
-rw-r--r--recipes/llvm/llvm2.6/llvm-fix-pthreads_h.patch14
-rw-r--r--recipes/llvm/llvm2.6_2.5+svnr20090511.bb (renamed from recipes/llvm/llvm2.6_2.5+svnr20090504.bb)4
4 files changed, 2 insertions, 48 deletions
diff --git a/recipes/llvm/llvm2.6-native_2.5+svnr20090504.bb b/recipes/llvm/llvm2.6-native_2.5+svnr20090511.bb
index 86397c9920..119e191856 100644
--- a/recipes/llvm/llvm2.6-native_2.5+svnr20090504.bb
+++ b/recipes/llvm/llvm2.6-native_2.5+svnr20090511.bb
@@ -1,6 +1,6 @@
require llvm-native.inc
-SRCREV = "70854"
+SRCREV = "71428"
PV = "2.5+svnr${SRCREV}"
@@ -9,7 +9,6 @@ PR = "r0"
SRC_URI = "\
svn://llvm.org/svn/llvm-project/llvm/;proto=http;module=trunk \
file://fix-build.patch;patch=1 \
- file://llvm-enable-threads-macro.patch;patch=1;pnum=0 \
file://llvm-debugonly-zeroormore.patch;patch=1;pnum=0 \
"
diff --git a/recipes/llvm/llvm2.6/llvm-fix-have_libpthread.patch b/recipes/llvm/llvm2.6/llvm-fix-have_libpthread.patch
deleted file mode 100644
index f1072d9af9..0000000000
--- a/recipes/llvm/llvm2.6/llvm-fix-have_libpthread.patch
+++ /dev/null
@@ -1,29 +0,0 @@
-Index: trunk/include/llvm/Config/config.h.cmake
-===================================================================
---- trunk.orig/include/llvm/Config/config.h.cmake 2009-05-06 16:39:19.957841609 +0200
-+++ trunk/include/llvm/Config/config.h.cmake 2009-05-06 16:39:20.185842055 +0200
-@@ -194,7 +194,7 @@
- #cmakedefine HAVE_LIBPSAPI ${HAVE_LIBPSAPI}
-
- /* Define to 1 if you have the `pthread' library (-lpthread). */
--#undef HAVE_LIBPTHREAD
-+#cmakedefine HAVE_LIBPTHREAD ${HAVE_LIBPTHREAD}
-
- /* Define to 1 if you have the `udis86' library (-ludis86). */
- #undef HAVE_LIBUDIS86
-Index: trunk/cmake/config-ix.cmake
-===================================================================
---- trunk.orig/cmake/config-ix.cmake 2009-05-06 16:49:45.121841057 +0200
-+++ trunk/cmake/config-ix.cmake 2009-05-06 16:50:25.738552620 +0200
-@@ -98,6 +98,11 @@
- if( HAVE_PTHREAD_H OR WIN32 )
- set(ENABLE_THREADS 1)
- endif()
-+
-+# FIXME: Actually check for the library
-+ if( HAVE_PTHREAD_H )
-+ set(HAVE_LIBPTHREAD 1)
-+ endif()
- endif()
-
- if( ENABLE_THREADS )
diff --git a/recipes/llvm/llvm2.6/llvm-fix-pthreads_h.patch b/recipes/llvm/llvm2.6/llvm-fix-pthreads_h.patch
deleted file mode 100644
index 6f17b850f6..0000000000
--- a/recipes/llvm/llvm2.6/llvm-fix-pthreads_h.patch
+++ /dev/null
@@ -1,14 +0,0 @@
-Index: include/llvm/Config/config.h.cmake
-===================================================================
---- include/llvm/Config/config.h.cmake (Revision 71077)
-+++ include/llvm/Config/config.h.cmake (Arbeitskopie)
-@@ -276,6 +276,9 @@
- /* Define to have the %a format string */
- #undef HAVE_PRINTF_A
-
-+/* Have pthread.h */
-+#cmakedefine HAVE_PTHREAD_H ${HAVE_PTHREAD_H}
-+
- /* Have pthread_mutex_lock */
- #cmakedefine HAVE_PTHREAD_MUTEX_LOCK ${HAVE_PTHREAD_MUTEX_LOCK}
-
diff --git a/recipes/llvm/llvm2.6_2.5+svnr20090504.bb b/recipes/llvm/llvm2.6_2.5+svnr20090511.bb
index 9ba13ceadc..035d021f7d 100644
--- a/recipes/llvm/llvm2.6_2.5+svnr20090504.bb
+++ b/recipes/llvm/llvm2.6_2.5+svnr20090511.bb
@@ -1,6 +1,6 @@
require llvm.inc
-SRCREV = "70854"
+SRCREV = "71428"
PV = "2.5+svnr${SRCREV}"
@@ -12,8 +12,6 @@ SRC_URI = "\
svn://llvm.org/svn/llvm-project/llvm/;proto=http;module=trunk \
file://fix-build.patch;patch=1 \
file://llvm-debugonly-zeroormore.patch;patch=1;pnum=0 \
- file://llvm-fix-pthreads_h.patch;patch=1;pnum=0 \
- file://llvm-fix-have_libpthread.patch;patch=1 \
"
S = "${WORKDIR}/trunk"