aboutsummaryrefslogtreecommitdiffstats
path: root/recipes/llvm
diff options
context:
space:
mode:
authorChris Larson <chris_larson@mentor.com>2010-05-23 20:23:53 -0700
committerChris Larson <chris_larson@mentor.com>2010-05-25 12:53:41 -0700
commitbf7d0467a0788a7fcc1c96e0dc35a25ae09278a0 (patch)
tree96f28e2f5133d68c3e3dadabaa2339340671454f /recipes/llvm
parentfab0af3aefee22b21541e403d3c356a6979bfa63 (diff)
downloadopenembedded-bf7d0467a0788a7fcc1c96e0dc35a25ae09278a0.tar.gz
Rename url params patch=<ignored>/pnum=<n> to apply={yes,no}/striplevel=<n>
I think this makes the behavior rather more clear. Signed-off-by: Chris Larson <chris_larson@mentor.com> Acked-by: Denys Dmytriyenko <denis@denix.org> Acked-by: Khem Raj <raj.khem@gmail.com>
Diffstat (limited to 'recipes/llvm')
-rw-r--r--recipes/llvm/llvm2.5-native_2.5.bb2
-rw-r--r--recipes/llvm/llvm2.5_2.5.bb2
-rw-r--r--recipes/llvm/llvm2.6-native_2.6.bb4
-rw-r--r--recipes/llvm/llvm2.6_2.6.bb6
-rw-r--r--recipes/llvm/llvm2.7_2.7.bb2
5 files changed, 8 insertions, 8 deletions
diff --git a/recipes/llvm/llvm2.5-native_2.5.bb b/recipes/llvm/llvm2.5-native_2.5.bb
index f6ed05995b..bb41e88939 100644
--- a/recipes/llvm/llvm2.5-native_2.5.bb
+++ b/recipes/llvm/llvm2.5-native_2.5.bb
@@ -1,6 +1,6 @@
require llvm-native.inc
-SRC_URI += "file://fix-build.patch;patch=1"
+SRC_URI += "file://fix-build.patch;apply=yes"
SRC_URI[md5sum] = "55df2ea8665c8094ad2ef85187b9fc74"
diff --git a/recipes/llvm/llvm2.5_2.5.bb b/recipes/llvm/llvm2.5_2.5.bb
index 02094ac98d..d76fd8dd94 100644
--- a/recipes/llvm/llvm2.5_2.5.bb
+++ b/recipes/llvm/llvm2.5_2.5.bb
@@ -1,6 +1,6 @@
require llvm.inc
-SRC_URI += "file://fix-build.patch;patch=1"
+SRC_URI += "file://fix-build.patch;apply=yes"
SRC_URI[md5sum] = "55df2ea8665c8094ad2ef85187b9fc74"
diff --git a/recipes/llvm/llvm2.6-native_2.6.bb b/recipes/llvm/llvm2.6-native_2.6.bb
index fa28970680..102789a7b6 100644
--- a/recipes/llvm/llvm2.6-native_2.6.bb
+++ b/recipes/llvm/llvm2.6-native_2.6.bb
@@ -3,8 +3,8 @@ require llvm-native.inc
PR = "r0"
SRC_URI += "\
- file://fix-build.patch;patch=1 \
- file://llvm-debugonly-zeroormore.patch;patch=1;pnum=0 \
+ file://fix-build.patch;apply=yes \
+ file://llvm-debugonly-zeroormore.patch;apply=yes;striplevel=0 \
"
LLVM_RELEASE = "2.6"
diff --git a/recipes/llvm/llvm2.6_2.6.bb b/recipes/llvm/llvm2.6_2.6.bb
index c476f34bcb..408428a25b 100644
--- a/recipes/llvm/llvm2.6_2.6.bb
+++ b/recipes/llvm/llvm2.6_2.6.bb
@@ -5,9 +5,9 @@ PR = "r1"
DEPENDS = "llvm-common llvm2.6-native"
SRC_URI += "\
- file://fix-build.patch;patch=1 \
- file://llvm-debugonly-zeroormore.patch;patch=1;pnum=0 \
- file://BX_to_BLX.patch;patch=1 \
+ file://fix-build.patch;apply=yes \
+ file://llvm-debugonly-zeroormore.patch;apply=yes;striplevel=0 \
+ file://BX_to_BLX.patch;apply=yes \
"
LLVM_RELEASE = "2.6"
diff --git a/recipes/llvm/llvm2.7_2.7.bb b/recipes/llvm/llvm2.7_2.7.bb
index 587bffb29b..e27b8ae79b 100644
--- a/recipes/llvm/llvm2.7_2.7.bb
+++ b/recipes/llvm/llvm2.7_2.7.bb
@@ -6,7 +6,7 @@ DEPENDS = "llvm-common llvm2.7-native"
SRC_URI = "\
http://llvm.org/releases/${PV}/llvm-${PV}.tgz \
- file://BX_to_BLX.patch;patch=1 \
+ file://BX_to_BLX.patch;apply=yes \
"
EXTRA_OECMAKE += "\