aboutsummaryrefslogtreecommitdiffstats
path: root/recipes/llvm
diff options
context:
space:
mode:
authorHenning Heinold <heinold@inf.fu-berlin.de>2010-07-08 00:12:00 +0200
committerHenning Heinold <heinold@inf.fu-berlin.de>2010-07-08 15:50:21 +0200
commit22afd95e74d273b228c7aa685a81d14f16ae1e3c (patch)
treeedb0f7c2a3ab9084234360e83681f06c78ddccb7 /recipes/llvm
parent54f7168696f6b179986511916ce39a53c0f7825f (diff)
downloadopenembedded-22afd95e74d273b228c7aa685a81d14f16ae1e3c.tar.gz
llvm-common: use new staging system and switch to BBCLASSEXTENDED
Diffstat (limited to 'recipes/llvm')
-rw-r--r--recipes/llvm/llvm-common-native.bb12
-rw-r--r--recipes/llvm/llvm-common.bb10
2 files changed, 4 insertions, 18 deletions
diff --git a/recipes/llvm/llvm-common-native.bb b/recipes/llvm/llvm-common-native.bb
deleted file mode 100644
index c2b79bd6a5..0000000000
--- a/recipes/llvm/llvm-common-native.bb
+++ /dev/null
@@ -1,12 +0,0 @@
-require llvm-common.bb
-
-inherit native
-
-do_install() {
- :
-}
-
-do_stage() {
- install -d ${STAGING_BINDIR}
- install -m 0755 ${WORKDIR}/llvm-config ${STAGING_BINDIR}
-}
diff --git a/recipes/llvm/llvm-common.bb b/recipes/llvm/llvm-common.bb
index b7f2bfc011..9c1a4e538c 100644
--- a/recipes/llvm/llvm-common.bb
+++ b/recipes/llvm/llvm-common.bb
@@ -1,14 +1,12 @@
DESCRIPTION = "Helper script for OE's llvm support"
+BBCLASSEXTEND = "native"
+
SRC_URI = "file://llvm-config"
PACKAGES = ""
do_install() {
- :
-}
-
-do_stage() {
- install -d ${STAGING_BINDIR_CROSS}
- install -m 0755 ${WORKDIR}/llvm-config ${STAGING_BINDIR_CROSS}
+ install -d ${D}${bindir}
+ install -m 0755 ${WORKDIR}/llvm-config ${D}${bindir}
}