aboutsummaryrefslogtreecommitdiffstats
path: root/recipes/llvm
diff options
context:
space:
mode:
authorRobert Schuster <robertschuster@fsfe.org>2010-06-11 13:20:00 +0200
committerRobert Schuster <robertschuster@fsfe.org>2010-06-11 13:21:21 +0200
commit5356193d0f64dfdb0b9fb500357a183a6f2c2316 (patch)
treeddc21c09cb3090412702b6799236b9338da351ef /recipes/llvm
parenta7bcc78ad94a7cbce2fd5da6fc3f54ae09228f8b (diff)
downloadopenembedded-5356193d0f64dfdb0b9fb500357a183a6f2c2316.tar.gz
llvm.inc: fixed typo.
llvm2.7 2.7: Build with shared library, added patch to work around not correctly linking libgcc.
Diffstat (limited to 'recipes/llvm')
-rw-r--r--recipes/llvm/llvm.inc2
-rw-r--r--recipes/llvm/llvm2.7/link.patch12
-rw-r--r--recipes/llvm/llvm2.7_2.7.bb4
3 files changed, 16 insertions, 2 deletions
diff --git a/recipes/llvm/llvm.inc b/recipes/llvm/llvm.inc
index 3c22318e33..3e11318743 100644
--- a/recipes/llvm/llvm.inc
+++ b/recipes/llvm/llvm.inc
@@ -13,7 +13,7 @@
# fixed (report bug).
#
# However the *recipe* for your program/library *must* declare
-# export WANT_LLVM_RELEASE = "<valid version number>
+# export WANT_LLVM_RELEASE = "<valid version number>"
# The version number is picked up by a generic wrapper script which just calls
# the variant of the specified version.
diff --git a/recipes/llvm/llvm2.7/link.patch b/recipes/llvm/llvm2.7/link.patch
new file mode 100644
index 0000000000..059bd92295
--- /dev/null
+++ b/recipes/llvm/llvm2.7/link.patch
@@ -0,0 +1,12 @@
+Index: llvm-2.7/tools/llvm-shlib/Makefile
+===================================================================
+--- llvm-2.7/tools/llvm-shlib/Makefile (revision 103711)
++++ llvm-2.7/tools/llvm-shlib/Makefile (working copy)
+@@ -56,5 +56,5 @@
+ LLVMLibsOptions := -Wl,--whole-archive $(LLVMLibsOptions)
+ -Wl,--no-whole-archive
+ # Don't allow unresolved symbols.
+- LLVMLibsOptions += -Wl,--no-undefined
++ LLVMLibsOptions += -lgcc -Wl,--no-undefined
+ endif
+
diff --git a/recipes/llvm/llvm2.7_2.7.bb b/recipes/llvm/llvm2.7_2.7.bb
index b72581c7e3..623f6fa4b8 100644
--- a/recipes/llvm/llvm2.7_2.7.bb
+++ b/recipes/llvm/llvm2.7_2.7.bb
@@ -1,17 +1,19 @@
require llvm.inc
-PR = "r0"
+PR = "r1"
DEPENDS = "llvm-common llvm2.7-native"
SRC_URI = "\
http://llvm.org/releases/${PV}/llvm-${PV}.tgz \
file://BX_to_BLX.patch \
+ file://link.patch \
"
EXTRA_OECMAKE += "\
-DLLVM_TARGET_ARCH:STRING=${LLVM_ARCH} \
-DLLVM_ENABLE_ASSERTIONS:BOOL=ON \
+ -DBUILD_SHARED_LIBS:BOOL=ON \
-DCMAKE_BUILD_TYPE:STRING=RelWithDebInfo \
"