aboutsummaryrefslogtreecommitdiffstats
path: root/recipes/llvm
diff options
context:
space:
mode:
authorChris Larson <chris_larson@mentor.com>2010-05-24 13:01:00 -0700
committerChris Larson <chris_larson@mentor.com>2010-05-25 12:54:52 -0700
commit6fe7cef27069415f2eba36bc640cf59013d4979b (patch)
treeb0cb8845ddc6b8bcffc50e08a2eeae98e049be98 /recipes/llvm
parentbf7d0467a0788a7fcc1c96e0dc35a25ae09278a0 (diff)
downloadopenembedded-6fe7cef27069415f2eba36bc640cf59013d4979b.tar.gz
Make the do_patch apply=yes param implicit if extension is .diff/.patch
For .diff/.patch you need to apply manually, you can specify apply=no. Signed-off-by: Chris Larson <chris_larson@mentor.com> Acked-by: Denys Dmytriyenko <denis@denix.org> Acked-by: Khem Raj <raj.khem@gmail.com>
Diffstat (limited to 'recipes/llvm')
-rw-r--r--recipes/llvm/llvm2.5-native_2.5.bb2
-rw-r--r--recipes/llvm/llvm2.5_2.5.bb2
-rw-r--r--recipes/llvm/llvm2.6-native_2.6.bb4
-rw-r--r--recipes/llvm/llvm2.6_2.6.bb6
-rw-r--r--recipes/llvm/llvm2.7_2.7.bb2
5 files changed, 8 insertions, 8 deletions
diff --git a/recipes/llvm/llvm2.5-native_2.5.bb b/recipes/llvm/llvm2.5-native_2.5.bb
index bb41e88939..416e0683b7 100644
--- a/recipes/llvm/llvm2.5-native_2.5.bb
+++ b/recipes/llvm/llvm2.5-native_2.5.bb
@@ -1,6 +1,6 @@
require llvm-native.inc
-SRC_URI += "file://fix-build.patch;apply=yes"
+SRC_URI += "file://fix-build.patch"
SRC_URI[md5sum] = "55df2ea8665c8094ad2ef85187b9fc74"
diff --git a/recipes/llvm/llvm2.5_2.5.bb b/recipes/llvm/llvm2.5_2.5.bb
index d76fd8dd94..301aa47365 100644
--- a/recipes/llvm/llvm2.5_2.5.bb
+++ b/recipes/llvm/llvm2.5_2.5.bb
@@ -1,6 +1,6 @@
require llvm.inc
-SRC_URI += "file://fix-build.patch;apply=yes"
+SRC_URI += "file://fix-build.patch"
SRC_URI[md5sum] = "55df2ea8665c8094ad2ef85187b9fc74"
diff --git a/recipes/llvm/llvm2.6-native_2.6.bb b/recipes/llvm/llvm2.6-native_2.6.bb
index 102789a7b6..dec132a8c1 100644
--- a/recipes/llvm/llvm2.6-native_2.6.bb
+++ b/recipes/llvm/llvm2.6-native_2.6.bb
@@ -3,8 +3,8 @@ require llvm-native.inc
PR = "r0"
SRC_URI += "\
- file://fix-build.patch;apply=yes \
- file://llvm-debugonly-zeroormore.patch;apply=yes;striplevel=0 \
+ file://fix-build.patch \
+ file://llvm-debugonly-zeroormore.patch;striplevel=0 \
"
LLVM_RELEASE = "2.6"
diff --git a/recipes/llvm/llvm2.6_2.6.bb b/recipes/llvm/llvm2.6_2.6.bb
index 408428a25b..35aa38fe76 100644
--- a/recipes/llvm/llvm2.6_2.6.bb
+++ b/recipes/llvm/llvm2.6_2.6.bb
@@ -5,9 +5,9 @@ PR = "r1"
DEPENDS = "llvm-common llvm2.6-native"
SRC_URI += "\
- file://fix-build.patch;apply=yes \
- file://llvm-debugonly-zeroormore.patch;apply=yes;striplevel=0 \
- file://BX_to_BLX.patch;apply=yes \
+ file://fix-build.patch \
+ file://llvm-debugonly-zeroormore.patch;striplevel=0 \
+ file://BX_to_BLX.patch \
"
LLVM_RELEASE = "2.6"
diff --git a/recipes/llvm/llvm2.7_2.7.bb b/recipes/llvm/llvm2.7_2.7.bb
index e27b8ae79b..b72581c7e3 100644
--- a/recipes/llvm/llvm2.7_2.7.bb
+++ b/recipes/llvm/llvm2.7_2.7.bb
@@ -6,7 +6,7 @@ DEPENDS = "llvm-common llvm2.7-native"
SRC_URI = "\
http://llvm.org/releases/${PV}/llvm-${PV}.tgz \
- file://BX_to_BLX.patch;apply=yes \
+ file://BX_to_BLX.patch \
"
EXTRA_OECMAKE += "\