aboutsummaryrefslogtreecommitdiffstats
path: root/recipes/lm_sensors
diff options
context:
space:
mode:
authorKhem Raj <raj.khem@gmail.com>2009-10-21 19:57:09 -0700
committerKhem Raj <raj.khem@gmail.com>2009-10-21 21:51:24 -0700
commita9447264efcef76f4e3759c3f61bfd37b89b5337 (patch)
tree617f081f97353de0dc6785262c0fc6f171fcaf30 /recipes/lm_sensors
parent7cb1640b06414ceb10b027fb5aad2f20873c29e0 (diff)
downloadopenembedded-a9447264efcef76f4e3759c3f61bfd37b89b5337.tar.gz
lmsensors-apps_2.10.8.bb: Fix QA error about missing GNU hash
* On ARM because we do not pass EXLDFLAGS in do_install and do_stage we get binaries without .gnu_hash section. Signed-off-by: Khem Raj <raj.khem@gmail.com>
Diffstat (limited to 'recipes/lm_sensors')
-rw-r--r--recipes/lm_sensors/lmsensors-apps_2.10.8.bb5
1 files changed, 3 insertions, 2 deletions
diff --git a/recipes/lm_sensors/lmsensors-apps_2.10.8.bb b/recipes/lm_sensors/lmsensors-apps_2.10.8.bb
index 8947ffb5b3..af58136f2a 100644
--- a/recipes/lm_sensors/lmsensors-apps_2.10.8.bb
+++ b/recipes/lm_sensors/lmsensors-apps_2.10.8.bb
@@ -2,6 +2,7 @@ DESCRIPTION = "Hardware health monitoring applications"
HOMEPAGE = "http://www.lm-sensors.org/"
DEPENDS = "sysfsutils virtual/libiconv"
LICENSE = "GPL"
+PR = "r1"
SRC_URI = "http://dl.lm-sensors.org/lm-sensors/releases/lm_sensors-${PV}.tar.gz \
file://prefix-fix.patch;patch=1 \
@@ -16,7 +17,7 @@ do_compile() {
}
do_install() {
- oe_runmake user_install DESTDIR=${D}
+ oe_runmake user_install EXLDFLAGS="${LDFLAGS}" DESTDIR=${D}
install -d ${D}/.usr
mv ${D}/* ${D}/.usr
@@ -31,7 +32,7 @@ do_install() {
}
do_stage() {
- oe_runmake user_install DESTDIR=${STAGING_DIR_TARGET}/${layout_prefix}
+ oe_runmake user_install EXLDFLAGS="${LDFLAGS}" DESTDIR=${STAGING_DIR_TARGET}/${layout_prefix}
}
PACKAGES =+ "libsensors libsensors-dev libsensors-dbg libsensors-doc"