aboutsummaryrefslogtreecommitdiffstats
path: root/recipes/lmbench
diff options
context:
space:
mode:
authorTom Rini <tom_rini@mentor.com>2010-07-16 10:02:52 -0700
committerTom Rini <tom_rini@mentor.com>2010-07-16 10:02:52 -0700
commit29e63e74ab78d8a69ac555a2223b8f4e1ac65304 (patch)
tree30ec8e2ea06dde3e02a545d617f196e695d38380 /recipes/lmbench
parent99b45920fd400febd21054980f4dfe5ba143e948 (diff)
downloadopenembedded-29e63e74ab78d8a69ac555a2223b8f4e1ac65304.tar.gz
lmbench: Fix builds by pulling in siteinfo stuff
At some point an automatic import of autotools.bbclass was removed. Since we only need CONFIG_SITEINFO, inherit siteinfo and set the variable so we're back to where we were. Signed-off-by: Tom Rini <tom_rini@mentor.com>
Diffstat (limited to 'recipes/lmbench')
-rw-r--r--recipes/lmbench/lmbench_2.0.4.bb6
-rw-r--r--recipes/lmbench/lmbench_2.5.bb6
2 files changed, 12 insertions, 0 deletions
diff --git a/recipes/lmbench/lmbench_2.0.4.bb b/recipes/lmbench/lmbench_2.0.4.bb
index ba96820463..fc6c7a13dc 100644
--- a/recipes/lmbench/lmbench_2.0.4.bb
+++ b/recipes/lmbench/lmbench_2.0.4.bb
@@ -14,6 +14,12 @@ EXTRA_OEMAKE = '"CC=${CC}" "AR=${AR}" "CFLAGS=$CFLAGS" \
"LDFLAGS=${LDFLAGS}" "LD=${LD}" "OS=${TARGET_SYS}" \
"TARGET=${TARGET_OS}" "O=${S}/bin/${TARGET_SYS}"'
+
+inherit siteinfo
+
+# Space separated list of shell scripts with variables defined to supply test
+# results for autoconf tests we cannot run at build time.
+export CONFIG_SITE = "${@siteinfo_get_files(d)}"
python do_unpack () {
bb.build.exec_func('base_do_unpack', d)
bb.build.exec_func('byebk_do_unpack', d)
diff --git a/recipes/lmbench/lmbench_2.5.bb b/recipes/lmbench/lmbench_2.5.bb
index cac96b474e..80f53a8a3f 100644
--- a/recipes/lmbench/lmbench_2.5.bb
+++ b/recipes/lmbench/lmbench_2.5.bb
@@ -13,6 +13,12 @@ EXTRA_OEMAKE = 'CC="${CC}" AR="${AR}" CFLAGS="${CFLAGS}" \
LDFLAGS="${LDFLAGS}" LD="${LD}" OS="${TARGET_SYS}" \
TARGET="${TARGET_OS}" BASE="${prefix}"'
+
+inherit siteinfo
+
+# Space separated list of shell scripts with variables defined to supply test
+# results for autoconf tests we cannot run at build time.
+export CONFIG_SITE = "${@siteinfo_get_files(d)}"
python do_unpack () {
bb.build.exec_func('base_do_unpack', d)
bb.build.exec_func('byebk_do_unpack', d)