summaryrefslogtreecommitdiffstats
path: root/recipes/lmbench
diff options
context:
space:
mode:
authorKoen Kooi <koen@openembedded.org>2010-08-11 15:47:18 +0200
committerKoen Kooi <koen@openembedded.org>2010-08-11 15:47:58 +0200
commit6d5bcdc04df95e18b53480869a0037841ed19e09 (patch)
tree7763d6e7c5c5e36bcc24588836351a4a17e7b91b /recipes/lmbench
parent7751138384b7a2de55c405d2d959ae3cad394c2d (diff)
downloadopenembedded-6d5bcdc04df95e18b53480869a0037841ed19e09.tar.gz
lmbench: fix build
Diffstat (limited to 'recipes/lmbench')
-rw-r--r--recipes/lmbench/lmbench_2.5.bb14
1 files changed, 8 insertions, 6 deletions
diff --git a/recipes/lmbench/lmbench_2.5.bb b/recipes/lmbench/lmbench_2.5.bb
index 80f53a8a3f..de7fc484ad 100644
--- a/recipes/lmbench/lmbench_2.5.bb
+++ b/recipes/lmbench/lmbench_2.5.bb
@@ -2,7 +2,10 @@ SECTION = "console/utils"
DESCRIPTION = "Tools for performance analysis."
LICENSE = "GPL"
RDEPENDS_${PN} = "debianutils"
-PR = "r2"
+
+PR = "r3"
+
+inherit autotools
SRC_URI = "${SOURCEFORGE_MIRROR}/lmbench/lmbench-${PV}.tgz \
file://build.patch \
@@ -14,11 +17,6 @@ EXTRA_OEMAKE = 'CC="${CC}" AR="${AR}" CFLAGS="${CFLAGS}" \
TARGET="${TARGET_OS}" BASE="${prefix}"'
-inherit siteinfo
-
-# Space separated list of shell scripts with variables defined to supply test
-# results for autoconf tests we cannot run at build time.
-export CONFIG_SITE = "${@siteinfo_get_files(d)}"
python do_unpack () {
bb.build.exec_func('base_do_unpack', d)
bb.build.exec_func('byebk_do_unpack', d)
@@ -28,6 +26,10 @@ byebk_do_unpack () {
find ${S}/.. -name BitKeeper -o -name SCCS | xargs rm -rf
}
+do_configure() {
+ :
+}
+
do_compile () {
. ${CONFIG_SITE}
if [ X"$ac_cv_uint" == X"yes" ]; then