aboutsummaryrefslogtreecommitdiffstats
path: root/recipes/lockstat
diff options
context:
space:
mode:
authorDenys Dmytriyenko <denis@denix.org>2009-03-17 14:32:59 -0400
committerDenys Dmytriyenko <denis@denix.org>2009-03-17 14:32:59 -0400
commit709c4d66e0b107ca606941b988bad717c0b45d9b (patch)
tree37ee08b1eb308f3b2b6426d5793545c38396b838 /recipes/lockstat
parentfa6cd5a3b993f16c27de4ff82b42684516d433ba (diff)
downloadopenembedded-709c4d66e0b107ca606941b988bad717c0b45d9b.tar.gz
rename packages/ to recipes/ per earlier agreement
See links below for more details: http://thread.gmane.org/gmane.comp.handhelds.openembedded/21326 http://thread.gmane.org/gmane.comp.handhelds.openembedded/21816 Signed-off-by: Denys Dmytriyenko <denis@denix.org> Acked-by: Mike Westerhof <mwester@dls.net> Acked-by: Philip Balister <philip@balister.org> Acked-by: Khem Raj <raj.khem@gmail.com> Acked-by: Marcin Juszkiewicz <hrw@openembedded.org> Acked-by: Koen Kooi <koen@openembedded.org> Acked-by: Frans Meulenbroeks <fransmeulenbroeks@gmail.com>
Diffstat (limited to 'recipes/lockstat')
-rw-r--r--recipes/lockstat/lockstat_1.4.10.bb25
1 files changed, 25 insertions, 0 deletions
diff --git a/recipes/lockstat/lockstat_1.4.10.bb b/recipes/lockstat/lockstat_1.4.10.bb
new file mode 100644
index 0000000000..ef7254eab3
--- /dev/null
+++ b/recipes/lockstat/lockstat_1.4.10.bb
@@ -0,0 +1,25 @@
+SECTION = "console/utils"
+DESCRIPTION = "A tool for retrieving kernel spinlock metering information."
+DEPENDS = "virtual/kernel"
+
+SRC_URI = "ftp://oss.sgi.com/projects/lockmeter/download/lockstat-${PV}.tar.gz"
+S = "${WORKDIR}/lockstat"
+
+export KERNEL_VERSION = "${@base_read_file('${STAGING_KERNEL_DIR}/kernel-abiversion')}"
+export KERNEL_SOURCE = "${@base_read_file('${STAGING_KERNEL_DIR}/kernel-source')}"
+CFLAGS += " -I${KERNEL_SOURCE}/include"
+
+python () {
+ # NOTE: any target machines with kernels supporting spinlock metering should
+ # check the MACHINE variable here to prevent the SkipPackage.
+ raise bb.parse.SkipPackage("The target machine's kernel does not appear able to use spinlock metering.")
+}
+
+do_compile () {
+ oe_runmake
+}
+
+do_install () {
+ install -d ${D}${sbindir}
+ install -m 0755 lockstat ${D}${sbindir}/
+}