summaryrefslogtreecommitdiffstats
path: root/recipes/loudmouth
diff options
context:
space:
mode:
authorMarcin Juszkiewicz <marcin@juszkiewicz.com.pl>2010-03-08 13:16:10 +0100
committerMarcin Juszkiewicz <marcin@juszkiewicz.com.pl>2010-03-09 18:34:21 +0100
commit52d301bd105351c587fa27b3383d2c229d015d06 (patch)
tree3bd64356011441e5c127ca3d0d6b2a1c8750cd5f /recipes/loudmouth
parentfda4472f284541b5378c87e4b5e8537c5e94069e (diff)
downloadopenembedded-52d301bd105351c587fa27b3383d2c229d015d06.tar.gz
loudmouth: added patch from Debian to use new GnuTLS
Signed-off-by: Marcin Juszkiewicz <marcin@juszkiewicz.com.pl>
Diffstat (limited to 'recipes/loudmouth')
-rw-r--r--recipes/loudmouth/loudmouth-1.4.3/04-use-pkg-config-for-gnutls.patch23
-rw-r--r--recipes/loudmouth/loudmouth_1.4.3.bb8
2 files changed, 26 insertions, 5 deletions
diff --git a/recipes/loudmouth/loudmouth-1.4.3/04-use-pkg-config-for-gnutls.patch b/recipes/loudmouth/loudmouth-1.4.3/04-use-pkg-config-for-gnutls.patch
new file mode 100644
index 0000000000..20f388e890
--- /dev/null
+++ b/recipes/loudmouth/loudmouth-1.4.3/04-use-pkg-config-for-gnutls.patch
@@ -0,0 +1,23 @@
+Description: use pkg-config to detect gnutls
+Debian: http://bugs.debian.org/529835
+Origin: http://groups.google.com/group/loudmouth-dev/browse_thread/thread/3f78255837048daf#
+
+--- a/configure.ac.orig 2009-08-16 20:29:36.000000000 +0200
++++ b/configure.ac 2009-08-16 20:30:43.000000000 +0200
+@@ -146,10 +146,12 @@ AC_ARG_WITH(openssl-libs,
+ enable_ssl=no
+ if test "x$ac_ssl" = "xgnutls"; then
+ dnl Look for GnuTLS
+- AM_PATH_LM_LIBGNUTLS($GNUTLS_REQUIRED, have_libgnutls=yes, have_libgnutls=no)
+- if test "x$have_libgnutls" = "xyes"; then
+- CFLAGS="$CFLAGS $LIBGNUTLS_CFLAGS"
+- LIBS="$LIBS $LIBGNUTLS_LIBS"
++ PKG_CHECK_MODULES(GNUTLS, gnutls >= $GNUTLS_REQUIRED, have_gnutls=yes, have_gnutls=no)
++ if test "x$have_gnutls" = "xyes"; then
++ AC_SUBST(ASYNCNS_CFLAGS)
++ AC_SUBST(ASYNCNS_LIBS)
++ CFLAGS="$CFLAGS $GNUTLS_CFLAGS"
++ LIBS="$LIBS $GNUTLS_LIBS"
+ AC_DEFINE(HAVE_GNUTLS, 1, [whether to use GnuTSL support.])
+ enable_ssl=GnuTLS
+ else
diff --git a/recipes/loudmouth/loudmouth_1.4.3.bb b/recipes/loudmouth/loudmouth_1.4.3.bb
index d8f519b611..ecd9419069 100644
--- a/recipes/loudmouth/loudmouth_1.4.3.bb
+++ b/recipes/loudmouth/loudmouth_1.4.3.bb
@@ -2,11 +2,9 @@ DESCRIPTION = "Loudmouth is a lightweight and easy-to-use C library for programm
HOMEPAGE = "http://www.loudmouth-project.org/"
LICENSE = "LGPL"
DEPENDS = "glib-2.0 gnutls check"
+PR = "r1"
-SRC_URI = "http://ftp.imendio.com/pub/imendio/${PN}/src/${PN}-${PV}.tar.gz"
+SRC_URI = "http://ftp.imendio.com/pub/imendio/${PN}/src/${PN}-${PV}.tar.gz \
+ file://04-use-pkg-config-for-gnutls.patch;patch=1"
inherit autotools pkgconfig
-
-do_stage() {
- autotools_stage_all
-}