summaryrefslogtreecommitdiffstats
path: root/recipes/lowpan-tools
diff options
context:
space:
mode:
authorDmitry Eremin-Solenikov <dbaryshkov@gmail.com>2010-06-16 01:18:46 +0400
committerDmitry Eremin-Solenikov <dbaryshkov@gmail.com>2010-06-16 02:38:52 +0400
commit024ce7a16f931d73886d94d75471c04f04697bdb (patch)
tree298143d95b9aef020f1c8ee938ace6cc75796a18 /recipes/lowpan-tools
parent4721a472806d2eb92562e45231288494fad2976f (diff)
downloadopenembedded-024ce7a16f931d73886d94d75471c04f04697bdb.tar.gz
lowpan-tools: add 0.2.1 release
Signed-off-by: Dmitry Eremin-Solenikov <dbaryshkov@gmail.com>
Diffstat (limited to 'recipes/lowpan-tools')
-rw-r--r--recipes/lowpan-tools/lowpan-tools.inc20
-rw-r--r--recipes/lowpan-tools/lowpan-tools_0.2.1.bb8
-rw-r--r--recipes/lowpan-tools/lowpan-tools_git.bb22
3 files changed, 33 insertions, 17 deletions
diff --git a/recipes/lowpan-tools/lowpan-tools.inc b/recipes/lowpan-tools/lowpan-tools.inc
new file mode 100644
index 0000000000..6afcc9c7b4
--- /dev/null
+++ b/recipes/lowpan-tools/lowpan-tools.inc
@@ -0,0 +1,20 @@
+DESCRIPTION = "LoWPAN utilities (IEEE802.15.4)"
+LICENSE = "GPLv2"
+DEPENDS = "libnl bison-native flex-native python-native"
+INC_PR = "r11"
+
+SRC_URI = "http://prdownloads.sourceforge.net/linux-zigbee/linux-zigbee-sources/${PV}/lowpan-tools-${PV}.tar.gz"
+
+PACKAGES += "${PN}-tests-dbg"
+PACKAGES += "${PN}-tests"
+FILES_${PN} = "${sbindir}/iz ${sbindir}/izconfig \
+ ${bindir}/izchat ${bindir}/izlisten ${sbindir}/izcoordinator \
+ ${sbindir}/izattach ${libdir}/ip/link_wpan.so"
+FILES_${PN}-dbg += "${libdir}/ip/.debug/link_wpan.so"
+FILES_${PN}-tests = "${libexecdir}/lowpan-tools ${PYTHON_SITEPACKAGES_DIR}"
+FILES_${PN}-tests-dbg = "${libexecdir}/lowpan-tools/.debug"
+RDEPENDS_${PN}-tests += "${PN} python-core"
+
+EXTRA_OECONF = "--disable-manpages"
+
+inherit autotools_stage python-dir
diff --git a/recipes/lowpan-tools/lowpan-tools_0.2.1.bb b/recipes/lowpan-tools/lowpan-tools_0.2.1.bb
new file mode 100644
index 0000000000..9d66a4cf52
--- /dev/null
+++ b/recipes/lowpan-tools/lowpan-tools_0.2.1.bb
@@ -0,0 +1,8 @@
+require lowpan-tools.inc
+
+PR = "${INC_PR}.0"
+
+EXTRA_OECONF = "--enable-ip-plugin"
+
+SRC_URI[md5sum] = "e2fa536e8b6402a88fcb98fe3296fe46"
+SRC_URI[sha256sum] = "f72dd915503803b02104abfd29a4b00216af471c11b2aec44c51b9cf4c5e618b"
diff --git a/recipes/lowpan-tools/lowpan-tools_git.bb b/recipes/lowpan-tools/lowpan-tools_git.bb
index 49ba84ed7a..b4a8983c8d 100644
--- a/recipes/lowpan-tools/lowpan-tools_git.bb
+++ b/recipes/lowpan-tools/lowpan-tools_git.bb
@@ -1,21 +1,9 @@
-DESCRIPTION = "LoWPAN utilities (IEEE802.15.4)"
-LICENSE = "GPL"
+require lowpan-tools.inc
+
+DEFAULT_PREFERENCE = "-1"
+
SRCREV = "a38879e4d5bc9795ebbf18d08ec4c533331efb66"
SRC_URI = "git://linux-zigbee.git.sourceforge.net/gitroot/linux-zigbee/linux-zigbee;protocol=git"
-DEPENDS = "libnl bison-native flex-native python-native"
-PR = "r11"
+PR = "${INC_PR}.0"
S = "${WORKDIR}/git"
-PACKAGES += "${PN}-tests-dbg"
-PACKAGES += "${PN}-tests"
-FILES_${PN} = "${sbindir}/iz ${sbindir}/izconfig \
- ${bindir}/izchat ${bindir}/izlisten ${sbindir}/izcoordinator \
- ${sbindir}/izattach ${libdir}/ip/link_wpan.so"
-FILES_${PN}-dbg += "${libdir}/ip/.debug/link_wpan.so"
-FILES_${PN}-tests = "${libexecdir}/lowpan-tools ${PYTHON_SITEPACKAGES_DIR}"
-FILES_${PN}-tests-dbg = "${libexecdir}/lowpan-tools/.debug"
-RDEPENDS_${PN}-tests += "${PN} python-core"
-
-EXTRA_OECONF = "--disable-manpages"
-
-inherit autotools_stage python-dir