summaryrefslogtreecommitdiffstats
path: root/recipes/lowpan-tools
diff options
context:
space:
mode:
authorDmitry Eremin-Solenikov <dbaryshkov@gmail.com>2009-05-25 16:46:13 +0400
committerDmitry Eremin-Solenikov <dbaryshkov@gmail.com>2009-05-25 16:46:13 +0400
commit9da5f51503ce6a0c9b8a0f5e6068c6fa19d44049 (patch)
tree96e8380ad6a0cc9977679517451937a9ad4ae3bf /recipes/lowpan-tools
parent44eb0c3efd56414c6fad6e2c2ea18a0c0e40d086 (diff)
downloadopenembedded-9da5f51503ce6a0c9b8a0f5e6068c6fa19d44049.tar.gz
lowpan-tools: fix building
1) upstream has changed naming to be 'lowpan-tools' instead of 'lowpan-utils' 2) bump git revision (and thus PR) to use upstream fix for supporting installation w/o manpages and add '--disable-manpages' to EXTRA_OECONF Signed-off-by: Dmitry Eremin-Solenikov <dbaryshkov@gmail.com>
Diffstat (limited to 'recipes/lowpan-tools')
-rw-r--r--recipes/lowpan-tools/lowpan-tools_git.bb20
1 files changed, 20 insertions, 0 deletions
diff --git a/recipes/lowpan-tools/lowpan-tools_git.bb b/recipes/lowpan-tools/lowpan-tools_git.bb
new file mode 100644
index 0000000000..1fde23218d
--- /dev/null
+++ b/recipes/lowpan-tools/lowpan-tools_git.bb
@@ -0,0 +1,20 @@
+DESCRIPTION = "LoWPAN utilities (IEEE802.15.4)"
+LICENSE = "GPL"
+SRCREV = "e9e80a2eefa7aadbbb15bef1519b373e2e907aa0"
+#SRC_URI = "git://github.com/lumag/lowpan-utils.git;protocol=git"
+SRC_URI = "git://linux-zigbee.git.sourceforge.net/gitroot/linux-zigbee;protocol=git"
+DEPENDS = "libnl bison-native flex-native"
+PR = "r6"
+
+S = "${WORKDIR}/git"
+PACKAGES += "${PN}-tests-dbg"
+PACKAGES += "${PN}-tests"
+FILES_${PN} = "${sbindir}/iz ${sbindir}/izconfig \
+ ${bindir}/izchat ${bindir}/izlisten ${sbindir}/izcoordinator \
+ ${sbindir}/izattach"
+FILES_${PN}-tests = "${libexecdir}/lowpan-tools ${libdir}/python*/site-packages"
+FILES_${PN}-tests-dbg = "${libexecdir}/lowpan-tools/.debug"
+
+EXTRA_OECONF = "--disable-manpages"
+
+inherit autotools_stage