aboutsummaryrefslogtreecommitdiffstats
path: root/recipes/lsh
diff options
context:
space:
mode:
authorDenys Dmytriyenko <denis@denix.org>2009-03-17 14:32:59 -0400
committerDenys Dmytriyenko <denis@denix.org>2009-03-17 14:32:59 -0400
commit709c4d66e0b107ca606941b988bad717c0b45d9b (patch)
tree37ee08b1eb308f3b2b6426d5793545c38396b838 /recipes/lsh
parentfa6cd5a3b993f16c27de4ff82b42684516d433ba (diff)
downloadopenembedded-709c4d66e0b107ca606941b988bad717c0b45d9b.tar.gz
rename packages/ to recipes/ per earlier agreement
See links below for more details: http://thread.gmane.org/gmane.comp.handhelds.openembedded/21326 http://thread.gmane.org/gmane.comp.handhelds.openembedded/21816 Signed-off-by: Denys Dmytriyenko <denis@denix.org> Acked-by: Mike Westerhof <mwester@dls.net> Acked-by: Philip Balister <philip@balister.org> Acked-by: Khem Raj <raj.khem@gmail.com> Acked-by: Marcin Juszkiewicz <hrw@openembedded.org> Acked-by: Koen Kooi <koen@openembedded.org> Acked-by: Frans Meulenbroeks <fransmeulenbroeks@gmail.com>
Diffstat (limited to 'recipes/lsh')
-rw-r--r--recipes/lsh/lsh_1.5.5.bb35
1 files changed, 35 insertions, 0 deletions
diff --git a/recipes/lsh/lsh_1.5.5.bb b/recipes/lsh/lsh_1.5.5.bb
new file mode 100644
index 0000000000..284a0100eb
--- /dev/null
+++ b/recipes/lsh/lsh_1.5.5.bb
@@ -0,0 +1,35 @@
+LICENSE = "GPL"
+SECTION = "console/network"
+DESCRIPTION = "lsh is a GNU GPL-licensed implementation of the SSH \
+(version 2) protocol. It includes a server, a client, and some \
+utility programs."
+DEPENDS = "zlib gmp liboop"
+
+SRC_URI = "http://www.lysator.liu.se/~nisse/archive/lsh-${PV}.tar.gz"
+S = "${WORKDIR}/lsh-${PV}"
+
+inherit autotools
+configopts = " --enable-debug-alloc Enable memory allocation sanity checks \
+ --enable-debug-trace Enable tracing support \
+ --enable-gcov Instrument for gcov (requires a modern gcc) \
+ --without-pty Disable pty support \
+ --disable-srp Disable the (experimental) support for SRP \
+ --disable-kerberos Don't support kerberos \
+ --disable-pam Don't support PAM \
+ --disable-datafellows-workarounds \
+ --enable-initgroups-workaround \
+ --disable-tcp-forward Disable tcp forwarding \
+ --disable-x11-forward Disable x11 forwarding (proxy only) \
+ --disable-agent-forward Disable auth-agent forwarding (proxy only) \
+ --disable-ipv6 Disable IPv6 support \
+ --disable-utmp Disable utmp and wtmp support \
+ --without-zlib Don't use zlib compression \
+ --with-tcpwrappers Use tcp-wrappers for filtering connections \
+ --with-sshd1=PROGRAM support fallback to SSH1 daemon \
+ --with-scheme=PROGRAM Use a particular scheme implementation \
+ --without-system-argp Don't use the system's argp \
+ --with-include-path A colon-separated list of directories to search for \
+ --with-lib-path A colon-separated list of directories to search for \
+ --with-x use the X Window System"
+EXTRA_OECONF = "--disable-srp --disable-kerberos --disable-pam \
+ --without-x"