summaryrefslogtreecommitdiffstats
path: root/recipes/lsof
diff options
context:
space:
mode:
authorGraham Gower <graham.gower@gmail.com>2010-07-15 14:07:51 +0000
committerStefan Schmidt <stefan@datenfreihafen.org>2010-07-16 11:52:07 +0200
commite2cd1d0756f2d228a64d280afe1b064c27a8aa96 (patch)
treef95d11fd0cc4877e52ae350f3d3a4b00e1225815 /recipes/lsof
parent0f889c153109cc2877cf3ae87f68bafa32c3d5f3 (diff)
downloadopenembedded-e2cd1d0756f2d228a64d280afe1b064c27a8aa96.tar.gz
lsof_4.83.bb: Make recipe buildable again.
Breakage introduced by 74e32f114272668dfa4c88805741cf55ef965989. Other recipes which call base_do_unpack directly do not share this issue. Signed-off-by: Graham Gower <graham.gower@gmail.com> Acked-by: Stefan Schmidt <stefan@datenfreihafen.org>
Diffstat (limited to 'recipes/lsof')
-rw-r--r--recipes/lsof/lsof_4.83.bb13
1 files changed, 5 insertions, 8 deletions
diff --git a/recipes/lsof/lsof_4.83.bb b/recipes/lsof/lsof_4.83.bb
index d74c574a33..0a5d557fbd 100644
--- a/recipes/lsof/lsof_4.83.bb
+++ b/recipes/lsof/lsof_4.83.bb
@@ -9,17 +9,14 @@ SRC_URI = "ftp://lsof.itap.purdue.edu/pub/tools/unix/lsof/lsof_${PV}.tar.bz2;nam
SRC_URI[lsof483tarbz2.md5sum] = "8f731a6251b8c0143d585df0d5ca779e"
SRC_URI[lsof483tarbz2.sha256sum] = "b89f930bbe36b970e3cd070b9860ee701d8c7285ffedf2fbcec0e5fa3cb1f544"
-LOCALSRC = "file://${WORKDIR}/lsof_${PV}/lsof_${PV}_src.tar"
+LOCALSRC = "${WORKDIR}/lsof_${PV}/lsof_${PV}_src.tar"
S = "${WORKDIR}/lsof_${PV}_src"
-# the tar.bz2 file contains another tar, cde below unpacks it
-python do_unpack () {
- bb.build.exec_func('base_do_unpack', d)
- src_uri = bb.data.getVar('SRC_URI', d)
- bb.data.setVar('SRC_URI', '${LOCALSRC}', d)
- bb.build.exec_func('base_do_unpack', d)
- bb.data.setVar('SRC_URI', src_uri, d)
+# The tar.bz2 file contains another tar.
+do_unpackpost() {
+ tar x --no-same-owner -f ${LOCALSRC} -C ${WORKDIR}
}
+addtask do_unpackpost before do_patch after do_unpack
export LSOF_OS = "${TARGET_OS}"
LSOF_OS_linux-uclibc = "linux"