aboutsummaryrefslogtreecommitdiffstats
path: root/recipes/ltp/ltp-20080229
diff options
context:
space:
mode:
authorDenys Dmytriyenko <denis@denix.org>2009-03-17 14:32:59 -0400
committerDenys Dmytriyenko <denis@denix.org>2009-03-17 14:32:59 -0400
commit709c4d66e0b107ca606941b988bad717c0b45d9b (patch)
tree37ee08b1eb308f3b2b6426d5793545c38396b838 /recipes/ltp/ltp-20080229
parentfa6cd5a3b993f16c27de4ff82b42684516d433ba (diff)
downloadopenembedded-709c4d66e0b107ca606941b988bad717c0b45d9b.tar.gz
rename packages/ to recipes/ per earlier agreement
See links below for more details: http://thread.gmane.org/gmane.comp.handhelds.openembedded/21326 http://thread.gmane.org/gmane.comp.handhelds.openembedded/21816 Signed-off-by: Denys Dmytriyenko <denis@denix.org> Acked-by: Mike Westerhof <mwester@dls.net> Acked-by: Philip Balister <philip@balister.org> Acked-by: Khem Raj <raj.khem@gmail.com> Acked-by: Marcin Juszkiewicz <hrw@openembedded.org> Acked-by: Koen Kooi <koen@openembedded.org> Acked-by: Frans Meulenbroeks <fransmeulenbroeks@gmail.com>
Diffstat (limited to 'recipes/ltp/ltp-20080229')
-rw-r--r--recipes/ltp/ltp-20080229/ballista.patch22
-rw-r--r--recipes/ltp/ltp-20080229/cross-compile.patch57
-rw-r--r--recipes/ltp/ltp-20080229/ltp-run4
-rw-r--r--recipes/ltp/ltp-20080229/posix_shell_compat.patch33
-rw-r--r--recipes/ltp/ltp-20080229/runltp-path.patch24
5 files changed, 140 insertions, 0 deletions
diff --git a/recipes/ltp/ltp-20080229/ballista.patch b/recipes/ltp/ltp-20080229/ballista.patch
new file mode 100644
index 0000000000..d318480208
--- /dev/null
+++ b/recipes/ltp/ltp-20080229/ballista.patch
@@ -0,0 +1,22 @@
+Index: ltp-full-20080229/testcases/ballista/Makefile
+===================================================================
+--- ltp-full-20080229.orig/testcases/ballista/Makefile 2008-02-29 08:55:46.000000000 +0100
++++ ltp-full-20080229/testcases/ballista/Makefile 2008-03-01 01:21:16.000000000 +0100
+@@ -1,4 +1,4 @@
+-ifeq ($(shell perl -v &> /dev/null && echo yes),yes)
++ifeq ($(shell perl -v > /dev/null && echo yes),yes)
+
+ all: bal
+
+Index: ltp-full-20080229/testcases/ballista/ballista/Makefile
+===================================================================
+--- ltp-full-20080229.orig/testcases/ballista/ballista/Makefile 2008-03-01 01:21:16.000000000 +0100
++++ ltp-full-20080229/testcases/ballista/ballista/Makefile 2008-03-01 01:22:22.000000000 +0100
+@@ -37,6 +37,7 @@
+
+ # build everything by default
+ all : callGen callGen_standAlone genCodeCreator replacer ballista
++ rm blexer bparser mut.out
+
+ # run-of-of-the-mill rules for utility programs
+ callGen: callGen.cpp
diff --git a/recipes/ltp/ltp-20080229/cross-compile.patch b/recipes/ltp/ltp-20080229/cross-compile.patch
new file mode 100644
index 0000000000..456bf4f135
--- /dev/null
+++ b/recipes/ltp/ltp-20080229/cross-compile.patch
@@ -0,0 +1,57 @@
+Index: ltp-full-20080229/Makefile
+===================================================================
+--- ltp-full-20080229.orig/Makefile 2008-02-29 08:55:41.000000000 +0100
++++ ltp-full-20080229/Makefile 2008-03-01 01:14:35.000000000 +0100
+@@ -33,11 +33,12 @@
+ endif
+ ifdef CROSS_COMPILER
+ CC=$(CROSS_COMPILER)gcc
++CPP=$(CROSS_COMPILER)g++
+ AR=$(CROSS_COMPILER)ar
+ endif
+
+ export CFLAGS += -Wall $(CROSS_CFLAGS)
+-export CC AR LDFLAGS
++export CC AR LDFLAGS CPP
+
+ -include config.mk
+
+Index: ltp-full-20080229/testcases/ballista/ballista/Makefile
+===================================================================
+--- ltp-full-20080229.orig/testcases/ballista/ballista/Makefile 2008-02-29 08:55:46.000000000 +0100
++++ ltp-full-20080229/testcases/ballista/ballista/Makefile 2008-03-01 01:14:35.000000000 +0100
+@@ -24,7 +24,7 @@
+ ########################
+
+ # compiler info for the host
+-CC = g++ -Wno-deprecated
++CC = $(CPP) -Wno-deprecated
+ CFLAGS = -w -O ${TARGET_DEF}
+ CLIBS = -lpthread -ldl -lnsl -rdynamic
+ TEST_MAN_FILE = selfHost
+Index: ltp-full-20080229/testcases/kernel/security/filecaps/Makefile
+===================================================================
+--- ltp-full-20080229.orig/testcases/kernel/security/filecaps/Makefile 2008-03-01 01:14:49.000000000 +0100
++++ ltp-full-20080229/testcases/kernel/security/filecaps/Makefile 2008-03-01 01:15:05.000000000 +0100
+@@ -20,7 +20,6 @@
+
+ SCRIPTS = filecapstest.sh checkforlibcap.sh checkforfilecaps.sh
+ ifeq ($(shell sh checkforlibcap.sh yesno),yes)
+-CC=gcc
+
+ CFLAGS += -I../../../../include -Wall
+ LDLIBS += -L../../../../lib -lltp -lcap
+@@ -29,11 +28,11 @@
+ TARGETS = $(patsubst %.c,%,$(SRCS))
+ INSTALLTARGETS = $(TARGETS) $(SCRIPTS)
+ all: $(TARGETS)
+- gcc -o checkforlibcap gotlibcap.c
++ $(CC) -o checkforlibcap gotlibcap.c
+ else
+ all:
+ @echo "setcap or xattr headers not installed. Please install libcap from"; echo "ftp://ftp.kernel.org/pub/linux/libs/security/linux-privs/libcap2"; echo "Then make clean in ltp or ltp/testcases/kernel/security/filecaps, and recompile ltp."
+- gcc -o checkforlibcap nolibcap.c
++ $(CC) -o checkforlibcap nolibcap.c
+ TARGETS =
+ endif
+
diff --git a/recipes/ltp/ltp-20080229/ltp-run b/recipes/ltp/ltp-20080229/ltp-run
new file mode 100644
index 0000000000..5d97f00532
--- /dev/null
+++ b/recipes/ltp/ltp-20080229/ltp-run
@@ -0,0 +1,4 @@
+#!/bin/sh
+/usr/libexec/ltp/runltp -t 180s > /home/root/testlog.txt
+echo "Benchmark run finished...."
+touch /home/root/testfinished.flag
diff --git a/recipes/ltp/ltp-20080229/posix_shell_compat.patch b/recipes/ltp/ltp-20080229/posix_shell_compat.patch
new file mode 100644
index 0000000000..b88d598deb
--- /dev/null
+++ b/recipes/ltp/ltp-20080229/posix_shell_compat.patch
@@ -0,0 +1,33 @@
+Index: ltp-full-20080229/testcases/network/generate.sh
+===================================================================
+--- ltp-full-20080229.orig/testcases/network/generate.sh 2008-03-01 00:34:24.000000000 +0100
++++ ltp-full-20080229/testcases/network/generate.sh 2008-03-01 00:35:13.000000000 +0100
+@@ -53,22 +53,24 @@
+ $makeit $data_dir/$jumbo_file $jumbo_size
+
+ if [ ! -e $data_dir/bin.sm ] ; then
+- cnt=6
+- while [ $((cnt=cnt-1)) -ge 0 ] ; do
++ cnt=5
++ while [ $cnt -ge 0 ] ; do
+ gzip -1 -c datafiles/ascii.sm >> $data_dir/bin.sm
++ cnt=$(($cnt-1))
+ done
+ fi
+
+ genfile() {
+ local input=$data_dir/$1 output=$data_dir/$2
+- local cnt=20
++ local cnt=19
+
+ if [ -e $output ] ; then
+ return 0
+ fi
+
+- while [ $((cnt=cnt-1)) -ge 0 ] ; do
++ while [ $cnt -ge 0 ] ; do
+ cat $input >> $output
++ cnt=$(($cnt-1))
+ done
+ }
+
diff --git a/recipes/ltp/ltp-20080229/runltp-path.patch b/recipes/ltp/ltp-20080229/runltp-path.patch
new file mode 100644
index 0000000000..d117b3c24e
--- /dev/null
+++ b/recipes/ltp/ltp-20080229/runltp-path.patch
@@ -0,0 +1,24 @@
+Index: runltp
+===================================================================
+--- ltp-full-20060412.orig/runltp 2005-03-12 03:26:14.000000000 +0800
++++ ltp-full-20060412/runltp 2006-04-26 16:42:13.000000000 +0800
+@@ -43,7 +43,7 @@
+ echo "FATAL: unable to change directory to $(dirname $0)"
+ exit 1
+ }
+- export LTPROOT=${PWD}
++ export LTPROOT=/usr/libexec/ltp
+ export TMPBASE="/tmp"
+ export TMP="${TMPBASE}/ltp-$$"
+ export PATH="${PATH}:${LTPROOT}/testcases/bin"
+--- ltp-full-20060412.orig/runltp 2007-02-28 20:40:17.000000000 -0800
++++ ltp-full-20060412/runltp 2007-04-01 11:38:38.000000000 -0700
+@@ -285,7 +285,7 @@
+ ${LTPROOT}/runtest/sched ${LTPROOT}/runtest/math \
+ ${LTPROOT}/runtest/nptl ${LTPROOT}/runtest/pty
+ do
+- [ -a "$SCENFILES" ] || \
++ [ -e "$SCENFILES" ] || \
+ {
+ echo "FATAL: missing scenario file $SCENFILES"
+ exit 1