aboutsummaryrefslogtreecommitdiffstats
path: root/recipes/ltp/ltp_20090131.bb
diff options
context:
space:
mode:
authorLeon Woestenberg <leon@sidebranch.com>2009-03-29 17:14:51 +0200
committerLeon Woestenberg <leon@sidebranch.com>2009-03-29 17:16:42 +0200
commitc9960f76ceaa781f3f8782c75963a9f93f52b1fc (patch)
treefc40e40a06c8c7fff1ff196c64f70c667cd1421b /recipes/ltp/ltp_20090131.bb
parent75b5212beab22ab222128726b7942160de572444 (diff)
downloadopenembedded-c9960f76ceaa781f3f8782c75963a9f93f52b1fc.tar.gz
ltp: Fix two QA issues; .debug leak and GNU_HASH.
Thanks to Koen for the hint on GNU_HASH.
Diffstat (limited to 'recipes/ltp/ltp_20090131.bb')
-rw-r--r--recipes/ltp/ltp_20090131.bb27
1 files changed, 8 insertions, 19 deletions
diff --git a/recipes/ltp/ltp_20090131.bb b/recipes/ltp/ltp_20090131.bb
index 9026ac5081..61775cf753 100644
--- a/recipes/ltp/ltp_20090131.bb
+++ b/recipes/ltp/ltp_20090131.bb
@@ -3,7 +3,7 @@ HOMEPAGE = "http://ltp.sourceforge.net"
LICENSE = "GPL"
SECTION = "console/utils"
DEPENDS = "zip-native"
-PR = "r2"
+PR = "r3"
inherit autotools
@@ -21,28 +21,17 @@ S = "${WORKDIR}/ltp-full-${PV}"
EXTRA_OEMAKE_append = " CROSS_COMPILE=${HOST_PREFIX}"
-FILES_${PN}-dbg = "${libexecdir}/ltp/*/*/*/*/*/.debug"
+FILES_${PN}-dbg = "${libexecdir}/ltp/*/*/*/*/*/*/*/*/*/.debug"
+FILES_${PN}-dbg += "${libexecdir}/ltp/*/*/*/*/*/*/*/*/.debug"
+FILES_${PN}-dbg += "${libexecdir}/ltp/*/*/*/*/*/*/*/.debug"
+FILES_${PN}-dbg += "${libexecdir}/ltp/*/*/*/*/*/*/.debug"
+FILES_${PN}-dbg += "${libexecdir}/ltp/*/*/*/*/*/.debug"
FILES_${PN}-dbg += "${libexecdir}/ltp/*/*/*/*/.debug"
FILES_${PN}-dbg += "${libexecdir}/ltp/*/*/*/.debug"
FILES_${PN}-dbg += "${libexecdir}/ltp/*/*/.debug"
FILES_${PN}-dbg += "${libexecdir}/ltp/*/.debug"
-#FILES_${PN}-dbg += "${libexecdir}/ltp/testcases/misc/math/float/trigo/.debug"
-#FILES_${PN}-dbg += "${libexecdir}/ltp/testcases/misc/math/float/iperb/.debug"
-#FILES_${PN}-dbg += "${libexecdir}/ltp/testcases/misc/math/float/exp_log/.debug"
-#FILES_${PN}-dbg += "${libexecdir}/ltp/testcases/misc/math/float/power/.debug"
-#FILES_${PN}-dbg += "${libexecdir}/ltp/testcases/misc/math/float/bessel/.debug"
-#FILES_${PN}-dbg += "${libexecdir}/ltp/testcases/misc/math/abs/.debug"
-#FILES_${PN}-dbg += "${libexecdir}/ltp/testcases/misc/math/atof/.debug"
-#FILES_${PN}-dbg += "${libexecdir}/ltp/testcases/misc/math/nextafter/.debug"
-#FILES_${PN}-dbg += "${libexecdir}/ltp/testcases/misc/math/fptests/.debug"
-#FILES_${PN}-dbg += "${libexecdir}/ltp/testcases/misc/f00f/.debug"
-#FILES_${PN}-dbg += "${libexecdir}/ltp/testcases/misc/crash/.debug"
-#FILES_${PN}-dbg += "${libexecdir}/ltp/pan/.debug"
-#FILES_${PN}-dbg += "${libexecdir}/ltp/testcases/network/ipv6/*/.debug"
-#FILES_${PN}-dbg += "${libexecdir}/ltp/testcases/network/rpc/rpc01/.debug"
-#FILES_${PN}-dbg += "${libexecdir}/ltp/testcases/bin/.debug"
-#FILES_${PN}-dbg += "${libexecdir}/ltp/testcases/kernel/syscalls/*/.debug"
-#FILES_${PN}-dbg += "${libexecdir}/ltp/testcases/kernel/mem/*/.debug"
+
+TARGET_CC_ARCH += "${LDFLAGS}"
do_compile(){
oe_runmake CROSS_COMPILE=${HOST_PREFIX}