aboutsummaryrefslogtreecommitdiffstats
path: root/recipes/ltrace/ltrace_0.5.3.bb
diff options
context:
space:
mode:
authorMichael 'Mickey' Lauer <mickey@vanille-media.de>2009-11-15 11:08:43 +0100
committerMichael 'Mickey' Lauer <mickey@vanille-media.de>2009-11-15 11:08:43 +0100
commit7df40b3378412f4700224e44042656159bc8f86c (patch)
treebb0d5a6ea7ab486e3db1638217744734600d4fa4 /recipes/ltrace/ltrace_0.5.3.bb
parent5034d680a5eabbc3f92eecb2fc489100e145b058 (diff)
downloadopenembedded-7df40b3378412f4700224e44042656159bc8f86c.tar.gz
ltrace: fix wrong path to coreutils-native and add actual dependency
Diffstat (limited to 'recipes/ltrace/ltrace_0.5.3.bb')
-rw-r--r--recipes/ltrace/ltrace_0.5.3.bb21
1 files changed, 11 insertions, 10 deletions
diff --git a/recipes/ltrace/ltrace_0.5.3.bb b/recipes/ltrace/ltrace_0.5.3.bb
index 050a023159..9296510f7d 100644
--- a/recipes/ltrace/ltrace_0.5.3.bb
+++ b/recipes/ltrace/ltrace_0.5.3.bb
@@ -1,17 +1,18 @@
DESCRIPTION = "ltrace shows runtime library call information for dynamically linked executables."
HOMEPAGE = "http://ltrace.alioth.debian.org"
SECTION = "devel"
-DEPENDS = "libelf"
+DEPENDS = "coreutils-native libelf"
LICENSE = "GPLv2"
-SRC_URI = "${DEBIAN_MIRROR}/main/l/ltrace/ltrace_${PV}.orig.tar.gz \
- ${DEBIAN_MIRROR}/main/l/ltrace/ltrace_${PV}-2.diff.gz;patch=1 \
- file://add-sysdep.patch;patch=1 \
- file://ltrace-compile.patch;patch=1 \
- file://ltrace-mips-remove-CP.patch;patch=1 \
- file://ltrace-mips.patch;patch=1 \
- file://ltrace-ppc.patch;patch=1 \
- "
+SRC_URI = "\
+ ${DEBIAN_MIRROR}/main/l/ltrace/ltrace_${PV}.orig.tar.gz \
+ ${DEBIAN_MIRROR}/main/l/ltrace/ltrace_${PV}-2.diff.gz;patch=1 \
+ file://add-sysdep.patch;patch=1 \
+ file://ltrace-compile.patch;patch=1 \
+ file://ltrace-mips-remove-CP.patch;patch=1 \
+ file://ltrace-mips.patch;patch=1 \
+ file://ltrace-ppc.patch;patch=1 \
+"
inherit autotools
PARALLEL_MAKE = ""
@@ -70,5 +71,5 @@ do_install() {
sparc*) LTRACE_ARCH=sparc ;;
x86_64*) LTRACE_ARCH=x86_64 ;;
esac
- oe_runmake install ${EXTRA_OEMAKE} ARCH=${LTRACE_ARCH} INSTALL=${STAGING_BINDIR_NATIVE}/install DESTDIR=${D}
+ oe_runmake install ${EXTRA_OEMAKE} ARCH=${LTRACE_ARCH} INSTALL=${STAGING_BINDIR_NATIVE}/install.coreutils-native DESTDIR=${D}
}