summaryrefslogtreecommitdiffstats
path: root/recipes/lua/lua5.1_5.1.4.bb
diff options
context:
space:
mode:
authorDenys Dmytriyenko <denis@denix.org>2009-03-17 14:32:59 -0400
committerDenys Dmytriyenko <denis@denix.org>2009-03-17 14:32:59 -0400
commit709c4d66e0b107ca606941b988bad717c0b45d9b (patch)
tree37ee08b1eb308f3b2b6426d5793545c38396b838 /recipes/lua/lua5.1_5.1.4.bb
parentfa6cd5a3b993f16c27de4ff82b42684516d433ba (diff)
downloadopenembedded-709c4d66e0b107ca606941b988bad717c0b45d9b.tar.gz
rename packages/ to recipes/ per earlier agreement
See links below for more details: http://thread.gmane.org/gmane.comp.handhelds.openembedded/21326 http://thread.gmane.org/gmane.comp.handhelds.openembedded/21816 Signed-off-by: Denys Dmytriyenko <denis@denix.org> Acked-by: Mike Westerhof <mwester@dls.net> Acked-by: Philip Balister <philip@balister.org> Acked-by: Khem Raj <raj.khem@gmail.com> Acked-by: Marcin Juszkiewicz <hrw@openembedded.org> Acked-by: Koen Kooi <koen@openembedded.org> Acked-by: Frans Meulenbroeks <fransmeulenbroeks@gmail.com>
Diffstat (limited to 'recipes/lua/lua5.1_5.1.4.bb')
-rw-r--r--recipes/lua/lua5.1_5.1.4.bb37
1 files changed, 37 insertions, 0 deletions
diff --git a/recipes/lua/lua5.1_5.1.4.bb b/recipes/lua/lua5.1_5.1.4.bb
new file mode 100644
index 0000000000..b9d26518b2
--- /dev/null
+++ b/recipes/lua/lua5.1_5.1.4.bb
@@ -0,0 +1,37 @@
+DESCRIPTION = "Lua is a powerful light-weight programming language designed \
+for extending applications."
+LICENSE = "MIT"
+HOMEPAGE = "http://www.lua.org/"
+
+DEPENDS += "readline"
+PR = "r0"
+SRC_URI = "http://www.lua.org/ftp/lua-${PV}.tar.gz \
+ file://makefile.patch;patch=1 \
+ file://lua5.1.pc"
+S = "${WORKDIR}/lua-${PV}"
+
+inherit binconfig
+
+EXTRA_OEMAKE = "'CC=${CC}' 'MYCFLAGS=${CFLAGS}' 'MYLDFLAGS=${LDFLAGS}'"
+
+do_compile () {
+ oe_runmake linux
+}
+
+do_stage () {
+ oe_libinstall -C src liblua5.1 ${STAGING_LIBDIR}/
+ install -d ${STAGING_INCDIR}/lua5.1
+ install -m 0644 src/lua.h src/luaconf.h src/lualib.h src/lauxlib.h ${STAGING_INCDIR}/lua5.1
+ install -m 0644 ${WORKDIR}/lua5.1.pc ${STAGING_LIBDIR}/pkgconfig/
+}
+
+do_install () {
+ oe_runmake \
+ 'INSTALL_TOP=${D}${prefix}' \
+ 'INSTALL_BIN=${D}${bindir}' \
+ 'INSTALL_INC=${D}${includedir}/lua5.1' \
+ 'INSTALL_MAN=${D}${mandir}/man1' \
+ 'INSTALL_SHARE=${D}${datadir}/lua' \
+ install
+}
+